]> git.pld-linux.org Git - packages/dehydrated.git/blame - dehydrated.spec
- release 2 (by relup.sh)
[packages/dehydrated.git] / dehydrated.spec
CommitLineData
1780cc1f 1Summary: letsencrypt/acme client implemented as a shell-script
0b9f695c
ER
2Name: dehydrated
3Version: 0.3.1
f85acc72 4Release: 2
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
0b9f695c
ER
7Source0: https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: 7a3b92b963da6469c4a53f051d6efa24
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
aebe760f 11Source3: nginx.conf
8f670f9f 12Source4: domains.txt
5765eca7 13Source5: hook.sh
a0535a11 14Source6: crontab
f5fc6721 15Patch0: pld.patch
0b9f695c 16URL: https://github.com/lukas2511/dehydrated
1780cc1f 17BuildRequires: rpmbuild(macros) >= 1.713
90738cc0 18Requires: ca-certificates
a0535a11 19Requires: crondaemon
1780cc1f 20Requires: curl
b9ec4220 21Requires: diffutils
1780cc1f
ER
22Requires: grep
23Requires: mktemp
60120665 24Requires: openssl-tools
1780cc1f 25Requires: sed
eb6aa75d 26Requires: webapps
9f9f4d8c
ER
27Suggests: webserver(access)
28Suggests: webserver(alias)
1780cc1f
ER
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
eb6aa75d
ER
32%define _webapps /etc/webapps
33%define _webapp %{name}
34%define _sysconfdir %{_webapps}/%{_webapp}
35%define _appdir %{_datadir}/%{_webapp}
36
1780cc1f
ER
37%description
38This is a client for signing certificates with an ACME-server
39(currently only provided by letsencrypt) implemented as a relatively
40simple bash-script.
41
42Current features:
43- Signing of a list of domains
44- Signing of a CSR
45- Renewal if a certificate is about to expire or SAN (subdomains)
46 changed
47- Certificate revocation
48
49%prep
50%setup -q
f5fc6721 51%patch0 -p1
1780cc1f
ER
52
53%install
54rm -rf $RPM_BUILD_ROOT
f19ccd97 55install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/cron.d} \
e354c9b6 56 $RPM_BUILD_ROOT/var/lib/%{name}/{accounts,acme-challenge,certs}
eb6aa75d 57
0b9f695c 58install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
59cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
60cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aebe760f 61cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
3ec257e0 62cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 63cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
0b9f695c 64cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/%{name}
5765eca7 65install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 66cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
eb6aa75d
ER
71%triggerin -- apache1 < 1.3.37-3, apache1-base
72%webapp_register apache %{_webapp}
73
74%triggerun -- apache1 < 1.3.37-3, apache1-base
75%webapp_unregister apache %{_webapp}
76
77%triggerin -- apache < 2.2.0, apache-base
78%webapp_register httpd %{_webapp}
79
80%triggerun -- apache < 2.2.0, apache-base
81%webapp_unregister httpd %{_webapp}
82
83%triggerin -- lighttpd
84%webapp_register lighttpd %{_webapp}
85
86%triggerun -- lighttpd
87%webapp_unregister lighttpd %{_webapp}
88
aebe760f
ER
89%triggerin -- nginx
90%webapp_register nginx %{_webapp}
91
92%triggerun -- nginx
93%webapp_unregister nginx %{_webapp}
94
1780cc1f
ER
95%files
96%defattr(644,root,root,755)
97%doc README.md CHANGELOG LICENSE
0b9f695c 98%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
7410a329 99%dir %attr(750,root,http) %{_sysconfdir}
eb6aa75d
ER
100%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
101%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
102%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
aebe760f 103%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
7693646e 104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
8f670f9f 105%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 106%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
0b9f695c 107%attr(755,root,root) %{_sbindir}/%{name}
f19ccd97
ER
108%dir %attr(751,root,root) /var/lib/%{name}
109%dir %attr(700,root,root) /var/lib/%{name}/accounts
e354c9b6 110%dir %attr(700,root,root) /var/lib/%{name}/certs
2e509387 111# challenges written here, need to be readable by webserver
f19ccd97 112%dir %attr(751,root,root) /var/lib/%{name}/acme-challenge
This page took 0.190649 seconds and 4 git commands to generate.