]> git.pld-linux.org Git - packages/dehydrated.git/blame - dehydrated.spec
- release 2 (by relup.sh)
[packages/dehydrated.git] / dehydrated.spec
CommitLineData
1780cc1f 1Summary: letsencrypt/acme client implemented as a shell-script
0b9f695c 2Name: dehydrated
06072c47 3Version: 0.6.5
c8b38766 4Release: 2
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
0b9f695c 7Source0: https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
06072c47 8# Source0-md5: cedf07369517c317c4e1075540b94699
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
aebe760f 11Source3: nginx.conf
5765eca7 12Source5: hook.sh
f60f554e
ER
13Source6: hook-dns-01.sh
14Source7: crontab
e91f3230 15Source8: sudoers
f5fc6721 16Patch0: pld.patch
cf01ce1c 17URL: https://dehydrated.io/
1780cc1f 18BuildRequires: rpmbuild(macros) >= 1.713
90738cc0 19Requires: ca-certificates
a0535a11 20Requires: crondaemon
1780cc1f 21Requires: curl
b9ec4220 22Requires: diffutils
1780cc1f
ER
23Requires: grep
24Requires: mktemp
60120665 25Requires: openssl-tools
1780cc1f 26Requires: sed
e91f3230 27Requires: sudo
eb6aa75d 28Requires: webapps
e91f3230
MK
29Requires(postun): /usr/sbin/groupdel
30Requires(pre): /usr/bin/getgid
31Requires(pre): /usr/sbin/groupadd
9f9f4d8c
ER
32Suggests: webserver(access)
33Suggests: webserver(alias)
1780cc1f
ER
34BuildArch: noarch
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
eb6aa75d
ER
37%define _webapps /etc/webapps
38%define _webapp %{name}
39%define _sysconfdir %{_webapps}/%{_webapp}
40%define _appdir %{_datadir}/%{_webapp}
41
1780cc1f
ER
42%description
43This is a client for signing certificates with an ACME-server
44(currently only provided by letsencrypt) implemented as a relatively
45simple bash-script.
46
47Current features:
48- Signing of a list of domains
49- Signing of a CSR
50- Renewal if a certificate is about to expire or SAN (subdomains)
51 changed
52- Certificate revocation
53
54%prep
55%setup -q
f5fc6721 56%patch0 -p1
1780cc1f
ER
57
58%install
59rm -rf $RPM_BUILD_ROOT
e91f3230 60install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/{cron,sudoers}.d} \
e354c9b6 61 $RPM_BUILD_ROOT/var/lib/%{name}/{accounts,acme-challenge,certs}
eb6aa75d 62
0b9f695c 63install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
64cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
65cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aebe760f 66cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
3ec257e0 67cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
cf01ce1c 68cp -p docs/examples/domains.txt $RPM_BUILD_ROOT%{_sysconfdir}
f60f554e 69cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/cron.d/%{name}
e91f3230 70cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/sudoers.d/%{name}
5765eca7 71install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
f60f554e 72install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 73cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f 74
e91f3230
MK
75%pre
76%groupadd -g 184 dehydrated
77
78%postun
79if [ "$1" = "0" ]; then
80 %groupremove dehydrated
81fi
82
1780cc1f
ER
83%clean
84rm -rf $RPM_BUILD_ROOT
85
eb6aa75d
ER
86%triggerin -- apache1 < 1.3.37-3, apache1-base
87%webapp_register apache %{_webapp}
88
89%triggerun -- apache1 < 1.3.37-3, apache1-base
90%webapp_unregister apache %{_webapp}
91
92%triggerin -- apache < 2.2.0, apache-base
93%webapp_register httpd %{_webapp}
94
95%triggerun -- apache < 2.2.0, apache-base
96%webapp_unregister httpd %{_webapp}
97
98%triggerin -- lighttpd
99%webapp_register lighttpd %{_webapp}
100
101%triggerun -- lighttpd
102%webapp_unregister lighttpd %{_webapp}
103
aebe760f
ER
104%triggerin -- nginx
105%webapp_register nginx %{_webapp}
106
107%triggerun -- nginx
108%webapp_unregister nginx %{_webapp}
109
1780cc1f
ER
110%files
111%defattr(644,root,root,755)
112%doc README.md CHANGELOG LICENSE
0b9f695c 113%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
e91f3230 114%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sudoers.d/%{name}
7410a329 115%dir %attr(750,root,http) %{_sysconfdir}
eb6aa75d
ER
116%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
117%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
118%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
aebe760f 119%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
7693646e 120%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
8f670f9f 121%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 122%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
f60f554e 123%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook-dns-01.sh
0b9f695c 124%attr(755,root,root) %{_sbindir}/%{name}
f19ccd97
ER
125%dir %attr(751,root,root) /var/lib/%{name}
126%dir %attr(700,root,root) /var/lib/%{name}/accounts
e91f3230 127%dir %attr(750,root,dehydrated) /var/lib/%{name}/certs
2e509387 128# challenges written here, need to be readable by webserver
b21cd0a3 129%dir %attr(751,root,dehydrated) /var/lib/%{name}/acme-challenge
This page took 0.112144 seconds and 4 git commands to generate.