]> git.pld-linux.org Git - packages/dehydrated.git/blame - dehydrated.spec
- up to 0.7.0
[packages/dehydrated.git] / dehydrated.spec
CommitLineData
1780cc1f 1Summary: letsencrypt/acme client implemented as a shell-script
0b9f695c 2Name: dehydrated
f8aa239e
AM
3Version: 0.7.0
4Release: 1
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
0b9f695c 7Source0: https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
f8aa239e 8# Source0-md5: a23c9f7a475b9d690e788ee13dd8f14a
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
aebe760f 11Source3: nginx.conf
5765eca7 12Source5: hook.sh
f60f554e
ER
13Source6: hook-dns-01.sh
14Source7: crontab
e91f3230 15Source8: sudoers
f5fc6721 16Patch0: pld.patch
cf01ce1c 17URL: https://dehydrated.io/
1780cc1f 18BuildRequires: rpmbuild(macros) >= 1.713
90738cc0 19Requires: ca-certificates
a0535a11 20Requires: crondaemon
1780cc1f 21Requires: curl
b9ec4220 22Requires: diffutils
1780cc1f
ER
23Requires: grep
24Requires: mktemp
60120665 25Requires: openssl-tools
1780cc1f 26Requires: sed
e91f3230 27Requires: sudo
eb6aa75d 28Requires: webapps
e91f3230
MK
29Requires(postun): /usr/sbin/groupdel
30Requires(pre): /usr/bin/getgid
31Requires(pre): /usr/sbin/groupadd
9f9f4d8c
ER
32Suggests: webserver(access)
33Suggests: webserver(alias)
414a1fa2 34Obsoletes: letsencrypt.sh
1780cc1f
ER
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
eb6aa75d
ER
38%define _webapps /etc/webapps
39%define _webapp %{name}
40%define _sysconfdir %{_webapps}/%{_webapp}
41%define _appdir %{_datadir}/%{_webapp}
42
1780cc1f
ER
43%description
44This is a client for signing certificates with an ACME-server
45(currently only provided by letsencrypt) implemented as a relatively
46simple bash-script.
47
48Current features:
49- Signing of a list of domains
50- Signing of a CSR
51- Renewal if a certificate is about to expire or SAN (subdomains)
52 changed
53- Certificate revocation
54
55%prep
56%setup -q
f5fc6721 57%patch0 -p1
1780cc1f
ER
58
59%install
60rm -rf $RPM_BUILD_ROOT
e91f3230 61install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/{cron,sudoers}.d} \
e354c9b6 62 $RPM_BUILD_ROOT/var/lib/%{name}/{accounts,acme-challenge,certs}
eb6aa75d 63
0b9f695c 64install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
65cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
66cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aebe760f 67cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
3ec257e0 68cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
cf01ce1c 69cp -p docs/examples/domains.txt $RPM_BUILD_ROOT%{_sysconfdir}
f60f554e 70cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/cron.d/%{name}
e91f3230 71cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/sudoers.d/%{name}
5765eca7 72install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
f60f554e 73install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 74cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f 75
e91f3230
MK
76%pre
77%groupadd -g 184 dehydrated
78
79%postun
80if [ "$1" = "0" ]; then
81 %groupremove dehydrated
82fi
83
1780cc1f
ER
84%clean
85rm -rf $RPM_BUILD_ROOT
86
eb6aa75d
ER
87%triggerin -- apache1 < 1.3.37-3, apache1-base
88%webapp_register apache %{_webapp}
89
90%triggerun -- apache1 < 1.3.37-3, apache1-base
91%webapp_unregister apache %{_webapp}
92
93%triggerin -- apache < 2.2.0, apache-base
94%webapp_register httpd %{_webapp}
95
96%triggerun -- apache < 2.2.0, apache-base
97%webapp_unregister httpd %{_webapp}
98
99%triggerin -- lighttpd
100%webapp_register lighttpd %{_webapp}
101
102%triggerun -- lighttpd
103%webapp_unregister lighttpd %{_webapp}
104
aebe760f
ER
105%triggerin -- nginx
106%webapp_register nginx %{_webapp}
107
108%triggerun -- nginx
109%webapp_unregister nginx %{_webapp}
110
1780cc1f
ER
111%files
112%defattr(644,root,root,755)
113%doc README.md CHANGELOG LICENSE
0b9f695c 114%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
e91f3230 115%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sudoers.d/%{name}
7410a329 116%dir %attr(750,root,http) %{_sysconfdir}
eb6aa75d
ER
117%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
118%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
119%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
aebe760f 120%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
7693646e 121%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
8f670f9f 122%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 123%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
f60f554e 124%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook-dns-01.sh
0b9f695c 125%attr(755,root,root) %{_sbindir}/%{name}
f19ccd97
ER
126%dir %attr(751,root,root) /var/lib/%{name}
127%dir %attr(700,root,root) /var/lib/%{name}/accounts
e91f3230 128%dir %attr(750,root,dehydrated) /var/lib/%{name}/certs
2e509387 129# challenges written here, need to be readable by webserver
b21cd0a3 130%dir %attr(751,root,dehydrated) /var/lib/%{name}/acme-challenge
This page took 0.137903 seconds and 4 git commands to generate.