]> git.pld-linux.org Git - packages/decibel.git/blob - decibel.spec
- rel .2
[packages/decibel.git] / decibel.spec
1 #
2 # Conditional build:
3 #
4 %define         qt_ver          4.4.3
5 %define         snap            890391
6
7 Summary:        Decibel
8 Summary(pl.UTF-8):      Decibel
9 Name:           decibel
10 Version:        0.7.0
11 Release:        0.%{snap}.2
12 License:        LGPL v2+
13 Group:          X11/Applications
14 #Source0:       http://decibel.kde.org/fileadmin/downloads/decibel/releases/%{name}-%{version}.tar.gz
15 Source0:        %{name}-%{version}-%{snap}.tar.gz
16 # Source0-md5:  595c8f1ac65880f73dbbe8d81c02ec58
17 URL:            http://decibel.kde.org/
18 BuildRequires:  QtCore-devel >= %{qt_ver}
19 BuildRequires:  QtDBus-devel >= %{qt_ver}
20 BuildRequires:  QtGui-devel >= %{qt_ver}
21 BuildRequires:  automoc4 >= 0.9.84
22 BuildRequires:  cmake >= 2.6.2
23 BuildRequires:  qt4-build >= %{qt_ver}
24 BuildRequires:  qt4-qmake >= %{qt_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.293
26 BuildRequires:  tapioca-qt-devel >= 0.17.7
27 BuildRequires:  telepathy-qt-devel >= 0.17.7
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Decibel is a realtime communications framework, integrating services
32 like CTI (Computer Telephone Integration), VoIP (Voice over IP), text
33 based chat and instant messaging.
34
35 #%description -l pl.UTF-8
36
37 %package devel
38 Summary:        Header files for decibel library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki decibel
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for decibel library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki decibel.
48
49 %prep
50 %setup -q -n %{name}-%{version}-%{snap}
51
52 %build
53 install -d build
54 cd build
55 %cmake .. \
56         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
57 %if "%{_lib}" == "lib64"
58         -DLIB_SUFFIX=64
59 %endif
60
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} -C build install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/decibel
75 %attr(755,root,root) %{_bindir}/decibel_logger
76 %attr(755,root,root) %{_bindir}/textchannelgui
77 %attr(755,root,root) %{_libdir}/libDecibel.so.0.7.1
78 %attr(755,root,root) %{_libdir}/libdecibel_pluginhelper.so.0.7.1
79 %{_libdir}/Decibel
80 %dir %{_datadir}/Decibel
81 %dir %{_datadir}/Decibel/components
82 %{_datadir}/Decibel/components/org.kde.Decibel.Log.component
83 %{_datadir}/Decibel/components/org.kde.SimpleClient.TextChannel.component
84 %{_datadir}/Decibel/components/org.kde.textchannelgui.TextChannel.component
85 %{_datadir}/dbus-1/services/org.kde.Decibel.Daemon.service
86 %{_datadir}/dbus-1/services/org.kde.Decibel.Log.service
87 %{_datadir}/dbus-1/services/org.kde.SimpleClient.service
88 %{_datadir}/dbus-1/services/org.kde.textchannelgui.service
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libDecibel.so
93 %attr(755,root,root) %{_libdir}/libdecibel_pluginhelper.so
94 %{_includedir}/Decibel
95 %{_pkgconfigdir}/Decibel.pc
This page took 0.07851 seconds and 3 git commands to generate.