]> git.pld-linux.org Git - packages/debhelper.git/blob - debhelper.spec
- use http://ftp.debian.org/ url
[packages/debhelper.git] / debhelper.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 Summary:        Helper programs for debian/rules
6 Summary(pl.UTF-8):      Programy pomocnicze dla debian/rules
7 Name:           debhelper
8 Version:        9.20160814
9 Release:        1
10 License:        GPL v2+
11 Group:          Development/Tools
12 Source0:        ftp://ftp.debian.org/debian/pool/main/d/debhelper/%{name}_%{version}.tar.xz
13 # Source0-md5:  2e6a77d0f969d2421260f3f75a2cf1ff
14 URL:            http://joeyh.name/code/debhelper/
15 BuildRequires:  dpkg
16 BuildRequires:  fakeroot
17 # uses man-db specific --recode option in dh_installman
18 BuildRequires:  man-db
19 BuildRequires:  perl-tools-pod
20 BuildRequires:  po4a
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A collection of programs that can be used in a debian/rules file to
28 automate common tasks related to building Debian packages. Programs
29 are included to install various files into your package, compress
30 files, fix file permissions, integrate your package with the Debian
31 menu system, debconf, doc-base, etc.
32
33 Most Debian packages use debhelper as part of their build process.
34
35 %description -l pl.UTF-8
36 Zestaw programów, których można używać w pliku debian/rules do
37 automatyzacji często wykonywanych zadań związanych z budowaniem
38 pakietów Debiana. Zawiera programy do instalowania różnych plików
39 pakietu, kompresji plików, poprawiania uprawnień plików, integracji
40 pakietu z systemem menu Debiana, debconfem, doc-base itp.
41
42 %prep
43 %setup -qc
44 mv %{name}/* .
45
46 %build
47 %{!?with_tests:DEB_BUILD_OPTIONS=nocheck} \
48 fakeroot debian/rules binary
49 mv debian/debhelper%{_docdir}/debhelper doc
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT
54 cp -a debian/debhelper/* $RPM_BUILD_ROOT
55
56 %{__rm} -r $RPM_BUILD_ROOT/DEBIAN
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc doc/*
64 %attr(755,root,root) %{_bindir}/dh
65 %attr(755,root,root) %{_bindir}/dh_*
66 %{_datadir}/%{name}
67
68 %dir %{perl_vendorlib}/Debian
69 %dir %{perl_vendorlib}/Debian/Debhelper
70 %{perl_vendorlib}/Debian/Debhelper/Dh_Buildsystems.pm
71 %{perl_vendorlib}/Debian/Debhelper/Dh_Getopt.pm
72 %{perl_vendorlib}/Debian/Debhelper/Dh_Lib.pm
73 %{perl_vendorlib}/Debian/Debhelper/Dh_Version.pm
74 %{perl_vendorlib}/Debian/Debhelper/Sequence
75 %{perl_vendorlib}/Debian/Debhelper/Buildsystem
76 %{perl_vendorlib}/Debian/Debhelper/Buildsystem.pm
77
78 %{_mandir}/man1/dh.1*
79 %{_mandir}/man1/dh_*.1*
80 %lang(de) %{_mandir}/de/man1/dh.1*
81 %lang(de) %{_mandir}/de/man1/dh_*.1*
82 %lang(es) %{_mandir}/es/man1/dh.1*
83 %lang(es) %{_mandir}/es/man1/dh_*.1*
84 %lang(fr) %{_mandir}/fr/man1/dh.1*
85 %lang(fr) %{_mandir}/fr/man1/dh_*.1*
86 %lang(pt) %{_mandir}/pt/man1/dh.1*
87 %lang(pt) %{_mandir}/pt/man1/dh_*.1*
88 %{_mandir}/man7/debhelper.7*
89 %lang(de) %{_mandir}/de/man7/debhelper.7*
90 %lang(fr) %{_mandir}/fr/man7/debhelper.7*
91 %lang(pt) %{_mandir}/pt/man7/debhelper.7*
This page took 0.033898 seconds and 3 git commands to generate.