]> git.pld-linux.org Git - packages/deadbeef.git/commitdiff
- fixed build with ffmpeg 0.8
authorlisu <lisu@pld-linux.org>
Thu, 30 Jun 2011 08:16:47 +0000 (08:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    deadbeef-ffmpeg-0.8.patch -> 1.1
    deadbeef.spec -> 1.6

deadbeef-ffmpeg-0.8.patch [new file with mode: 0644]
deadbeef.spec

diff --git a/deadbeef-ffmpeg-0.8.patch b/deadbeef-ffmpeg-0.8.patch
new file mode 100644 (file)
index 0000000..d62e942
--- /dev/null
@@ -0,0 +1,29 @@
+--- deadbeef-0.5.1/plugins/ffmpeg/ffmpeg.c~    2011-05-22 15:58:53.000000000 +0200
++++ deadbeef-0.5.1/plugins/ffmpeg/ffmpeg.c     2011-06-30 10:13:28.476471360 +0200
+@@ -140,7 +140,7 @@
+     for (i = 0; i < info->fctx->nb_streams; i++)
+     {
+         info->ctx = info->fctx->streams[i]->codec;
+-        if (info->ctx->codec_type == CODEC_TYPE_AUDIO)
++        if (info->ctx->codec_type == AVMEDIA_TYPE_AUDIO)
+         {
+             info->codec = avcodec_find_decoder (info->ctx->codec_id);
+             if (info->codec != NULL) {
+@@ -490,7 +490,7 @@
+     for (i = 0; i < fctx->nb_streams; i++)
+     {
+         ctx = fctx->streams[i]->codec;
+-        if (ctx->codec_type == CODEC_TYPE_AUDIO)
++        if (ctx->codec_type == AVMEDIA_TYPE_AUDIO)
+         {
+             codec = avcodec_find_decoder(ctx->codec_id);
+             if (codec != NULL && !strcasecmp (codec->name, "alac")) { // only open alac streams
+@@ -745,7 +745,7 @@
+     for (i = 0; i < fctx->nb_streams; i++)
+     {
+         ctx = fctx->streams[i]->codec;
+-        if (ctx->codec_type == CODEC_TYPE_AUDIO)
++        if (ctx->codec_type == AVMEDIA_TYPE_AUDIO)
+         {
+             codec = avcodec_find_decoder(ctx->codec_id);
+             if (codec != NULL)
index 8cbec52076d4cf1c565b0e37d14378e74cd8977c..a15cbac9c1e3f155169b18bbb133c307a5cf5d35 100644 (file)
@@ -7,12 +7,13 @@ Group:                X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/deadbeef/%{name}-%{version}.tar.bz2
 # Source0-md5: be8359d1bd9cf7679cf2ca748996e726
 Patch0:                lm-missing-symbols.patch
+Patch1:                %{name}-ffmpeg-0.8.patch
 URL:           http://deadbeef.sourceforge.net/
 BuildRequires: alsa-lib-devel
 BuildRequires: automake >= 1.11
 BuildRequires: curl-devel
 BuildRequires: dbus-devel
-BuildRequires: ffmpeg-devel
+BuildRequires: ffmpeg-devel >= 0.8
 BuildRequires: gettext-devel
 BuildRequires: gtk+2-devel >= 2.12
 BuildRequires: imlib2-devel
@@ -159,6 +160,7 @@ WavPack decoder.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__automake}
This page took 0.075189 seconds and 4 git commands to generate.