]> git.pld-linux.org Git - packages/ddd.git/blobdiff - ddd.spec
- xorgs modular deps, release 3.
[packages/ddd.git] / ddd.spec
index 6b744ffe13e63178bae2456fdc3f0dad6a6f0cd8..2c122e283f85697d3f6045bad73b8c0604038e9e 100644 (file)
--- a/ddd.spec
+++ b/ddd.spec
@@ -1,35 +1,43 @@
-%include       /usr/lib/rpm/macros.python
 Summary:       X interface to the GDB, DBX and XDB debuggers
 Summary(ja):   GDB,DBX,Ladebug,JDB,Perl,Python¤Î¥°¥é¥Õ¥£¥«¥ë¥Ç¥Ð¥Ã¥¬¤Î¥Õ¥í¥ó¥È¥¨¥ó¥É
 Summary(pl):   Interfejs X do debugerów GDB, DBX i XDB
 Summary(zh_CN):        Í¼Ðλ¯µÄ³ÌÐòµ÷ÊÔÆ÷Ç°¶Ë;ÈçGDB,DBX,Ladebug,JDB,Perl,Python
 Name:          ddd
-Version:       3.3.1
-Release:       17
+Version:       3.3.11
+Release:       3
+Epoch:         1
 License:       GPL
 Group:         Development/Debuggers
 Source0:       ftp://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
-# Source0-md5: 38589618d7cd02a03d062bb116bbf1d2
+# Source0-md5: f19437ebfdb5f2667d6de30f700dd319
 Source1:       %{name}.desktop
-Source2:       %{name}-python.desktop
-Source3:       http://art.gnome.org/images/icons/other/Debugger.png
-# Source3-md5: c046d9b0a04abdbb4a2be08a374ac2cd
-Patch0:                %{name}-DESTDIR.patch
-Patch1:                %{name}-ptrace.patch
-Patch2:                %{name}-info.patch
-Patch3:                %{name}-gcc3.patch
+Source2:       http://art.gnome.org/images/icons/other/Debugger.png
+# Source2-md5: c046d9b0a04abdbb4a2be08a374ac2cd
+Patch0:                %{name}-ptrace.patch
+Patch1:                %{name}-info.patch
+Patch2:                %{name}-home_etc.patch
+Patch3:                %{name}-am185.patch
 URL:           http://www.gnu.org/software/ddd/
-BuildRequires: XFree86-devel
-BuildRequires: automake
+BuildRequires: autoconf >= 2.59
+BuildRequires: automake >= 1:1.9
+BuildRequires: bison
+BuildRequires: elfutils-devel
+BuildRequires: flex
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: motif-devel
 BuildRequires: ncurses-devel >= 5.0
-BuildRequires: python >= 2.2
-BuildRequires: rpm-pythonprov
+BuildRequires: readline-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXpm-devel
 BuildRequires: texinfo
 Requires:      gdb
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _appdefsdir     /usr/X11R6/lib/X11/app-defaults
+
+%define                specflags       -fno-strict-aliasing
+
 %description
 The Data Display Debugger (DDD) is a common graphical user interface
 for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
@@ -71,19 +79,6 @@ program
 podrêcznik on-line; interaktywna pomoc; linia poleceñ GDB/DBX/XDB z
 pe³n± edycj±, histori± i wyszukiwaniem.
 
-%package python
-Summary:       X interface to the GDB, DBX and XDB debuggers - The python debugger
-Summary(pl):   Interfejs X do debugerów GDB, DBX i XDB - debugger pythona
-Group:         Development/Debuggers
-Requires:      %{name} = %{version}
-%pyrequires_eq python
-
-%description python
-Data Display Debugger - python debugger.
-
-%description python -l pl
-Data Display Debugger - debugger pythona.
-
 %prep
 %setup -q
 %patch0 -p1
@@ -92,34 +87,29 @@ Data Display Debugger - debugger pythona.
 %patch3 -p1
 
 %build
+%{__libtoolize}
 %{__aclocal}
+%{__autoconf}
 %{__automake}
-%configure2_13 \
+%configure \
        --with-motif \
-       --with-readline-libraries=%{_libdir}
+       --with-readline \
+       --with-termlib=tinfo
 
-%{__make} CXXOPT="-DNDEBUG %{rpmcflags}"
+%{__make} \
+       CXXOPT="-DNDEBUG %{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{py_sitedir} \
-       $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults \
-       $RPM_BUILD_ROOT{%{_applnkdir}/Development,%{_pixmapsdir}}
+install -d $RPM_BUILD_ROOT{%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install pydb/pydb.py $RPM_BUILD_ROOT%{_bindir}/pydb
-install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT%{py_sitedir}
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
+install ddd/Ddd $RPM_BUILD_ROOT%{_appdefsdir}
 
-install ddd/Ddd $RPM_BUILD_ROOT%{_libdir}/X11/app-defaults
-
-install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Development
-install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
-
-mv doc/README README.doc
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -132,18 +122,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc ANNOUNCE AUTHORS *BUGS INSTALL NEWS* PROBLEMS README* TIPS TODO doc/ddd.pdf
-%doc doc/sample.dddinit
-%{_applnkdir}/Development/ddd.desktop
-%{_pixmapsdir}/*
+%doc AUTHORS NEWS README TIPS TODO doc/*.pdf
 %attr(755,root,root) %{_bindir}/ddd
-%{_libdir}/X11/app-defaults/Ddd
-%{_mandir}/man1/*
 %{_datadir}/ddd*
+%{_appdefsdir}/Ddd
+%{_desktopdir}/ddd.desktop
+%{_pixmapsdir}/*.png
+%{_mandir}/man1/*
 %{_infodir}/ddd*
-
-%files python
-%defattr(644,root,root,755)
-%{_applnkdir}/Development/ddd-python.desktop
-%attr(755,root,root) %{_bindir}/pydb
-%{py_sitedir}/*.py?
This page took 0.093904 seconds and 4 git commands to generate.