]> git.pld-linux.org Git - packages/ddd.git/blame - ddd.spec
- release 7
[packages/ddd.git] / ddd.spec
CommitLineData
51509a3c 1Summary: X interface to the GDB, DBX and XDB debuggers
7fe70d6d
ER
2Summary(ja.UTF-8): GDB,DBX,Ladebug,JDB,Perl,Pythonのグラフィカルデバッガのフロントエンド
3Summary(pl.UTF-8): Interfejs X do debugerów GDB, DBX i XDB
4Summary(zh_CN.UTF-8): 图形化的程序调试器前端;如GDB,DBX,Ladebug,JDB,Perl,Python
51509a3c 5Name: ddd
4f010032 6Version: 3.3.11
1017a516 7Release: 7
f3eee0e0 8Epoch: 1
1393fd34 9License: GPL
51509a3c 10Group: Development/Debuggers
7aad6555 11Source0: http://ftp.gnu.org/gnu/ddd/%{name}-%{version}.tar.gz
4f010032 12# Source0-md5: f19437ebfdb5f2667d6de30f700dd319
07562c8e 13Source1: %{name}.desktop
9bb96c4f 14Source2: http://art.gnome.org/images/icons/other/Debugger.png
15# Source2-md5: c046d9b0a04abdbb4a2be08a374ac2cd
4240a013
JB
16Patch0: %{name}-ptrace.patch
17Patch1: %{name}-info.patch
18Patch2: %{name}-home_etc.patch
a7af7153 19Patch3: %{name}-am185.patch
1393fd34 20URL: http://www.gnu.org/software/ddd/
5a888cbe 21BuildRequires: autoconf >= 2.59
f23f37e6 22BuildRequires: automake >= 1:1.9
7e33ad50 23BuildRequires: bison
4240a013 24BuildRequires: elfutils-devel
7e33ad50 25BuildRequires: flex
a90f00aa 26BuildRequires: libstdc++-devel
7e33ad50 27BuildRequires: libtool
dbca9d34 28BuildRequires: motif-devel
0feeb2de 29BuildRequires: ncurses-devel >= 5.0
7e33ad50 30BuildRequires: readline-devel
58bdacec
PS
31BuildRequires: xorg-lib-libXmu-devel
32BuildRequires: xorg-lib-libXpm-devel
a90f00aa 33BuildRequires: texinfo
5d4db591 34Requires: gdb
81b4f762 35Requires: xorg-lib-libXt >= 1.0.0
ea35aef7 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22b41ee6 37
de7449a2 38%define _appdefsdir %{_datadir}/X11/app-defaults
c6b2bea0 39
58bdacec
PS
40%define specflags -fno-strict-aliasing
41
22b41ee6 42%description
1393fd34 43The Data Display Debugger (DDD) is a common graphical user interface
44for GDB, DBX, and XDB, the popular UNIX debuggers. Besides
45``classical'' front-end features such as viewing source texts, DDD
46provides a graphical data display, where data structures are displayed
47as graphs. A simple mouse click dereferences pointers or views
48structure contents, updated each time the program stops. Using DDD,
49you can reason about your application by viewing its data, not just by
50viewing it execute lines of source code. Other DDD features include:
51debugging of programs written in C, C++, Ada, Fortran, Java, Pascal,
52Modula-2, or Modula-3; machine-level debugging; hypertext source
53navigation and lookup; breakpoint, backtrace, and history editors;
54preferences and settings editors; program execution in terminal
55emulator window; debugging on remote host; on-line manual; interactive
56help on the Motif user interface; GDB/DBX/XDB command-line interface
57with full editing, history, search, and completion capabilities. DDD
58has been designed to compete with well-known commercial debuggers
22b41ee6 59
5e79cfbc
JR
60%description -l ja.UTF-8
61DDDは、GDB,DBX,WDB,Ladebug,JDB,XDB,Perlデバッガ、またはPythonデバッガ
62のようなコマンドライン型デバッガをグラフィカル型のデバッガに変身させる
63フロントエンドです。ソースコードの参照等のような"通常"のフロントエンド
64の機能のみならず、DDDはデータ構造をグラフとして表示する、会話式グラフ
65ィカルデータ表示することで有名になりました。
dbe688e0 66
5e79cfbc 67%description -l pl.UTF-8
4c663710 68Data Display Debugger (DDD) jest typowym graficznym interfejsem do
5e79cfbc
JR
69GDB, DBX, i XDB - popularnych UNIXowych debuggerów. Poza
70``klasycznymi'' możliwościami interfejsów graficznych takich jak
71przeglądanie kodów źródłowych DDD dostarcza graficznych narzędzi,
72gdzie struktury wyświetlane są w postaci graficznej. Proste kliknięcie
73myszą pozwala na przeglądanie zawartości struktur (aktualizowane za
74każdym razem gdy program się zatrzyma). Inne możliwości DDD to:
75możliwość debugowania programów napisanych w C, C++, Ada, Fortran,
4c663710 76Java, Pascal, Modula-2, or Modula-2; debugowanie na poziomie maszyny;
5e79cfbc
JR
77hypertekstowa nawigacja po źródłach; breakpoint, backtrace i emulator
78okna historii; możliwość ustawiania preferencji; uruchamianie
79programów w oknie terminala; debugowanie na zdalnych serwerach;
80podręcznik on-line; interaktywna pomoc; linia poleceń GDB/DBX/XDB z
81pełną edycją, historią i wyszukiwaniem.
68340e17 82
22b41ee6 83%prep
84%setup -q
1393fd34 85%patch0 -p1
5eb7cc1a 86%patch1 -p1
7cc68d05 87%patch2 -p1
a7af7153 88%patch3 -p1
22b41ee6 89
90%build
7e33ad50 91%{__libtoolize}
64739cb8 92%{__aclocal}
7e33ad50 93%{__autoconf}
6edd3549 94%{__automake}
7e33ad50 95%configure \
64739cb8 96 --with-motif \
5a888cbe
JB
97 --with-readline \
98 --with-termlib=tinfo
41389164 99
076497b8
JB
100%{__make} \
101 CXXOPT="-DNDEBUG %{rpmcflags}"
22b41ee6 102
103%install
104rm -rf $RPM_BUILD_ROOT
c6b2bea0 105install -d $RPM_BUILD_ROOT{%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
63d390b5 106
a90f00aa
PG
107%{__make} install \
108 DESTDIR=$RPM_BUILD_ROOT
22b41ee6 109
c6b2bea0 110install ddd/Ddd $RPM_BUILD_ROOT%{_appdefsdir}
22b41ee6 111
c6b2bea0 112install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
9bb96c4f 113install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/ddd.png
22b41ee6 114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
41429509
ER
118%post -p /sbin/postshell
119-/usr/sbin/fix-info-dir -c %{_infodir}
4da4eebb 120
41429509
ER
121%postun -p /sbin/postshell
122-/usr/sbin/fix-info-dir -c %{_infodir}
4da4eebb 123
22b41ee6 124%files
29e353f7 125%defattr(644,root,root,755)
125d54d5 126%doc AUTHORS NEWS README TIPS TODO doc/*.pdf
b14a1eae 127%attr(755,root,root) %{_bindir}/ddd
4da4eebb 128%{_datadir}/ddd*
c6b2bea0
JB
129%{_appdefsdir}/Ddd
130%{_desktopdir}/ddd.desktop
131%{_pixmapsdir}/*.png
132%{_mandir}/man1/*
4da4eebb 133%{_infodir}/ddd*
This page took 0.133115 seconds and 4 git commands to generate.