]> git.pld-linux.org Git - packages/ddccontrol.git/blame_incremental - ddccontrol.spec
- updated gettext BR
[packages/ddccontrol.git] / ddccontrol.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with gnome # don't build gnome applet
4%bcond_without gtk # don't build GTK+ GUI
5%bcond_without static_libs # don't build static library
6#
7%define dbversion 20061014
8%define ddcdb %{name}-db-%{dbversion}
9
10Summary: DDCcontrol - control the monitor parameters
11Summary(pl.UTF-8): DDCcontrol - narzędzie do regulacji parametrów monitora
12Name: ddccontrol
13Version: 0.4.2
14Release: 5
15License: GPL v2+
16Group: Applications
17Source0: http://dl.sourceforge.net/ddccontrol/%{name}-%{version}.tar.bz2
18# Source0-md5: b0eb367f3bc0564bd577e38d0b4107fc
19Source1: http://dl.sourceforge.net/ddccontrol/%{ddcdb}.tar.bz2
20# Source1-md5: 91951918e5bc553c251776cdff8cea9c
21Patch0: %{name}-desktop.patch
22Patch1: %{name}-gnome.patch
23Patch2: %{name}-pl.patch
24Patch3: %{name}-link.patch
25URL: http://ddccontrol.sourceforge.net/
26BuildRequires: autoconf >= 2.50
27BuildRequires: automake
28BuildRequires: gettext-tools
29%{?with_gnome:BuildRequires: gnome-panel-devel >= 2.10}
30%{?with_gtk:BuildRequires: gtk+2-devel >= 2:2.4}
31BuildRequires: intltool
32BuildRequires: libtool
33BuildRequires: libxml2-devel
34BuildRequires: pciutils-devel
35BuildRequires: pkgconfig
36Requires: %{name}-libs = %{version}-%{release}
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40DDCcontrol is a program used to control monitor parameters, like
41brightness and contrast, by software, i.e. without using the OSD and
42the buttons in front of the monitor.
43
44%description -l pl.UTF-8
45DDCcontrol jest programem służącym do regulacji parametrów monitora
46takich jak jaskrawość i kontrast, bez używania OSD i przycisków na
47obudowie monitora.
48
49%package gtk
50Summary: GTK+ GUI for ddccontrol
51Summary(pl.UTF-8): Graficzny interfejs GTK+ dla ddccontrol
52Group: X11/Applications
53Requires: %{name} = %{version}-%{release}
54
55%description gtk
56GTK+ GUI for ddccontrol.
57
58%description gtk -l pl.UTF-8
59Graficzny interfejs GTK+ dla ddccontrol.
60
61%package applet
62Summary: GNOME applet for ddccontrol
63Summary(pl.UTF-8): Aplet GNOME dla ddccontrol
64Group: X11/Applications
65Requires: %{name} = %{version}-%{release}
66
67%description applet
68GNOME applet for ddccontrol.
69
70%description applet -l pl.UTF-8
71Aplet GNOME dla ddccontrol.
72
73%package libs
74Summary: ddccontrol library
75Summary(pl.UTF-8): Biblioteka ddccontrol
76Group: Libraries
77
78%description libs
79DDCcontrol library.
80
81%description libs -l pl.UTF-8
82Biblioteka DDCcontrol.
83
84%package devel
85Summary: Development files for ddccontrol library
86Summary(pl.UTF-8): Pliki niezbędne programistom używającym biblioteki ddccontrol
87Group: Development/Libraries
88Requires: %{name}-libs = %{version}-%{release}
89Requires: libxml2-devel
90Requires: pciutils-devel
91
92%description devel
93Development files for ddccontrol library.
94
95%description devel -l pl.UTF-8
96Pliki niezbędne programistom używającym biblioteki ddccontrol.
97
98%package static
99Summary: Static ddccontrol library
100Summary(pl.UTF-8): Biblioteka statyczna ddccontrol
101Group: Development/Libraries
102Requires: %{name}-devel = %{version}-%{release}
103
104%description static
105Static ddccontrol library.
106
107%description static -l pl.UTF-8
108Biblioteka statyczna ddccontrol.
109
110%prep
111%setup -q -a 1
112%patch0 -p1
113%patch1 -p1
114%patch2 -p1
115%patch3 -p1
116
117%build
118%{__intltoolize}
119%{__libtoolize}
120%{__aclocal} -I m4
121%{__autoconf}
122%{__autoheader}
123%{__automake}
124%configure \
125 %{!?with_gtk:--disable-gnome} \
126 %{!?with_gnome:--disable-gnome-applet} \
127 %{!?with_static_libs:--disable-static}
128%{__make}
129cd %{ddcdb}
130%configure
131%{__make}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135%{__make} install \
136 DESTDIR=$RPM_BUILD_ROOT
137
138%{__make} -C %{ddcdb} install \
139 DESTDIR=$RPM_BUILD_ROOT
140
141%{__rm} $RPM_BUILD_ROOT%{_libdir}/libddccontrol.la
142
143%find_lang %{name} --all-name
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post libs -p /sbin/ldconfig
149%postun libs -p /sbin/ldconfig
150
151%files -f %{name}.lang
152%defattr(644,root,root,755)
153%doc AUTHORS ChangeLog NEWS README TODO doc/html
154%attr(755,root,root) %{_bindir}/ddccontrol
155%attr(755,root,root) %{_bindir}/ddcpci
156%{_datadir}/ddccontrol-db
157%{_mandir}/man1/ddccontrol.1*
158
159%if %{with gtk}
160%files gtk
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_bindir}/gddccontrol
163%{_desktopdir}/gddccontrol.desktop
164%{_pixmapsdir}/gddccontrol.png
165%{_mandir}/man1/gddccontrol.1*
166%endif
167
168%if %{with gnome}
169%files applet
170%defattr(644,root,root,755)
171%dir %{_libdir}/ddccontrol
172%attr(755,root,root) %{_libdir}/ddccontrol/ddcc-applet
173%{_datadir}/ddccontrol
174%{_libdir}/bonobo/servers/*
175%endif
176
177%files libs
178%defattr(644,root,root,755)
179%attr(755,root,root) %{_libdir}/libddccontrol.so.*.*.*
180%attr(755,root,root) %ghost %{_libdir}/libddccontrol.so.0
181
182%files devel
183%defattr(644,root,root,755)
184%attr(755,root,root) %{_libdir}/libddccontrol.so
185%{_includedir}/ddccontrol
186
187%if %{with static_libs}
188%files static
189%defattr(644,root,root,755)
190%{_libdir}/libddccontrol.a
191%endif
This page took 0.060338 seconds and 4 git commands to generate.