]> git.pld-linux.org Git - packages/dconf.git/blob - dconf.spec
- rel 4
[packages/dconf.git] / dconf.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  vala            # do not build Vala API
5 #
6 Summary:        Low-level configuration system
7 Summary(pl.UTF-8):      Niskopoziomowy system konfiguracji
8 Name:           dconf
9 Version:        0.26.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/dconf/0.26/%{name}-%{version}.tar.xz
14 # Source0-md5:  7fc3cb1cf22d904d8744bd12e9c9d3dd
15 URL:            http://live.gnome.org/dconf
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.11.2
18 BuildRequires:  glib2-devel >= 1:2.44.0
19 BuildRequires:  gtk-doc >= 1.15
20 BuildRequires:  libxslt-progs
21 BuildRequires:  rpmbuild(macros) >= 1.527
22 BuildRequires:  tar >= 1:1.22
23 # not needed atm., generated files are packaged
24 #%{?with_vala:BuildRequires:    vala >= 2:0.18.0}
25 BuildRequires:  xz
26 Requires(post,postun):  glib2 >= 1:2.39.1
27 Requires:       dbus
28 Requires:       glib2 >= 1:2.44.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 dconf is a low-level configuration system. Its main purpose is to
33 provide a backend to GSettings on platforms that don't already have
34 configuration storage systems.
35
36 %description -l pl.UTF-8
37 dconf to niskopoziomowy system konfiguracji. Głównym celem jest
38 dostarczenie backendu dla GSettings na platformach, które jeszcze nie
39 mają systemów przechowywania danych konfiguracyjnych.
40
41 %package devel
42 Summary:        Header files for dconf library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dconf
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.44.0
47
48 %description devel
49 Header files for dconf library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki dconf.
53
54 %package apidocs
55 Summary:        dconf API documentation
56 Summary(pl.UTF-8):      Dokumentacja API biblioteki dconf
57 Group:          Documentation
58 Requires:       gtk-doc-common
59 %if "%{_rpmversion}" >= "5"
60 BuildArch:      noarch
61 %endif
62
63 %description apidocs
64 API documentation for dconf library.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki dconf.
68
69 %package -n bash-completion-dconf
70 Summary:        bash-completion for dconf
71 Summary(pl.UTF-8):      Bashowe uzupełnianie nazw dla dconf
72 Group:          Applications/Shells
73 Requires:       bash-completion >= 2
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description -n bash-completion-dconf
79 bash-completion for dconf.
80
81 %description -n bash-completion-dconf -l pl.UTF-8
82 Bashowe uzupełnianie nazw dla dconf.
83
84 %package -n vala-dconf
85 Summary:        dconf API for Vala language
86 Summary(pl.UTF-8):      API dconf dla języka Vala
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.18.0
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description -n vala-dconf
95 dconf API for Vala language.
96
97 %description -n vala-dconf -l pl.UTF-8
98 API dconf dla języka Vala.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         --with-html-dir=%{_gtkdocdir} \
110         %{__enable_disable apidocs gtk-doc} \
111         --disable-silent-rules
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 install -d $RPM_BUILD_ROOT%{_sysconfdir}/dconf/{db,profile}
118 install -d $RPM_BUILD_ROOT%{_datadir}/dconf/profile
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 /sbin/ldconfig
130
131 umask 022
132 %{_bindir}/gio-querymodules %{_libdir}/gio/modules || :
133
134 %glib_compile_schemas
135
136 %postun
137 /sbin/ldconfig
138
139 umask 022
140 %{_bindir}/gio-querymodules %{_libdir}/gio/modules || :
141
142 %glib_compile_schemas
143
144 %files
145 %defattr(644,root,root,755)
146 %doc NEWS README
147 %attr(755,root,root) %{_bindir}/dconf
148 %attr(755,root,root) %{_libdir}/libdconf.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libdconf.so.1
150 %attr(755,root,root) %{_libexecdir}/dconf-service
151 %attr(755,root,root) %{_libdir}/gio/modules/libdconfsettings.so
152 %{_datadir}/dbus-1/services/ca.desrt.dconf.service
153 %dir %{_sysconfdir}/dconf
154 %dir %{_sysconfdir}/dconf/db
155 %dir %{_sysconfdir}/dconf/profile
156 %dir %{_datadir}/dconf
157 %dir %{_datadir}/dconf/profile
158 %{_mandir}/man1/dconf-service.1*
159 %{_mandir}/man1/dconf.1*
160 %{_mandir}/man7/dconf.7*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libdconf.so
165 %{_includedir}/dconf
166 %{_pkgconfigdir}/dconf.pc
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/dconf
172 %endif
173
174 %files -n bash-completion-dconf
175 %defattr(644,root,root,755)
176 %{bash_compdir}/dconf
177
178 %if %{with vala}
179 %files -n vala-dconf
180 %defattr(644,root,root,755)
181 %{_datadir}/vala/vapi/dconf.deps
182 %{_datadir}/vala/vapi/dconf.vapi
183 %endif
This page took 0.056342 seconds and 3 git commands to generate.