]> git.pld-linux.org Git - packages/dcom98.git/blame - dcom98.spec
- Completed the UTF-8 conversion.
[packages/dcom98.git] / dcom98.spec
CommitLineData
b1836464 1# This spec file is released under the GNU General Public License version 2.0
2# (http://www.gnu.org/licenses/gpl.txt).
3#
4# NOTE: Releasing this spec file under the GPL does not alter the licensing of
5# DCOM98 itself. Satisfying the terms of DCOM98's license remains the user's
6# responsibility.
7
b1836464 8%define _wine_cdrive %{_datadir}/wine
9%define _wine_system %{_wine_cdrive}/windows/system
10
5f54d8e5 11Summary: Package of DLLs supporting Microsoft's DCOM framework
686386fe 12Summary(pl.UTF-8): Pakiet bibliotek DLL obsługujących szkielet DCOM Microsoftu
b1836464 13Name: dcom98
0c8b8cc3 14Version: 1.3
15Release: 3
16Group: Libraries
17License: Distributable
b1836464 18Vendor: Microsoft
19Source0: http://download.microsoft.com/msdownload/dcom/98/x86/en/%{name}.exe
0c8b8cc3 20# Source0-md5: 9a7bc7ff37168217123a5e28aadef897
21URL: http://www.microsoft.com/com/tech/DCOM.asp
22Requires: wine
23#Requires: wine-utils
24BuildRequires: cabextract
b1836464 25Obsoletes: dcom
0c8b8cc3 26ExclusiveArch: %{ix86}
515ad107 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
b1836464 28
29%description
30The Distributed Component Object Model (DCOM) is a protocol that
31enables software components to communicate directly over a network in
32a reliable, secure, and efficient manner. Previously called "Network
33OLE," DCOM is designed for use across multiple network transports,
34including Internet protocols such as HTTP. DCOM is based on the Open
35Software Foundation's DCE-RPC spec and will work with both Java
5f54d8e5
JB
36applets and ActiveX(R) components through its use of the Component
37Object Model (COM).
38
686386fe 39%description -l pl.UTF-8
40DCOM (Distributed Component Object Model) to protokół pozwalający
41komponentom programowym komunikować się bezpośrednio po sieci w pewny,
42bezpieczny i wydajny sposób. Znany wcześniej jako "sieciowe OLE", DCOM
43został zaprojektowany do używania poprzez wiele sieciowych warstw
44transportowych, w tym protokołów internetowych takich jak HTTP. DCOM
45jest oparty na specyfikacji DCE-RPC Open Software Foundation i działa
46zarówno z apletami Javy, jak i komponentami ActiveX(R) dzięki
5f54d8e5 47wykorzystaniu modelu COM (Component Object Model).
b1836464 48
49%prep
50/usr/bin/cabextract -L $RPM_SOURCE_DIR/dcom98.exe
51
52%install
53rm -rf $RPM_BUILD_ROOT
bc4b3a3a 54install -d $RPM_BUILD_ROOT%{_wine_system}
5f54d8e5
JB
55install -d $RPM_BUILD_ROOT%{_wine_cdrive}/inf
56mv advpack.dll $RPM_BUILD_ROOT%{_wine_system}
57mv asycfilt.dll $RPM_BUILD_ROOT%{_wine_system}
58mv comcat.dll $RPM_BUILD_ROOT%{_wine_system}
59mv compobj.dll $RPM_BUILD_ROOT%{_wine_system}
60mv dcom98.inf $RPM_BUILD_ROOT%{_wine_cdrive}/inf
61mv dllhost.exe $RPM_BUILD_ROOT%{_wine_system}
62mv imagehlp.dll $RPM_BUILD_ROOT%{_wine_system}
63mv iprop.dll $RPM_BUILD_ROOT%{_wine_system}
64mv ole2.dll $RPM_BUILD_ROOT%{_wine_system}
65mv ole32.dll $RPM_BUILD_ROOT%{_wine_system}
66mv oleaut32.dll $RPM_BUILD_ROOT%{_wine_system}
67mv olecnv32.dll $RPM_BUILD_ROOT%{_wine_system}
68mv olepro32.dll $RPM_BUILD_ROOT%{_wine_system}
69mv olethk32.dll $RPM_BUILD_ROOT%{_wine_system}
70mv rpcltc1.dll $RPM_BUILD_ROOT%{_wine_system}
71mv rpcltc5.dll $RPM_BUILD_ROOT%{_wine_system}
72mv rpcltccm.dll $RPM_BUILD_ROOT%{_wine_system}
73mv rpclts5.dll $RPM_BUILD_ROOT%{_wine_system}
74mv rpcltscm.dll $RPM_BUILD_ROOT%{_wine_system}
75mv rpcmqcl.dll $RPM_BUILD_ROOT%{_wine_system}
76mv rpcmqsvr.dll $RPM_BUILD_ROOT%{_wine_system}
77mv rpcns4.dll $RPM_BUILD_ROOT%{_wine_system}
78mv rpcrt4.dll $RPM_BUILD_ROOT%{_wine_system}
79mv rpcss.exe $RPM_BUILD_ROOT%{_wine_system}
80mv secur32.dll $RPM_BUILD_ROOT%{_wine_system}
81mv stdole2.tlb $RPM_BUILD_ROOT%{_wine_system}
82mv stdole32.tlb $RPM_BUILD_ROOT%{_wine_system}
83mv storage.dll $RPM_BUILD_ROOT%{_wine_system}
bc4b3a3a
TP
84mv w95inf16.dll $RPM_BUILD_ROOT%{_wine_system}/w95inf16.dll
85mv w95inf32.dll $RPM_BUILD_ROOT%{_wine_system}/w95inf32.dll
b1836464 86
87rm -f eula98.txt
88rm -f relnt98.txt
89rm -f install.exe
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
96%{_wine_system}/advpack.dll
97%{_wine_system}/asycfilt.dll
98%{_wine_system}/comcat.dll
99%{_wine_system}/compobj.dll
100%{_wine_cdrive}/inf/dcom98.inf
101%{_wine_system}/dllhost.exe
102%{_wine_system}/imagehlp.dll
103%{_wine_system}/iprop.dll
104%{_wine_system}/ole2.dll
105%{_wine_system}/ole32.dll
106%{_wine_system}/oleaut32.dll
107%{_wine_system}/olecnv32.dll
108%{_wine_system}/olepro32.dll
109%{_wine_system}/olethk32.dll
110%{_wine_system}/rpcltc1.dll
111%{_wine_system}/rpcltc5.dll
112%{_wine_system}/rpcltccm.dll
113%{_wine_system}/rpclts5.dll
114%{_wine_system}/rpcltscm.dll
115%{_wine_system}/rpcmqcl.dll
116%{_wine_system}/rpcmqsvr.dll
117%{_wine_system}/rpcns4.dll
118%{_wine_system}/rpcrt4.dll
119%{_wine_system}/rpcss.exe
120%{_wine_system}/secur32.dll
121%{_wine_system}/stdole2.tlb
122%{_wine_system}/stdole32.tlb
123%{_wine_system}/storage.dll
124%{_wine_system}/w95inf16.dll
125%{_wine_system}/w95inf32.dll
This page took 0.06775 seconds and 4 git commands to generate.