]> git.pld-linux.org Git - packages/dchub.git/commitdiff
- fix PIC (-fPIC is compiler flag, not linker!)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 18 Dec 2003 21:22:50 +0000 (21:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dchub-pic.patch -> 1.1

dchub-pic.patch [new file with mode: 0644]

diff --git a/dchub-pic.patch b/dchub-pic.patch
new file mode 100644 (file)
index 0000000..f89c9a1
--- /dev/null
@@ -0,0 +1,14 @@
+--- dchub-0.5.2/plugin/Makefile.am.orig        2003-11-28 15:29:40.000000000 +0000
++++ dchub-0.5.2/plugin/Makefile.am     2003-12-18 21:14:53.000000000 +0000
+@@ -6,9 +6,9 @@
+ SUFFIXES = .c .o .so
+ .c.o:
+-      $(CC) -c $(CFLAGS) $(CPPFLAGS) $(GLIB_CFLAGS) -o $@ $<
++      $(CC) -fPIC -c $(CFLAGS) $(CPPFLAGS) $(GLIB_CFLAGS) -o $@ $<
+ .o.so:
+-      $(CC) -fPIC -shared $(CFLAGS) $(GLIB_CFLAGS) $< -o $@
++      $(CC) -shared $(CFLAGS) $(GLIB_CFLAGS) $< -o $@
+ pluginsdir = $(libexecdir)/dchub/plugins
This page took 0.119478 seconds and 4 git commands to generate.