]> git.pld-linux.org Git - packages/dcc-dccd.git/blobdiff - dcc-dccd.spec
- use %useradd/%groupadd macros
[packages/dcc-dccd.git] / dcc-dccd.spec
index b4e4f0c5428d4891e89e21b959841e9a002c8335..bf34b58baaeb5d7ea0f07412f309d44edfb2f7cd 100644 (file)
@@ -1,19 +1,24 @@
 Summary:       Distributed Checksum Clearinghouse, anti-spam tool
 Summary(pl):   Narzêdzie anty-spamowe bazuj±ce na sumach kontrolnych (DCC)
 Name:          dcc-dccd
-Version:       1.2.27
+Version:       1.2.50
 Release:       1
 License:       BSD-like
 Group:         Networking
 Source0:       http://www.dcc-servers.net/dcc/source/%{name}-%{version}.tar.Z
-# Source0-md5: ba23ff397cbaf3974c58fa0d3b3f4f73
+# Source0-md5: 676b17dca43a3dabe22c057a6cfdde77
 URL:           http://www.dcc-servers.net/
+BuildRequires: fhs-compliance
+BuildRequires: using-special-registered-not-regular-user
+BuildRequires: rpmbuild(macros) >= 1.202
 Requires(pre): /usr/sbin/useradd
 Requires(postun):      /usr/sbin/userdel
 Requires(post,preun):  /sbin/chkconfig
+Provides:      user(dcc)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                dccdir  /var/lib/dcc
+%define                cgidir  /srv/httpd/cgi-bin
 
 %description
 Distributed Checksum Clearinghouse or DCC is a cooperative,
@@ -49,7 +54,7 @@ jak
 Summary:       Tools to access a DCC server
 Summary(pl):   Narzêdzia dostêpowe dla serwera DCC
 Group:         Networking
-Requires:      %{name} >= 1.1.2
+Requires:      %{name} = %{version}-%{release}
 
 %description client
 Distributed Checksum Clearinghouse or DCC is a cooperative,
@@ -66,7 +71,7 @@ from sources in a "white list." White lists are generally the
 responsibility of DCC clients, since only they know which bulk mail
 they solicited.
 
-%description -l pl client
+%description client -l pl
 DCC (Distributed Checksum Clearinghouse) jest kooperatywnym,
 rozproszonym systemem maj±cym na celu wykrywanie masowej poczty lub
 poczty wys³anej do wielu ludzi. Pozwala jednostkom otrzymuj±cym
@@ -85,7 +90,7 @@ jak
 Summary:       DCC Server
 Summary(pl):   Serwer DCC
 Group:         Networking
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description server
 Distributed Checksum Clearinghouse or DCC is a cooperative,
@@ -102,7 +107,7 @@ from sources in a "white list." White lists are generally the
 responsibility of DCC clients, since only they know which bulk mail
 they solicited.
 
-%description -l pl server
+%description server -l pl
 DCC (Distributed Checksum Clearinghouse) jest kooperatywnym,
 rozproszonym systemem maj±cym na celu wykrywanie masowej poczty lub
 poczty wys³anej do wielu ludzi. Pozwala jednostkom otrzymuj±cym
@@ -118,13 +123,13 @@ Za bia
 jak± masow± pocztê zamawiali.
 
 %package cgi
-Summary:       cgi-scripts for managing mail delivery on a DCC enabled server
-Summary(pl):   Skrypty cgi do obs³ugi dostarczania poczty na serwerze DCC
+Summary:       CGI scripts for managing mail delivery on a DCC enabled server
+Summary(pl):   Skrypty CGI do obs³ugi dostarczania poczty na serwerze DCC
 Group:         Networking
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description cgi
-Example set of cgi-scripts to allow users to point-and-click manage
+Example set of CGI scripts to allow users to point-and-click manage
 their own DCC whitelists and thus what is delivered to them. Allows
 overriding of site level lists. The scripts give controlled access to
 the whitelists which are otherwise in protected directory space (owned
@@ -133,7 +138,7 @@ by dcc).
 NB these scripts need configured after installation.
 
 %description cgi -l pl
-Przyk³adowy zestaw skryptów pozwalaj±cych u¿ytkownikom na klikane
+Przyk³adowy zestaw skryptów CGI pozwalaj±cych u¿ytkownikom na klikane
 zarz±dzenie ich bia³ymi listami DCC, a wiêc i tym, co dostaj±. Pozwala
 przykrywaæ listy dotycz±ce serwera. Skrypty daj± dostêp do bia³ych
 list, które normalnie s± w zabezpieczonym katalogu (którego
@@ -145,12 +150,18 @@ Te skrypty wymagaj
 %setup -q
 
 %build
-%configure2_13 \
-       --prefix=%{_var}/lib/dcc \
+CFLAGS="%{rpmcflags}"; export CFLAGS
+LDFLAGS="%{rpmldflags}"; export LDFLAGS
+./configure \
+       --bindir=%{_bindir} \
+       --libexecdir=%{_libexecdir} \
+       --mandir=%{_mandir} \
+       --homedir=%{dccdir} \
        --with-uid=99 \
-       --with-cgibin=/home/services/httpd/html/cgi-bin \
+       --with-cgibin=%{cgidir} \
        --with-rundir=%{_var}/run \
        --with-db-memory=32
+
 %{__make}
 %{__make} -C dccifd/dccif-test
 
@@ -167,10 +178,17 @@ install -d $RPM_BUILD_ROOT%{_includedir}/dcc
 INST_UID="$( id -u )" INST_GID="$( id -g )"; export INST_UID INST_GID
 
 %{makeinstall} \
-       MANOWN=$INST_UID MANGRP=$INST_GID DCC_SUID=$INST_UID DCC_OWN=$INST_UID \
-       DCC_GRP=$INST_GID BINOWN=$INST_UID GRP=$INST_GID INSTALL="install -C" \
-       DCC_PROTO_HOMEDIR=$RPM_BUILD_ROOT%{dccdir} \
-       DCC_CGIBINDIR=$RPM_BUILD_ROOT/home/services/http/html/cgi-bin \
+       MANOWN=$INST_UID \
+       MANGRP=$INST_GID \
+       DCC_SUID=$INST_UID \
+       DCC_OWN=$INST_UID \
+       DCC_GRP=$INST_GID \
+       BINOWN=$INST_UID \
+       GRP=$INST_GID \
+       INSTALL="install -C" \
+       INST_BINDIR=$RPM_BUILD_ROOT%{cgidir} \
+       DCC_HOMEDIR=$RPM_BUILD_ROOT%{dccdir} \
+       DCC_CGIBINDIR=$RPM_BUILD_ROOT%{cgidir} \
        DCC_LIBEXECDIR=$RPM_BUILD_ROOT%{_sbindir} \
        DCC_BINDIR=$RPM_BUILD_ROOT%{_sbindir} \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -182,13 +200,13 @@ install homedir/flod $RPM_BUILD_ROOT%{dccdir}/flod
 
 # move some binaries in place, wierd stuff...
 for i in dbclean dblist dccd dccifd dccsight wlist; do
-    mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_sbindir}/
+       mv -f $RPM_BUILD_ROOT%{_bindir}/$i $RPM_BUILD_ROOT%{_sbindir}
 done
-mv -f $RPM_BUILD_ROOT%{dccdir}
+
 # install extras
-install dccifd/dccif-test/dccif-test $RPM_BUILD_ROOT%{_sbindir}/
-install dccifd/dccif-test/dccif-test.pl $RPM_BUILD_ROOT%{_sbindir}/
-install dccifd/dccif.pl $RPM_BUILD_ROOT%{_sbindir}/
+install dccifd/dccif-test/dccif-test $RPM_BUILD_ROOT%{_sbindir}
+install dccifd/dccif-test/dccif-test.pl $RPM_BUILD_ROOT%{_sbindir}
+install dccifd/dccif.pl $RPM_BUILD_ROOT%{_sbindir}
 
 # Set some initial logging, but no rejections
 perl -p -i -e "s/BRAND=\$/BRAND=%{version}-%{release}/ ; s/DCCM_LOG_AT=\$/\$&10/ ; " \
@@ -200,13 +218,13 @@ cp homedir/README README.homedir
 cp cgi-bin/README README.cgi-bin
 
 # install devel files
-install dccd/*.h $RPM_BUILD_ROOT%{_includedir}/dcc/
-install dcclib/*.h $RPM_BUILD_ROOT%{_includedir}/dcc/
-install include/*.h $RPM_BUILD_ROOT%{_includedir}/dcc/
-install srvrlib/*.h $RPM_BUILD_ROOT%{_includedir}/dcc/
-install dcclib/libdcc.a $RPM_BUILD_ROOT%{_libdir}/
-install srvrlib/libsrvr.a $RPM_BUILD_ROOT%{_libdir}/
-install thrlib/libthr.a $RPM_BUILD_ROOT%{_libdir}/
+install dccd/*.h $RPM_BUILD_ROOT%{_includedir}/dcc
+install dcclib/*.h $RPM_BUILD_ROOT%{_includedir}/dcc
+install include/*.h $RPM_BUILD_ROOT%{_includedir}/dcc
+install srvrlib/*.h $RPM_BUILD_ROOT%{_includedir}/dcc
+install dcclib/libdcc.a $RPM_BUILD_ROOT%{_libdir}
+install srvrlib/libsrvr.a $RPM_BUILD_ROOT%{_libdir}
+install thrlib/libthr.a $RPM_BUILD_ROOT%{_libdir}
 
 # house cleaning
 rm -f $RPM_BUILD_ROOT/var/www/dcc-bin/README
@@ -219,18 +237,18 @@ rm -f $RPM_BUILD_ROOT%{_sbindir}/updatedcc
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-/usr/sbin/useradd -d /var/dcc -r dcc >/dev/null 2>&1 || :
+# TODO register userid in uid_gid.db.txt
+%useradd -u XXX -d %{dccdir} -r dcc
 
 %postun
 if [ $1 = 0 ]; then
-        /usr/sbin/userdel -r dcc > /dev/null 2>&1 || :
+       %userremove dcc
 fi
 
 %post
-/sbin/chkconfig --add dccd || :
-/sbin/chkconfig --level 016 dccd off || :
+/sbin/chkconfig --add dccd
 umask 022
-/usr/bin/cdcc info > %{dccdir}/map.txt || :
+/usr/bin/cdcc info > %{dccdir}/map.txt
 
 %post cgi
 echo The scripts need configured and added into your web configuration.
@@ -244,6 +262,11 @@ fi
 
 %files
 %defattr(644,root,root,755)
+%doc CHANGES FAQ.html FAQ.txt INSTALL.html INSTALL.txt LICENSE cdcc.html
+%doc dbclean.html dblist.html dccd.html dcc.html dccproc.html
+%doc dccsight.html homedir/flod homedir/ids homedir/map.txt homedir/README
+%doc misc/dcc.m4 misc/dccdnsbl.m4 misc/hackmc
+#%doc dccm.html 
 %dir %{dccdir}
 %dir %{dccdir}/log
 %dir %{dccdir}/userdirs/local
@@ -251,11 +274,6 @@ fi
 %dir %{dccdir}/userdirs/procmail
 %dir %{dccdir}/userdirs/esmtp
 %dir /var/run/dcc
-%doc CHANGES FAQ.html FAQ.txt INSTALL.html INSTALL.txt LICENSE cdcc.html
-%doc dbclean.html dblist.html dccd.html dcc.html dccproc.html
-%doc dccsight.html homedir/flod homedir/ids homedir/map.txt homedir/README
-%doc misc/dcc.m4 misc/dccdnsbl.m4 misc/hackmc misc/na-spam misc/ng-spam
-#%doc dccm.html 
 %config(noreplace) %verify(not size mtime md5) %{dccdir}/dcc_conf
 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whiteclnt
 %config(noreplace) %verify(not size mtime md5) %{dccdir}/whitecommon
@@ -270,12 +288,14 @@ fi
 %{dccdir}/grey_whitelist
 
 %files client
+%defattr(644,root,root,755)
 %attr(4755,root,root) %{_bindir}/cdcc
 %attr(4755,root,root) %{_bindir}/dccproc
-%{_mandir}/man8/cdcc.8.gz
-%{_mandir}/man8/dccproc.8.gz
+%{_mandir}/man8/cdcc.8*
+%{_mandir}/man8/dccproc.8*
 
 %files server
+%defattr(644,root,root,755)
 %attr(754,root,root) /etc/rc.d/init.d/dccd
 %attr(750,root,root) /etc/cron.daily/dccd
 %attr(4755,root,root) %{_sbindir}/dccsight
@@ -291,10 +311,7 @@ fi
 %attr(755,root,root) %{_sbindir}/dccifd
 %attr(755,root,root) %{_sbindir}/fetch-testmsg-whitelist
 %attr(755,root,root) %{_sbindir}/hackmc
-%attr(755,root,root) %{_sbindir}/na-spam
 %attr(755,root,root) %{_sbindir}/newwebuser
-%attr(755,root,root) %{_sbindir}/ng-spam
-%attr(755,root,root) %{_sbindir}/refeed
 %attr(755,root,root) %{_sbindir}/wlist
 # sendmail stuff
 #%attr(755,root,root) %{_sbindir}/dccm
@@ -306,22 +323,21 @@ fi
 %attr(755,root,root) %{_sbindir}/start-grey
 %attr(755,root,root) %{_sbindir}/stats-get
 %attr(755,root,root) %{_sbindir}/stop-dccd
-%{_mandir}/man8/dbclean.8.gz
-%{_mandir}/man8/dblist.8.gz
-%{_mandir}/man8/dcc.8.gz
-%{_mandir}/man8/dccd.8.gz
-%{_mandir}/man8/dccifd.8.gz
-%{_mandir}/man8/dccm.8.gz
-%{_mandir}/man8/dccsight.8.gz
+%{_mandir}/man8/dbclean.8*
+%{_mandir}/man8/dblist.8*
+%{_mandir}/man8/dcc.8*
+%{_mandir}/man8/dccd.8*
+%{_mandir}/man8/dccifd.8*
+%{_mandir}/man8/dccm.8*
+%{_mandir}/man8/dccsight.8*
 
 %files cgi
 %defattr(644,root,root,755)
-%dir /home/services/http/html/cgi-bin
-/home/services/http/html/cgi-bin/chgpasswd
-/home/services/http/html/cgi-bin/common
-/home/services/http/html/cgi-bin/edit-whiteclnt
-/home/services/http/html/cgi-bin/http2https
-/home/services/http/html/cgi-bin/list-log
-/home/services/http/html/cgi-bin/list-msg
-/home/services/http/html/cgi-bin/README
-/home/services/http/html/cgi-bin/webuser-notify
+%{cgidir}/chgpasswd
+%{cgidir}/common
+%{cgidir}/edit-whiteclnt
+%{cgidir}/http2https
+%{cgidir}/list-log
+%{cgidir}/list-msg
+%{cgidir}/README
+%{cgidir}/webuser-notify
This page took 0.11353 seconds and 4 git commands to generate.