]> git.pld-linux.org Git - packages/dbview.git/commitdiff
- spec taken from RH-contrib, icon probably from Caldera
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 4 Jul 2001 22:21:47 +0000 (22:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dbview-fixes.patch -> 1.1
    dbview-make.patch -> 1.1
    dbview.spec -> 1.1

dbview-fixes.patch [new file with mode: 0644]
dbview-make.patch [new file with mode: 0644]
dbview.spec [new file with mode: 0644]

diff --git a/dbview-fixes.patch b/dbview-fixes.patch
new file mode 100644 (file)
index 0000000..f5cc85e
--- /dev/null
@@ -0,0 +1,30 @@
+--- dbview-1.0.3.orig/db_dump.h        Tue Oct  8 09:18:40 1996
++++ dbview-1.0.3/db_dump.h     Wed Jul  4 22:06:16 2001
+@@ -72,7 +72,7 @@
+     char    type;                                               /*field type*/
+     /* A-T uses large data model but drop it for now */
+     char   *data_ptr;                         /*pointer into buffer*/
+-    char   length;                                   /*field length*/
++    unsigned char length;                     /*field length*/
+     char   dec_point;                         /*field decimal point*/
+     char   fill[14];
+     } DBASE_FIELD;
+--- dbview-1.0.3.orig/db_dump.c        Tue Oct  8 09:25:54 1996
++++ dbview-1.0.3/db_dump.c     Wed Jul  4 23:12:49 2001
+@@ -116,7 +116,7 @@
+ {
+     char *c=var;
+-    for (c+=strlen(var); isspace (*c); c--);
++    for (c+=strlen(var); c>=var && isspace (*c); c--);
+     *(++c) = '\0';
+     return var;
+@@ -210,7 +210,6 @@
+       stack_field(fld);
+     }
+     read(dbfile,Buffer,1);              /* read the silly little \r 0x0d character */
+-    read(dbfile,Buffer,1);              /* strange, it only works if we read another byte */
+     return;
+ }
diff --git a/dbview-make.patch b/dbview-make.patch
new file mode 100644 (file)
index 0000000..98a11bf
--- /dev/null
@@ -0,0 +1,51 @@
+--- dbview-1.0.3.orig/Makefile Thu Sep 26 22:05:30 1996
++++ dbview-1.0.3/Makefile      Wed Jul  4 22:04:37 2001
+@@ -19,7 +19,7 @@
+ MAN=man
+ CC= gcc
+-CFLAGS= -O6 -fomit-frame-pointer -Wall -pipe
++CFLAGS= $(OPT) -Wall -pipe
+ # CFLAGS= -g -fomit-frame-pointer -Wall -pipe
+ # Look where your install program is
+@@ -27,7 +27,7 @@
+ INSTALL = /usr/bin/install
+ prefix = /usr
+ bindir = $(prefix)/bin
+-mandir = $(prefix)/$(MAN)
++mandir = $(prefix)/share/$(MAN)
+ obj = db_dump.o dbview.o version.o
+@@ -43,10 +43,10 @@
+       makedepend *.c
+ install: all
+-      $(INSTALL) -d -o root -g root -m 755 $(bindir)
+-      $(INSTALL) -s -o root -g root -m 755 dbview $(bindir)
+-      $(INSTALL) -d -o $(MAN) -g $(MAN) -m 755 $(mandir)/man1
+-      $(INSTALL) -o $(MAN) -g $(MAN) -m 644 dbview.1 $(mandir)/man1
++      $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
++      $(INSTALL) -m 755 dbview $(DESTDIR)$(bindir)
++      $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
++      $(INSTALL) -m 644 dbview.1 $(DESTDIR)$(mandir)/man1
+ clean:
+       rm -f dbview *.o *.log *~ *.orig Makefile.bak;
+@@ -56,13 +56,5 @@
+ # DO NOT DELETE
+-db_dump.o: db_dump.h /usr/include/fcntl.h /usr/include/features.h
+-db_dump.o: /usr/include/sys/cdefs.h /usr/include/sys/types.h
+-db_dump.o: /usr/include/linux/types.h /usr/include/asm/types.h
+-db_dump.o: /usr/include/gnu/types.h /usr/include/linux/fcntl.h
+-db_dump.o: /usr/include/sys/stat.h /usr/include/linux/stat.h
+-db_dump.o: /usr/include/stdio.h /usr/include/libio.h /usr/include/_G_config.h
+-db_dump.o: /usr/include/unistd.h /usr/include/posix_opt.h
+-db_dump.o: /usr/include/confname.h /usr/include/malloc.h
+-dbview.o: version.h db_dump.h /usr/include/stdio.h /usr/include/libio.h
+-dbview.o: /usr/include/_G_config.h /usr/include/getopt.h
++db_dump.o: db_dump.h
++dbview.o: version.h db_dump.h
diff --git a/dbview.spec b/dbview.spec
new file mode 100644 (file)
index 0000000..fce1935
--- /dev/null
@@ -0,0 +1,47 @@
+Summary:       dbview - view dBase files
+Summary(pl):   Program do ogl±dania plików dBase
+Name:          dbview
+Version:       1.0.3
+Release:       4
+License:       GPL
+Group:         Applications/Databases
+Group(de):     Applikationen/Dateibanken
+Group(pl):     Aplikacje/Bazy danych
+Source0:       ftp://metalab.unc.edu/pub/Linux/apps/database/proprietary/%{name}-%{version}.tar.gz
+Patch0:                %{name}-make.patch
+Patch1:                %{name}-fixes.patch
+Icon:          %{name}.xpm
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+dbview is a little tool that will display dBase III and IV files. You
+can also use it to convert your old .dbf files for further use with
+Unix.
+
+%description -l pl
+dbview jest ma³ym programem wy¶wietlaj±cym zawarto¶æ plików dBase III
+i IV. Mo¿na go wykorzystaæ do konwersji starych plików .dbf do
+wykorzystania pod Uniksem.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+%{__make} OPT="%{rpmcflags}"
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
+
+gzip -9nf README dBASE
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc *.gz
+%attr(755,root,root) %{_bindir}/*
+%{_mandir}/man1/*
This page took 0.040862 seconds and 4 git commands to generate.