]> git.pld-linux.org Git - packages/dbus-c++.git/commitdiff
- added write patch (fix write buffer argument) auto/th/dbus-c++-0.9.0-5
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 23 Apr 2018 19:35:08 +0000 (21:35 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 23 Apr 2018 19:35:08 +0000 (21:35 +0200)
dbus-c++-write.patch [new file with mode: 0644]
dbus-c++.spec

diff --git a/dbus-c++-write.patch b/dbus-c++-write.patch
new file mode 100644 (file)
index 0000000..870c44b
--- /dev/null
@@ -0,0 +1,9 @@
+--- libdbus-c++-0.9.0/src/pipe.cpp.orig        2011-11-29 23:16:31.000000000 +0100
++++ libdbus-c++-0.9.0/src/pipe.cpp     2018-04-23 21:28:46.612510662 +0200
+@@ -83,5 +83,5 @@
+ void Pipe::signal()
+ {
+   // TODO: ignoring return of read/write generates warning; maybe relevant for eventloop work...
+-  ::write(_fd_write, '\0', 1);
++  ::write(_fd_write, "\0", 1);
+ }
index 33d8e70e81668134202c284095a003d80feb8bfb..33fb85efb2e4126c9377ca2a82e3416cbeed46f3 100644 (file)
@@ -15,6 +15,7 @@ Patch0:               %{name}-macros.patch
 Patch1:                %{name}-gcc4.7.patch
 Patch2:                %{name}-linkfix.patch
 Patch3:                %{name}-threading.patch
+Patch4:                %{name}-write.patch
 URL:           http://sourceforge.net/projects/dbus-cplusplus/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -146,6 +147,7 @@ Statyczna biblioteka dbus-c++-ecore.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
This page took 0.103546 seconds and 4 git commands to generate.