- Don't force specific jdk.
authorpawelz <pawelz@pld-linux.org>
Fri, 23 Apr 2010 00:01:49 +0000 (00:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    db4.8.spec -> 1.5

db4.8.spec

index 153a722..d857fac 100644 (file)
@@ -4,12 +4,6 @@
 %bcond_without tcl             # don't build Tcl bindings
 %bcond_without static_libs     # don't build static libraries
 
-%if "%{pld_release}" == "ti"
-%bcond_without java_sun        # build with gcj
-%else
-%bcond_with    java_sun        # build with java-sun
-%endif
-
 %include       /usr/lib/rpm/macros.java
 
 %define                libver          4.8
@@ -29,9 +23,7 @@ Source0:      http://download.oracle.com/berkeley-db/db-%{ver}.tar.gz
 URL:           http://www.oracle.com/technology/products/berkeley-db/index.html
 BuildRequires: automake
 %if %{with java}
-%{!?with_java_sun:BuildRequires:       java-gcj-compat-devel}
-%{?with_java_sun:BuildRequires:        java-sun}
-BuildRequires: rpm >= 4.4.9-56
+BuildRequires: jdk
 BuildRequires: rpm-javaprov
 %endif
 BuildRequires: libstdc++-devel
This page took 0.035244 seconds and 4 git commands to generate.