]> git.pld-linux.org Git - packages/db4.4.git/blobdiff - db4.4.spec
- updated URLs
[packages/db4.4.git] / db4.4.spec
index 3080876e28331df1eb87ba7906b0e0207538957b..1d612fbdb41b1f8eb7c4042ad50ca97364b80ce5 100644 (file)
@@ -1,33 +1,33 @@
 #
 # Conditional build:
 #
 # Conditional build:
-%bcond_with    java    # build db-java
-%bcond_without tcl     # don't build Tcl bindings
-%bcond_with    pmutex  # use POSIX mutexes (only process-private with linuxthreads)
-%bcond_without nptl    # don't use process-shared POSIX mutexes (NPTL provides full interface)
+%bcond_without java            # don't build Java library
+%bcond_without tcl             # don't build Tcl bindings
+%bcond_with    pmutex          # use POSIX mutexes (only process-private with linuxthreads)
+%bcond_without nptl            # don't use process-shared POSIX mutexes (NPTL provides full interface)
 %bcond_without static_libs     # don't build static libraries
 #
 %bcond_without static_libs     # don't build static libraries
 #
+%define                ver             4.4.20
+%define                patchlevel      4
 %{?with_nptl:%define   with_pmutex     1}
 Summary:       Berkeley DB database library for C
 Summary(pl.UTF-8):     Biblioteka C do obsługi baz Berkeley DB
 Name:          db4.4
 %{?with_nptl:%define   with_pmutex     1}
 Summary:       Berkeley DB database library for C
 Summary(pl.UTF-8):     Biblioteka C do obsługi baz Berkeley DB
 Name:          db4.4
-Version:       4.4.20
-Release:       2
+Version:       %{ver}.%{patchlevel}
+Release:       1
 Epoch:         0
 License:       Sleepycat public license (GPL-like, see LICENSE)
 Group:         Libraries
 Epoch:         0
 License:       Sleepycat public license (GPL-like, see LICENSE)
 Group:         Libraries
-# alternative site (sometimes working): http://www.berkeleydb.com/
-#Source0Download: http://dev.sleepycat.com/downloads/releasehistorybdb.html
-Source0:       http://downloads.sleepycat.com/db-%{version}.tar.gz
+#Source0Download: http://www.oracle.com/technetwork/database/berkeleydb/downloads/index-082944.html
+Source0:       http://download.oracle.com/berkeley-db/db-%{ver}.tar.gz
 # Source0-md5: d84dff288a19186b136b0daf7067ade3
 # Source0-md5: d84dff288a19186b136b0daf7067ade3
-Patch0:                http://www.sleepycat.com/update/4.4.20/patch.4.4.20.1
-Patch1:                http://www.sleepycat.com/update/4.4.20/patch.4.4.20.2
-URL:           http://www.sleepycat.com/
+%patchset_source -f http://download.oracle.com/berkeley-db/patches/db/%{ver}/patch.%{ver}.%g 1 %{patchlevel}
+URL:           http://www.oracle.com/technetwork/database/berkeleydb/downloads/index.html
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: ed
 %{?with_java:BuildRequires:    jdk}
 BuildRequires: libstdc++-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: ed
 %{?with_java:BuildRequires:    jdk}
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.2
 BuildRequires: sed >= 4.0
 %{?with_tcl:BuildRequires:     tcl-devel >= 8.4.0}
 Provides:      db = %{version}-%{release}
 BuildRequires: sed >= 4.0
 %{?with_tcl:BuildRequires:     tcl-devel >= 8.4.0}
 Provides:      db = %{version}-%{release}
@@ -238,19 +238,25 @@ Ten pakiet zawiera narzędzia do obsługi baz Berkeley DB z linii
 poleceń.
 
 %prep
 poleceń.
 
 %prep
-%setup -q -n db-%{version}
-%patch0 -p0
-%patch1 -p0
+%setup -q -n db-%{ver}
+# official patches
+%patchset_patch 1 %{patchlevel}
 
 
-%if !%{with nptl}
+%if %{without nptl}
 sed -i -e 's,AM_PTHREADS_SHARED("POSIX/.*,:,' dist/aclocal/mutex.ac
 %endif
 
 sed -i -e 's,AM_PTHREADS_SHARED("POSIX/.*,:,' dist/aclocal/mutex.ac
 %endif
 
+sed -i -e '/AC_PROG_LIBTOOL/aLT_OUTPUT' dist/configure.ac
+
 %build
 cd dist
 cp -f /usr/share/aclocal/libtool.m4 aclocal/libtool.ac
 %build
 cd dist
 cp -f /usr/share/aclocal/libtool.m4 aclocal/libtool.ac
+cp -f /usr/share/aclocal/ltoptions.m4 aclocal/ltoptions.ac
+cp -f /usr/share/aclocal/ltsugar.m4 aclocal/ltsugar.ac
+cp -f /usr/share/aclocal/ltversion.m4 aclocal/ltversion.ac
+cp -f /usr/share/aclocal/lt~obsolete.m4 aclocal/lt~obsolete.ac
 cp -f /usr/share/automake/config.sub .
 cp -f /usr/share/automake/config.sub .
-cp -f /usr/share/libtool/ltmain.sh .
+cp -f /usr/share/libtool/config/ltmain.sh .
 sh s_config
 cd ..
 
 sh s_config
 cd ..
 
@@ -310,14 +316,14 @@ install -d $RPM_BUILD_ROOT%{_javadir}
 
 %if %{with static_libs}
 %{__make} -C build_unix.static library_install \
 
 %if %{with static_libs}
 %{__make} -C build_unix.static library_install \
-       docdir=%{_docdir}/db-%{version}-docs \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       docdir=%{_docdir}/db-%{version}-docs
 %endif
 
 %{__make} -C build_unix library_install \
 %endif
 
 %{__make} -C build_unix library_install \
-       docdir=%{_docdir}/db-%{version}-docs \
        DESTDIR=$RPM_BUILD_ROOT \
        DESTDIR=$RPM_BUILD_ROOT \
-       LIB_INSTALL_FILE_LIST=""
+       LIB_INSTALL_FILE_LIST="" \
+       docdir=%{_docdir}/db-%{version}-docs
 
 mv $RPM_BUILD_ROOT%{_libdir}/libdb-4.4.so $RPM_BUILD_ROOT/%{_lib}
 
 
 mv $RPM_BUILD_ROOT%{_libdir}/libdb-4.4.so $RPM_BUILD_ROOT/%{_lib}
 
@@ -362,6 +368,8 @@ cp -rf examples_cxx/* $RPM_BUILD_ROOT%{_examplesdir}/db-cxx-%{version}
 %if %{with java}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
 cp -rf examples_java/* $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
 %if %{with java}
 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
 cp -rf examples_java/* $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
+%else
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/db-%{version}-docs/java
 %endif
 
 %clean
 %endif
 
 %clean
This page took 0.120007 seconds and 4 git commands to generate.