]> git.pld-linux.org Git - packages/db.git/commitdiff
- posixmutexes handling fix (now only private cap depends on build env)
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 24 Jul 2004 20:38:02 +0000 (20:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed libdb and libdb_tcl linking

Changed files:
    db.spec -> 1.57

db.spec

diff --git a/db.spec b/db.spec
index 247186d49e318b5f154474b7220308f3dc2e9430..7e4435610709cfd75053618ee7d6337d7ca864c0 100644 (file)
--- a/db.spec
+++ b/db.spec
@@ -2,8 +2,10 @@
 # Conditional build:
 %bcond_with    java    # build db-java (required for openoffice)
 %bcond_without tcl     # don't build tcl bindings
-%bcond_with    nptl    # enable posix mutexes
+%bcond_with    pmutex  # use POSIX mutexes (only process-private with linuxthreads)
+%bcond_with    nptl    # synonym for pmutex (NPTL provides full interface)
 #
+%{?with_nptl:%define   pmutex  1}
 Summary:       Berkeley DB database library for C
 Summary(pl):   Biblioteka C do obsĀ³ugi baz Berkeley DB
 Name:          db
@@ -244,7 +246,7 @@ CC="%{__cc}"
 CXX="%{__cxx}"
 CFLAGS="%{rpmcflags}"
 CXXFLAGS="%{rpmcflags} -fno-implicit-templates"
-LDFLAGS="%{rpmldflags} %{?with_nptl:-lpthread}"
+LDFLAGS="%{rpmldflags}"
 export CC CXX CFLAGS CXXFLAGS LDFLAGS
 
 ../dist/%configure \
@@ -252,7 +254,7 @@ export CC CXX CFLAGS CXXFLAGS LDFLAGS
        --disable-shared \
        --enable-static \
        --enable-rpc \
-       %{?with_nptl:--enable-posixmutexes} \
+       --%{?with_pmutex:en}%{!?with_pmutex:dis}able-posixmutexes \
        --enable-cxx
 
 # (temporarily?) disabled because of compilation errors:
@@ -267,7 +269,7 @@ cd ../build_unix
        --libdir=%{_libdir} \
        --enable-compat185 \
        --enable-rpc \
-       %{?with_nptl:--enable-posixmutexes} \
+       --%{?with_pmutex:en}%{!?with_pmutex:dis}able-posixmutexes \
        --enable-cxx \
        %{?with_tcl:--enable-tcl} \
        %{?with_tcl:--with-tcl=/usr/lib} \
@@ -276,7 +278,9 @@ cd ../build_unix
        --enable-shared 
 
 %{__make} library_build \
-       TCFLAGS='-I$(builddir) -I%{_includedir}'
+       TCFLAGS='-I$(builddir) -I%{_includedir}' \
+       LIBSO_LIBS="\$(LIBS)" \
+       LIBTSO_LIBS="\$(LIBS) -ltcl"
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.067877 seconds and 4 git commands to generate.