]> git.pld-linux.org Git - packages/davfs.git/blob - davfs.spec
fdf4c736f357618c13c88f4391f090c6baa0ae38
[packages/davfs.git] / davfs.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel          without kernel from distribution
4 #
5 %define         _rel    1
6
7 Summary:        Web-based Distributed Authoring and Versioning
8 Summary(pl):    Bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie
9 Name:           davfs
10 Version:        0.2.4
11 Release:        %{_rel}
12 License:        GPL
13 Group:          Base/Kernel
14 Source0:        http://dl.sourceforge.net/dav/%{name}-%{version}.tar.gz
15 # Source0-md5:  705a99583a118ef3325551d700e49caa
16 Patch0:         %{name}-path.patch
17 Patch1:         %{name}-is_socket_ready.patch
18 URL:            http://dav.sourceforge.net/
19 %{!?_without_dist_kernel:BuildRequires: kernel-headers}
20 BuildRequires:  autoconf
21 BuildRequires:  %{kgcc_package}
22 BuildRequires:  openssl-devel >= 0.9.7
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     /etc
26
27 %description
28 WebDAV is an acronym for Web-based Distributed Authoring and Version-
29 ing. Usually http is a read only protocol, but if you install DAV on
30 your web server, it becomes writable. Furthermore, if you use DAVfs,
31 you can mount your web server onto your filesystem and can use it as a
32 normal disk.
33
34 %description -l pl
35 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
36 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
37 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
38 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
39 u¿ywaæ tak jak normalnego dysku.
40
41 %package -n kernel-fs-davfs
42 Summary:        DAVfs - Drivers
43 Summary(pl):    DAVfs - Sterowniki
44 Release:        %{_rel}@%{_kernel_ver_str}
45 Group:          Base/Kernel
46 %{!?_without_dist_kernel:%requires_releq_kernel_up}
47 Requires(post,postun):  /sbin/depmod
48
49 %description -n kernel-fs-davfs
50 WebDAV is an acronym for Web-based Distributed Authoring and Version-
51 ing. Usually http is a read only protocol, but if you install DAV on
52 your web server, it becomes writable. Furthermore, if you use DAVfs,
53 you can mount your web server onto your filesystem and can use it as a
54 normal disk.
55
56 %description -n kernel-fs-davfs -l pl
57 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
58 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
59 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
60 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
61 u¿ywaæ tak jak normalnego dysku.
62
63 %package -n kernel-smp-fs-davfs
64 Summary:        DAVfs - SMP Drivers
65 Summary(pl):    DAVfs - Sterowniki SMP
66 Release:        %{_rel}@%{_kernel_ver_str}
67 Group:          Base/Kernel
68 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
69 Requires(post,postun):  /sbin/depmod
70
71 %description -n kernel-smp-fs-davfs
72 WebDAV is an acronym for Web-based Distributed Authoring and Version-
73 ing. Usually http is a read only protocol, but if you install DAV on
74 your web server, it becomes writable. Furthermore, if you use DAVfs,
75 you can mount your web server onto your filesystem and can use it as a
76 normal disk.
77
78 %description -n kernel-smp-fs-davfs -l pl
79 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
80 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
81 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
82 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
83 u¿ywaæ tak jak normalnego dysku.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 %configure2_13 \
92         --with-ssl \
93         --with-kernel=%{_kernelsrcdir}
94 %{__make}
95
96 %{__make} -C davfs clean all \
97         CC=%{kgcc} \
98         CFLAGS="-O2 -D__KERNEL__ -DMODULE -D__SMP__ -DCONFIG_X86_LOCAL_APIC \
99         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
100         -fno-strict-aliasing -pipe -fno-strength-reduce"
101 mv -f davfs/davfs.o davfs-smp.o
102
103 %{__make} -C davfs clean all \
104         CC=%{kgcc} \
105         CFLAGS="-O2 -D__KERNEL__ -DMODULE \
106         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
107         -fno-strict-aliasing -pipe -fno-strength-reduce"
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{/sbin,/etc/rc.d/init.d}
112 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
113
114 echo "all install:" > davfs/Makefile
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install davfs/davfs.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/davfs.o
120 install davfs-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/davfs.o
121 ln -sf %{_sbindir}/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -n kernel-fs-davfs
127 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
128
129 %postun -n kernel-fs-davfs
130 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
131
132 %post   -n kernel-smp-fs-davfs
133 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver}smp }%{_kernel_ver}smp
134
135 %postun -n kernel-smp-fs-davfs
136 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver}smp }%{_kernel_ver}smp
137
138 %files
139 %defattr(644,root,root,755)
140 %doc ChangeLog doc/*.html
141 %attr(755,root,root) /sbin/*
142 %attr(755,root,root) %{_sbindir}/*
143
144 %files -n kernel-fs-davfs
145 %defattr(644,root,root,755)
146 /lib/modules/%{_kernel_ver}/misc/*.o*
147
148 %files -n kernel-smp-fs-davfs
149 %defattr(644,root,root,755)
150 /lib/modules/%{_kernel_ver}smp/misc/*.o*
This page took 0.03706 seconds and 2 git commands to generate.