]> git.pld-linux.org Git - packages/davfs.git/blob - davfs.spec
4d155054e4a9a3f0a00d86c84b644150 davfs-is_socket_ready.patch
[packages/davfs.git] / davfs.spec
1
2 # conditional build
3 # _without_dist_kernel          without kernel from distribution
4
5 %define         _rel    1
6
7 Summary:        Web-based Distributed Authoring and Versioning
8 Summary(pl):    Bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie
9 Name:           davfs
10 Version:        0.2.4
11 Release:        %{_rel}
12 License:        GPL
13 Group:          Base/Kernel
14 Source0:        http://prdownloads.sourceforge.net/dav/%{name}-%{version}.tar.gz
15 Source1:        %{name}.init
16 Patch0:         %{name}-path.patch
17 URL:            http://dav.sourceforge.net/
18 %{!?_without_dist_kernel:BuildRequires: kernel-headers}
19 BuildRequires:  autoconf
20 BuildRequires:  %{kgcc_package}
21 BuildRequires:  openssl-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc
25
26 %description
27 WebDAV is an acronym for Web-based Distributed Authoring and Version-
28 ing. Usually http is a read only protocol, but if you install DAV on
29 your web server, it becomes writable. Furthermore, if you use DAVfs,
30 you can mount your web server onto your filesystem and can use it as a
31 normal disk.
32
33 %description -l pl
34 WebDAV to bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie.
35 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
36 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
37 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
38 u¿ywaæ tak jak normalnego dysku.
39
40 %package -n kernel-fs-davfs
41 Summary:        DAVfs - Drivers
42 Summary(pl):    DAVfs - Sterowniki
43 Release:        %{_rel}@%{_kernel_ver_str}
44 Group:          Base/Kernel
45 Prereq:         /sbin/depmod
46 %{!?_without_dist_kernel:%requires_releq_kernel_up}
47
48
49 %description -n kernel-fs-davfs
50 WebDAV is an acronym for Web-based Distributed Authoring and Version-
51 ing. Usually http is a read only protocol, but if you install DAV on
52 your web server, it becomes writable. Furthermore, if you use DAVfs,
53 you can mount your web server onto your filesystem and can use it as a
54 normal disk.
55
56 %description -n kernel-fs-davfs -l pl
57 WebDAV to bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie.
58 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
59 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
60 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
61 u¿ywaæ tak jak normalnego dysku.
62
63 %package -n kernel-smp-fs-davfs
64 Summary:        DAVfs - SMP Drivers
65 Summary(pl):    DAVfs - Sterowniki SMP
66 Release:        %{_rel}@%{_kernel_ver_str}
67 Group:          Base/Kernel
68 Prereq:         /sbin/depmod
69 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
70
71 %description -n kernel-smp-fs-davfs
72 WebDAV is an acronym for Web-based Distributed Authoring and Version-
73 ing. Usually http is a read only protocol, but if you install DAV on
74 your web server, it becomes writable. Furthermore, if you use DAVfs,
75 you can mount your web server onto your filesystem and can use it as a
76 normal disk.
77
78 %description -n kernel-smp-fs-davfs -l pl
79 WebDAV to bazuj±cy na WWW Rozproszone Autoryzowanie i Wersjonowanie.
80 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
81 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
82 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
83 u¿ywaæ tak jak normalnego dysku.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 %configure2_13 \
91         --with-ssl \
92         --with-kernel=%{_kernelsrcdir}
93 %{__make}
94
95 %{__make} -C davfs clean all \
96         CC=%{kgcc} \
97         CFLAGS="-O2 -D__KERNEL__ -DMODULE -D__SMP__ -DCONFIG_X86_LOCAL_APIC \
98         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
99         -fno-strict-aliasing -pipe -fno-strength-reduce"
100 mv davfs/davfs.o davfs-smp.o
101
102 %{__make} -C davfs clean all \
103         CC=%{kgcc} \
104         CFLAGS="-O2 -D__KERNEL__ -DMODULE \
105         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
106         -fno-strict-aliasing -pipe -fno-strength-reduce"
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/rc.d/init.d}
111 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
112
113 echo "all install:" > davfs/Makefile
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install davfs/davfs.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/davfs.o
119 install davfs-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/davfs.o
120 ln -s %{_sbindir}/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
121
122 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/davfsd
123
124 gzip -9nf ChangeLog
125
126 %post   -n kernel-fs-davfs
127 /sbin/depmod -a
128
129 %postun -n kernel-fs-davfs
130 /sbin/depmod -a
131
132 %post   -n kernel-smp-fs-davfs
133 /sbin/depmod -a
134
135 %postun -n kernel-smp-fs-davfs
136 /sbin/depmod -a
137
138 %post
139 /sbin/chkconfig --add davfsd
140 if [ -f /var/lock/subsys/davfsd ]; then
141         /etc/rc.d/init.d/davfsd restart 1>&2
142 else
143         echo "Run \"/etc/rc.d/init.d/davfsd start\" to start davfsd daemon."
144 fi
145
146 %preun
147 if [ "$1" = "0" ]; then
148         if [ -f /var/lock/subsys/davfsd ]; then
149                 /etc/rc.d/init.d/davfsd stop 1>&2
150         fi
151         /sbin/chkconfig --del davfsd
152 fi
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files
158 %defattr(644,root,root,755)
159 %doc *.gz doc/*.html
160 %attr(755,root,root) /sbin/*
161 %attr(755,root,root) %{_sbindir}/*
162 %attr(754,root,root) /etc/rc.d/init.d/davfsd
163
164 %files -n kernel-fs-davfs
165 %defattr(644,root,root,755)
166 %attr(600,root,root) /lib/modules/%{_kernel_ver}/misc/*.o
167
168 %files -n kernel-smp-fs-davfs
169 %defattr(644,root,root,755)
170 %attr(600,root,root) /lib/modules/%{_kernel_ver}smp/misc/*.o
This page took 0.078572 seconds and 3 git commands to generate.