]> git.pld-linux.org Git - packages/davfs.git/blob - davfs.spec
- added using depmod macro
[packages/davfs.git] / davfs.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel          without kernel from distribution
4 #
5 %define         _rel    1
6
7 Summary:        Web-based Distributed Authoring and Versioning
8 Summary(pl):    Bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie
9 Name:           davfs
10 Version:        0.2.4
11 Release:        %{_rel}
12 License:        GPL
13 Group:          Base/Kernel
14 Source0:        http://dl.sourceforge.net/dav/%{name}-%{version}.tar.gz
15 # Source0-md5:  705a99583a118ef3325551d700e49caa
16 Patch0:         %{name}-path.patch
17 Patch1:         %{name}-is_socket_ready.patch
18 URL:            http://dav.sourceforge.net/
19 %{!?_without_dist_kernel:BuildRequires: kernel-headers}
20 BuildRequires:  autoconf
21 BuildRequires:  %{kgcc_package}
22 BuildRequires:  openssl-devel >= 0.9.7
23 BuildRequires:  rpmbuild(macros) >= 1.118
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc
27
28 %description
29 WebDAV is an acronym for Web-based Distributed Authoring and Version-
30 ing. Usually http is a read only protocol, but if you install DAV on
31 your web server, it becomes writable. Furthermore, if you use DAVfs,
32 you can mount your web server onto your filesystem and can use it as a
33 normal disk.
34
35 %description -l pl
36 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
37 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
38 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
39 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
40 u¿ywaæ tak jak normalnego dysku.
41
42 %package -n kernel-fs-davfs
43 Summary:        DAVfs - Drivers
44 Summary(pl):    DAVfs - Sterowniki
45 Release:        %{_rel}@%{_kernel_ver_str}
46 Group:          Base/Kernel
47 %{!?_without_dist_kernel:%requires_releq_kernel_up}
48 Requires(post,postun):  /sbin/depmod
49
50 %description -n kernel-fs-davfs
51 WebDAV is an acronym for Web-based Distributed Authoring and Version-
52 ing. Usually http is a read only protocol, but if you install DAV on
53 your web server, it becomes writable. Furthermore, if you use DAVfs,
54 you can mount your web server onto your filesystem and can use it as a
55 normal disk.
56
57 %description -n kernel-fs-davfs -l pl
58 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
59 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
60 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
61 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
62 u¿ywaæ tak jak normalnego dysku.
63
64 %package -n kernel-smp-fs-davfs
65 Summary:        DAVfs - SMP Drivers
66 Summary(pl):    DAVfs - Sterowniki SMP
67 Release:        %{_rel}@%{_kernel_ver_str}
68 Group:          Base/Kernel
69 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
70 Requires(post,postun):  /sbin/depmod
71
72 %description -n kernel-smp-fs-davfs
73 WebDAV is an acronym for Web-based Distributed Authoring and Version-
74 ing. Usually http is a read only protocol, but if you install DAV on
75 your web server, it becomes writable. Furthermore, if you use DAVfs,
76 you can mount your web server onto your filesystem and can use it as a
77 normal disk.
78
79 %description -n kernel-smp-fs-davfs -l pl
80 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
81 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
82 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
83 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
84 u¿ywaæ tak jak normalnego dysku.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90
91 %build
92 %configure2_13 \
93         --with-ssl \
94         --with-kernel=%{_kernelsrcdir}
95 %{__make}
96
97 %{__make} -C davfs clean all \
98         CC=%{kgcc} \
99         CFLAGS="-O2 -D__KERNEL__ -DMODULE -D__SMP__ -DCONFIG_X86_LOCAL_APIC \
100         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
101         -fno-strict-aliasing -pipe -fno-strength-reduce"
102 mv -f davfs/davfs.o davfs-smp.o
103
104 %{__make} -C davfs clean all \
105         CC=%{kgcc} \
106         CFLAGS="-O2 -D__KERNEL__ -DMODULE \
107         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
108         -fno-strict-aliasing -pipe -fno-strength-reduce"
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{/sbin,/etc/rc.d/init.d}
113 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
114
115 echo "all install:" > davfs/Makefile
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install davfs/davfs.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/davfs.o
121 install davfs-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/davfs.o
122 ln -sf %{_sbindir}/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -n kernel-fs-davfs
128 %depmod %{_kernel_ver}
129
130 %postun -n kernel-fs-davfs
131 %depmod %{_kernel_ver}
132
133 %post   -n kernel-smp-fs-davfs
134 %depmod %{_kernel_ver}smp
135
136 %postun -n kernel-smp-fs-davfs
137 %depmod %{_kernel_ver}smp
138
139 %files
140 %defattr(644,root,root,755)
141 %doc ChangeLog doc/*.html
142 %attr(755,root,root) /sbin/*
143 %attr(755,root,root) %{_sbindir}/*
144
145 %files -n kernel-fs-davfs
146 %defattr(644,root,root,755)
147 /lib/modules/%{_kernel_ver}/misc/*.o*
148
149 %files -n kernel-smp-fs-davfs
150 %defattr(644,root,root,755)
151 /lib/modules/%{_kernel_ver}smp/misc/*.o*
This page took 0.078738 seconds and 3 git commands to generate.