]> git.pld-linux.org Git - packages/davfs.git/blob - davfs.spec
47ecbb0831d4f9fa74df08985660005946b176aa
[packages/davfs.git] / davfs.spec
1
2 # conditional build
3 # _without_dist_kernel          without kernel from distribution
4
5 %define         _rel    1
6
7 Summary:        Web-based Distributed Authoring and Versioning
8 Summary(pl):    Bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie
9 Name:           davfs
10 Version:        0.2.4
11 Release:        %{_rel}
12 License:        GPL
13 Group:          Base/Kernel
14 Source0:        http://dl.sourceforge.net/dav/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-path.patch
16 Patch1:         %{name}-is_socket_ready.patch
17 URL:            http://dav.sourceforge.net/
18 %{!?_without_dist_kernel:BuildRequires: kernel-headers}
19 BuildRequires:  autoconf
20 BuildRequires:  %{kgcc_package}
21 BuildRequires:  openssl-devel >= 0.9.7
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc
25
26 %description
27 WebDAV is an acronym for Web-based Distributed Authoring and Version-
28 ing. Usually http is a read only protocol, but if you install DAV on
29 your web server, it becomes writable. Furthermore, if you use DAVfs,
30 you can mount your web server onto your filesystem and can use it as a
31 normal disk.
32
33 %description -l pl
34 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
35 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
36 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
37 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
38 u¿ywaæ tak jak normalnego dysku.
39
40 %package -n kernel-fs-davfs
41 Summary:        DAVfs - Drivers
42 Summary(pl):    DAVfs - Sterowniki
43 Release:        %{_rel}@%{_kernel_ver_str}
44 Group:          Base/Kernel
45 %{!?_without_dist_kernel:%requires_releq_kernel_up}
46 Requires(post,postun):  /sbin/depmod
47
48 %description -n kernel-fs-davfs
49 WebDAV is an acronym for Web-based Distributed Authoring and Version-
50 ing. Usually http is a read only protocol, but if you install DAV on
51 your web server, it becomes writable. Furthermore, if you use DAVfs,
52 you can mount your web server onto your filesystem and can use it as a
53 normal disk.
54
55 %description -n kernel-fs-davfs -l pl
56 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
57 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
58 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
59 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
60 u¿ywaæ tak jak normalnego dysku.
61
62 %package -n kernel-smp-fs-davfs
63 Summary:        DAVfs - SMP Drivers
64 Summary(pl):    DAVfs - Sterowniki SMP
65 Release:        %{_rel}@%{_kernel_ver_str}
66 Group:          Base/Kernel
67 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
68 Requires(post,postun):  /sbin/depmod
69
70 %description -n kernel-smp-fs-davfs
71 WebDAV is an acronym for Web-based Distributed Authoring and Version-
72 ing. Usually http is a read only protocol, but if you install DAV on
73 your web server, it becomes writable. Furthermore, if you use DAVfs,
74 you can mount your web server onto your filesystem and can use it as a
75 normal disk.
76
77 %description -n kernel-smp-fs-davfs -l pl
78 WebDAV to bazuj±ce na WWW Rozproszone Autoryzowanie i Wersjonowanie.
79 Zazwyczaj protokó³ http jest protoko³em tylko do odczytu ale po
80 zainstalowaniu DAVa staje siê on równie¿ zapisywalnym. Co wiêcej je¶li
81 u¿ywasz DAVfs to mo¿esz montowaæ swój serwer www jako system plików i
82 u¿ywaæ tak jak normalnego dysku.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88
89 %build
90 %configure2_13 \
91         --with-ssl \
92         --with-kernel=%{_kernelsrcdir}
93 %{__make}
94
95 %{__make} -C davfs clean all \
96         CC=%{kgcc} \
97         CFLAGS="-O2 -D__KERNEL__ -DMODULE -D__SMP__ -DCONFIG_X86_LOCAL_APIC \
98         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
99         -fno-strict-aliasing -pipe -fno-strength-reduce"
100 mv -f davfs/davfs.o davfs-smp.o
101
102 %{__make} -C davfs clean all \
103         CC=%{kgcc} \
104         CFLAGS="-O2 -D__KERNEL__ -DMODULE \
105         -I%{_kernelsrcdir}/include -Wall -Wstrict-prototypes -fomit-frame-pointer \
106         -fno-strict-aliasing -pipe -fno-strength-reduce"
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{/sbin,/etc/rc.d/init.d}
111 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
112
113 echo "all install:" > davfs/Makefile
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install davfs/davfs.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/davfs.o
119 install davfs-smp.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/davfs.o
120 ln -sf %{_sbindir}/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -n kernel-fs-davfs
126 /sbin/depmod -a
127
128 %postun -n kernel-fs-davfs
129 /sbin/depmod -a
130
131 %post   -n kernel-smp-fs-davfs
132 /sbin/depmod -a
133
134 %postun -n kernel-smp-fs-davfs
135 /sbin/depmod -a
136
137 %files
138 %defattr(644,root,root,755)
139 %doc ChangeLog doc/*.html
140 %attr(755,root,root) /sbin/*
141 %attr(755,root,root) %{_sbindir}/*
142
143 %files -n kernel-fs-davfs
144 %defattr(644,root,root,755)
145 /lib/modules/%{_kernel_ver}/misc/*.o*
146
147 %files -n kernel-smp-fs-davfs
148 %defattr(644,root,root,755)
149 /lib/modules/%{_kernel_ver}smp/misc/*.o*
This page took 0.042766 seconds and 2 git commands to generate.