]> git.pld-linux.org Git - packages/dash.git/commitdiff
- new
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 31 May 2006 23:00:42 +0000 (23:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dash.spec -> 1.1

dash.spec [new file with mode: 0644]

diff --git a/dash.spec b/dash.spec
new file mode 100644 (file)
index 0000000..ffa03da
--- /dev/null
+++ b/dash.spec
@@ -0,0 +1,56 @@
+Summary:       POSIX-compliant implementation of /bin/sh
+Name:          dash
+Version:       0.5.3
+Release:       0.1
+License:       GPL v2+
+Group:         Applications/Shells
+Source0:       http://gondor.apana.org.au/~herbert/dash/files/%{name}-%{version}.tar.gz
+# Source0-md5: 1a3cd6669459be4344ec55ec9d4914f8
+URL:           http://gondor.apana.org.au/~herbert/dash/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _bindir                 /bin
+%define                _shell                  %{_bindir}/posh
+
+%description
+DASH is a POSIX-compliant implementation of /bin/sh that aims to be as
+small as possible. It does this without sacrificing speed where
+possible. In fact, it is significantly faster than bash (the GNU
+Bourne-Again SHell) for most tasks.
+
+DASH is a direct descendant of the NetBSD version of ash (the Almquist
+SHell)
+
+%prep
+%setup -q
+
+%build
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+if [ ! -f /etc/shells ]; then
+       umask 022
+       echo '%{_shell}' > /etc/shells
+else
+       grep -q '^%{_shell}$' /etc/shells || echo '%{_shell}' >> /etc/shells
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       %{__sed} -i -e '/^%(echo %{_shell} | sed -e 's,/,\\/,g')$/d' /etc/shells
+fi
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/dash
+%{_mandir}/man1/dash.1*
This page took 0.131618 seconds and 4 git commands to generate.