]> git.pld-linux.org Git - packages/darktable.git/blob - darktable.spec
- updated to 1.4.2
[packages/darktable.git] / darktable.spec
1 #
2 # Conditional build:
3 %bcond_without  gegl    # build without GeGL
4 %bcond_without  gomp    # OpenMP threading support
5 %bcond_without  opencl  # OpenCL support
6 %bcond_with     vte     # lighttable mode shell ("file manager" April fool)
7
8 Summary:        darktable - a virtual lighttable and darkroom for photographers
9 Summary(pl.UTF-8):      darktable - wirtualny podświetlany stół i ciemnia dla fotografów
10 Name:           darktable
11 Version:        1.4.2
12 Release:        1
13 License:        GPL v3
14 Group:          X11/Applications/Graphics
15 Source0:        http://downloads.sourceforge.net/darktable/%{name}-%{version}.tar.xz
16 # Source0-md5:  f86554329c2c809ffb009244a6f1d643
17 Patch0:         cmake-glib.patch
18 URL:            http://darktable.sourceforge.net/
19 BuildRequires:  GraphicsMagick-devel
20 %{?with_opencl:BuildRequires:   OpenCL-devel}
21 BuildRequires:  OpenEXR-devel >= 2.0
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  SDL-devel >= 1.2
24 BuildRequires:  cairo-devel
25 BuildRequires:  cmake >= 2.6
26 BuildRequires:  colord-devel
27 BuildRequires:  curl-devel >= 7.18.0
28 BuildRequires:  dbus-glib-devel >= 0.80
29 BuildRequires:  desktop-file-utils
30 BuildRequires:  exiv2-devel
31 BuildRequires:  flickcurl-devel
32 BuildRequires:  fop
33 %{?with_gomp:BuildRequires:     gcc-c++ >= 6:4.3}
34 BuildRequires:  gdk-pixbuf2-devel >= 2
35 %{?with_gegl:BuildRequires:     gegl-devel}
36 BuildRequires:  gettext
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.30
39 BuildRequires:  gnome-doc-utils
40 BuildRequires:  gtk+2-devel >= 2:2.24
41 BuildRequires:  intltool
42 BuildRequires:  json-glib-devel
43 BuildRequires:  lcms2-devel >= 2
44 BuildRequires:  lensfun-devel
45 BuildRequires:  libglade2-devel
46 BuildRequires:  libgnome-keyring-devel
47 %{?with_gomp:BuildRequires:     libgomp-devel}
48 BuildRequires:  libgphoto2-devel >= 2.4.5
49 BuildRequires:  libjpeg-devel
50 BuildRequires:  libpng-devel
51 BuildRequires:  librsvg-devel >= 1:2.26
52 BuildRequires:  libsoup-devel >= 2
53 BuildRequires:  libtiff-devel
54 BuildRequires:  libwebp-devel >= 0.3.0
55 BuildRequires:  libxml2-devel >= 1:2.6
56 BuildRequires:  libxml2-progs
57 BuildRequires:  libxslt-progs
58 BuildRequires:  lua52-devel >= 5.2
59 BuildRequires:  openjpeg-devel >= 1.5.0
60 BuildRequires:  perl-tools-pod
61 BuildRequires:  pango-devel
62 BuildRequires:  pkgconfig >= 1:0.22
63 BuildRequires:  sqlite3-devel >= 3
64 BuildRequires:  squish-devel
65 %{?with_vte:BuildRequires:      vte-devel >= 0.26.0}
66 Requires(post,postun):  gtk-update-icon-cache
67 Requires(post,postun):  hicolor-icon-theme
68 Requires:       curl >= 7.18.0
69 Requires:       dbus-glib >= 0.80
70 Requires:       glib2 >= 1:2.30
71 Requires:       gtk+2 >= 2:2.24
72 Requires:       openjpeg >= 1.5.0
73 %{?with_vte:Requires:   vte >= 0.26.0}
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 darktable is a virtual lighttable and darkroom for photographers.
78
79 %description -l pl.UTF-8
80 darktable to wirtualny podświetlany stół i ciemnia dla fotografów.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85
86 %build
87 install -d build
88 cd build
89 %cmake .. \
90         %{?with_vte:-DAPRIL_FOOLS=ON} \
91         -DBINARY_PACKAGE_BUILD=ON \
92         -DPROJECT_VERSION:STRING="%{name}-%{version}-%{release}" \
93         %{!?with_opencl:-DUSE_OPENCL=OFF} \
94         %{!?with_gomp:-DUSE_OPENMP=OFF}
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
104
105 %{__mv} $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
106
107 %find_lang %{name} --with-gnome --with-omf
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %update_desktop_database_post
114 %update_icon_cache hicolor
115
116 %postun
117 %update_desktop_database_postun
118 %update_icon_cache hicolor
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %doc README.md RELEASE_NOTES doc/{AUTHORS,NEWS,README,TODO,TRANSLATORS,grouping.txt}
123 %attr(755,root,root) %{_bindir}/darktable
124 %attr(755,root,root) %{_bindir}/darktable-cli
125 %attr(755,root,root) %{_bindir}/darktable-cltest
126 %attr(755,root,root) %{_bindir}/darktable-viewer
127 %{_datadir}/appdata/darktable.appdata.xml
128 %{_datadir}/darktable
129 %{_desktopdir}/darktable.desktop
130 %{_iconsdir}/hicolor/*/apps/darktable.png
131 %{_iconsdir}/hicolor/scalable/apps/darktable*.svg
132 %dir %{_libdir}/darktable
133 %dir %{_libdir}/darktable/plugins
134 %dir %{_libdir}/darktable/plugins/imageio
135 %dir %{_libdir}/darktable/plugins/imageio/format
136 %dir %{_libdir}/darktable/plugins/imageio/storage
137 %dir %{_libdir}/darktable/plugins/lighttable
138 %dir %{_libdir}/darktable/views
139 %attr(755,root,root) %{_libdir}/darktable/libdarktable.so
140 %attr(755,root,root) %{_libdir}/darktable/plugins/*.so
141 %attr(755,root,root) %{_libdir}/darktable/plugins/imageio/format/*.so
142 %attr(755,root,root) %{_libdir}/darktable/plugins/imageio/storage/*.so
143 %attr(755,root,root) %{_libdir}/darktable/plugins/lighttable/*.so
144 %attr(755,root,root) %{_libdir}/darktable/views/*.so
145 %{_mandir}/man1/darktable.1*
146 %{_mandir}/man1/darktable-cli.1*
This page took 0.092512 seconds and 3 git commands to generate.