]> git.pld-linux.org Git - packages/darktable.git/blob - darktable.spec
3edeb941a52e8ba084370ddbeead3eae0b6230a4
[packages/darktable.git] / darktable.spec
1 #
2 # Conditional build:
3 %bcond_without  gegl    # build without GeGL
4 %bcond_without  openmp  # OpenMP threading support
5 %bcond_without  opencl  # OpenCL support
6 %bcond_with     vte     # lighttable mode shell ("file manager" April fool)
7
8 Summary:        darktable - a virtual lighttable and darkroom for photographers
9 Summary(pl.UTF-8):      darktable - wirtualny podświetlany stół i ciemnia dla fotografów
10 Name:           darktable
11 Version:        4.6.1
12 Release:        1
13 License:        GPL v3
14 Group:          X11/Applications/Graphics
15 Source0:        https://github.com/darktable-org/darktable/releases/download/release-%{version}/%{name}-%{version}.tar.xz
16 # Source0-md5:  e46c3dc0cf649f8b3b73f55153aabe97
17 URL:            https://www.darktable.org/
18 BuildRequires:  GraphicsMagick-devel
19 %{?with_opencl:BuildRequires:   OpenCL-devel}
20 BuildRequires:  OpenEXR-devel >= 3.0
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  SDL2-devel >= 2.0
23 BuildRequires:  cairo-devel
24 BuildRequires:  cmake >= 3.10
25 BuildRequires:  colord-devel
26 BuildRequires:  colord-gtk-devel
27 BuildRequires:  cups-devel
28 BuildRequires:  curl-devel >= 7.56.0
29 BuildRequires:  dbus-glib-devel >= 0.80
30 BuildRequires:  desktop-file-utils
31 BuildRequires:  exiftool
32 BuildRequires:  exiv2-devel >= 0.27.4
33 BuildRequires:  flickcurl-devel
34 BuildRequires:  fop
35 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.3}
36 BuildRequires:  gdk-pixbuf2-devel >= 2
37 %{?with_gegl:BuildRequires:     gegl-devel}
38 BuildRequires:  gettext
39 BuildRequires:  gettext-tools
40 BuildRequires:  glib2-devel >= 1:2.40
41 BuildRequires:  gnome-doc-utils
42 BuildRequires:  gtk+3-devel >= 3.24.15
43 BuildRequires:  intltool
44 BuildRequires:  iso-codes >= 4.4
45 BuildRequires:  json-glib-devel
46 BuildRequires:  lcms2-devel >= 2
47 BuildRequires:  lensfun-devel
48 BuildRequires:  libavif-devel >= 0.9.3
49 BuildRequires:  libglade2-devel
50 BuildRequires:  libgnome-keyring-devel
51 %{?with_openmp:BuildRequires:   libgomp-devel}
52 BuildRequires:  libgphoto2-devel >= 2.5
53 BuildRequires:  libheif-devel >= 1.16.0
54 BuildRequires:  libicu-devel
55 BuildRequires:  libjpeg-devel
56 BuildRequires:  libjxl-devel >= 0.7.0
57 BuildRequires:  libpng-devel
58 BuildRequires:  librsvg-devel >= 1:2.26
59 BuildRequires:  libsecret-devel
60 BuildRequires:  libsoup-devel >= 2
61 BuildRequires:  libtiff-devel
62 BuildRequires:  libwebp-devel >= 0.3.0
63 BuildRequires:  libwebp-devel >= 0.3.0
64 BuildRequires:  libxml2-devel >= 1:2.6
65 BuildRequires:  libxml2-progs
66 BuildRequires:  libxslt-progs
67 BuildRequires:  llvm-devel >= 12.0
68 BuildRequires:  lua54-devel >= 5.4
69 BuildRequires:  openjpeg-devel >= 1.5.0
70 BuildRequires:  pango-devel
71 BuildRequires:  perl-tools-pod
72 BuildRequires:  pkgconfig >= 1:0.22
73 BuildRequires:  po4a
74 BuildRequires:  pugixml-devel >= 1.8
75 BuildRequires:  python3-jsonschema
76 BuildRequires:  sqlite3-devel >= 3.24
77 BuildRequires:  squish-devel
78 %{?with_vte:BuildRequires:      vte-devel >= 0.26.0}
79 Requires(post,postun):  gtk-update-icon-cache
80 Requires(post,postun):  hicolor-icon-theme
81 Requires:       curl >= 7.56
82 Requires:       dbus-glib >= 0.80
83 Requires:       exiftool
84 Requires:       glib2 >= 1:2.30
85 Requires:       gtk+3 >= 3.24.15
86 Requires:       openjpeg >= 1.5.0
87 %{?with_vte:Requires:   vte >= 0.26.0}
88 ExclusiveArch:  %{x8664}
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %description
92 darktable is a virtual lighttable and darkroom for photographers.
93
94 %description -l pl.UTF-8
95 darktable to wirtualny podświetlany stół i ciemnia dla fotografów.
96
97 %prep
98 %setup -q
99
100 %build
101 install -d build
102 cd build
103 export CXXFLAGS="%{rpmcxxflags}"
104 %cmake .. \
105         -DCMAKE_BUILD_TYPE=%{!?debug:RELEASE}%{?debug:DEBUG} \
106         %{?with_vte:-DAPRIL_FOOLS=ON} \
107         -DBINARY_PACKAGE_BUILD=ON \
108         -DPROJECT_VERSION:STRING="%{version}" \
109         -DUSE_AVIF=OFF \
110         -DTESTBUILD_OPENCL_PROGRAMS=OFF \
111         %{!?with_opencl:-DUSE_OPENCL=OFF} \
112         %{!?with_openmp:-DUSE_OPENMP=OFF}
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT/etc/ld.so.conf.d
119 echo "%{_libdir}/%{name}" >$RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}.conf
120 %{__make} -C build install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
124
125 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{en@truecase,en}
126
127 %find_lang %{name} --with-gnome --with-omf
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 /sbin/ldconfig
134 %update_desktop_database_post
135 %update_icon_cache hicolor
136
137 %banner %{name} -e << EOF
138 =====================================================================
139
140 When updating from the stable 4.4.x series, please bear in mind that
141 your edits will be preserved during this process, but the new library
142 and configuration will no longer be usable with 4.4.x.
143
144 You are strongly advised to take a backup first.
145
146 =====================================================================
147 EOF
148
149 %postun
150 /sbin/ldconfig
151 %update_desktop_database_postun
152 %update_icon_cache hicolor
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS CONTRIBUTING.md README.md RELEASE_NOTES.md
157 %doc doc/{TRANSLATORS.md,grouping.txt,thumbnail_color_management.txt}
158 %attr(755,root,root) %{_bindir}/darktable
159 %attr(755,root,root) %{_bindir}/darktable-chart
160 %attr(755,root,root) %{_bindir}/darktable-cli
161 %attr(755,root,root) %{_bindir}/darktable-cltest
162 %attr(755,root,root) %{_bindir}/darktable-cmstest
163 %attr(755,root,root) %{_bindir}/darktable-generate-cache
164 %attr(755,root,root) %{_bindir}/darktable-rs-identify
165 /etc/ld.so.conf.d/%{name}.conf
166 %{_datadir}/metainfo/org.darktable.darktable.appdata.xml
167 %{_datadir}/darktable
168 %{_desktopdir}/org.darktable.darktable.desktop
169 %{_iconsdir}/hicolor/*/apps/darktable.png
170 %{_iconsdir}/hicolor/scalable/apps/darktable*.svg
171 %dir %{_libdir}/darktable
172 %dir %{_libdir}/darktable/plugins
173 %dir %{_libdir}/darktable/plugins/imageio
174 %dir %{_libdir}/darktable/plugins/imageio/format
175 %dir %{_libdir}/darktable/plugins/imageio/storage
176 %dir %{_libdir}/darktable/plugins/lighttable
177 %dir %{_libdir}/darktable/views
178 %attr(755,root,root) %{_libdir}/darktable/libdarktable.so
179 %attr(755,root,root) %{_libdir}/darktable/plugins/*.so
180 %attr(755,root,root) %{_libdir}/darktable/plugins/imageio/format/*.so
181 %attr(755,root,root) %{_libdir}/darktable/plugins/imageio/storage/*.so
182 %attr(755,root,root) %{_libdir}/darktable/plugins/lighttable/*.so
183 %attr(755,root,root) %{_libdir}/darktable/views/*.so
184 %lang(de) %{_mandir}/de/man1/darktable.1*
185 %lang(de) %{_mandir}/de/man1/darktable-cli.1*
186 %lang(de) %{_mandir}/de/man1/darktable-cltest.1*
187 %lang(de) %{_mandir}/de/man1/darktable-cmstest.1*
188 %lang(de) %{_mandir}/de/man1/darktable-generate-cache.1*
189 %lang(es) %{_mandir}/es/man1/darktable.1*
190 %lang(es) %{_mandir}/es/man1/darktable-cli.1*
191 %lang(es) %{_mandir}/es/man1/darktable-cltest.1*
192 %lang(es) %{_mandir}/es/man1/darktable-cmstest.1*
193 %lang(es) %{_mandir}/es/man1/darktable-generate-cache.1*
194 %lang(fr) %{_mandir}/fr/man1/darktable.1*
195 %lang(fr) %{_mandir}/fr/man1/darktable-cli.1*
196 %lang(fr) %{_mandir}/fr/man1/darktable-cltest.1*
197 %lang(fr) %{_mandir}/fr/man1/darktable-cmstest.1*
198 %lang(fr) %{_mandir}/fr/man1/darktable-generate-cache.1*
199 %{_mandir}/man1/darktable.1*
200 %{_mandir}/man1/darktable-cli.1*
201 %{_mandir}/man1/darktable-cltest.1*
202 %{_mandir}/man1/darktable-cmstest.1*
203 %{_mandir}/man1/darktable-generate-cache.1*
This page took 0.067285 seconds and 4 git commands to generate.