]> git.pld-linux.org Git - packages/dante.git/commitdiff
- added headers to devel, dante-1_1_9-1
authorkloczek <kloczek@pld-linux.org>
Thu, 15 Mar 2001 04:57:33 +0000 (04:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added static subpackage,
- simplifications in %install and %build,
- spec adapterized,
- few other fixes in %files.

Changed files:
    dante.spec -> 1.2

dante.spec

index e60d599946856da3f9e262df1787fb826ab4fe58..74cb8e1fa4674dc414a10392d69a8e56fbb419fa 100644 (file)
@@ -4,13 +4,14 @@ Version:      1.1.9
 Release:       1
 License:       BSD-type
 Group:         Networking/Daemons
-URL:           http://www.inet.no/dante/
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
 Source0:       ftp://ftp.inet.no/pub/socks/%{name}-%{version}.tar.gz
 Source1:       sockd.init
+URL:           http://www.inet.no/dante/
+BuildRequires: libwrap-devel
 Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define prefix %{_prefix}
-
 %description
 Dante is a free implementation of the proxy protocols socks version 4,
 socks version 5 (rfc1928) and msproxy. It can be used as a firewall
@@ -23,7 +24,9 @@ existing applications to become socks clients.
 %package server
 Summary:       A free Socks v4/v5 server implementation
 Group:         Networking/Daemons
-Requires:      dante = %{version}
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
+Requires:      %{name} = %{version}
 
 %description server
 This package contains the socks proxy daemon and its documentation.
@@ -33,44 +36,46 @@ allows socks clients to connect through it to the network.
 %package devel
 Summary:       development libraries for socks
 Group:         Networking/Daemons
-Requires:      dante = %{version}
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
+Requires:      %{name} = %{version}
 
 %description devel
 Additional libraries required to compile programs that use socks.
 
-%prep
-rm -rf $RPM_BUILD_ROOT
+%package static
+Summary:       static libraries for socks
+Group:         Networking/Daemons
+Group(de):     Netzwerkwesen/Server
+Group(pl):     Sieciowe/Serwery
+Requires:      %{name}-devel = %{version}
+
+%description static
+Static libraries for socks.
 
+%prep
 %setup -q
 
 %build
-
-CFLAGS="${RPM_OPT_FLAGS}" 
-%configure --prefix=%{_prefix}
+%configure
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%{__install} -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
 
-%{__make} install DESTDIR=${RPM_BUILD_ROOT}
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-#set library as executable - prevent ldd from complaining
-chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so.*.*
+%{__install} example/sock{s,d}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
 
-install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d ${RPM_BUILD_ROOT}%{_bindir}
+%{__install} %{SOURCE1} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/sockd
 
-install example/socks.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
-install example/sockd.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
-
-install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/sockd
-
-ln -sf %{_libdir}/libdsocks.so $RPM_BUILD_ROOT/%{_libdir}/libdsocks.so.0
+gzip -9nf BUGS CREDITS LICENSE NEWS README SUPPORT TODO
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-
+%post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %post server
@@ -78,35 +83,31 @@ rm -rf $RPM_BUILD_ROOT
 
 %postun server
 if [ $1 = 0 ]; then
-   /sbin/chkconfig --del sockd
+       /sbin/chkconfig --del sockd
 fi
 
 %files
 %defattr(644,root,root,755)
-#files beginning with two capital letters are docs: BUGS, README.foo etc.
-%doc [A-Z][A-Z]*
-%{_libdir}/libsocks.so.0.1.0
-%{_libdir}/libsocks.so.0
-%{_libdir}/libdsocks.so.0.1.0
-%{_libdir}/libdsocks.so.0
+%doc *.gz
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/socks.conf
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 %attr(755,root,root) %{_bindir}/socksify
 %{_mandir}/man5/socks.conf.5*
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/socks.conf
 
 %files server
 %defattr(644,root,root,755)
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sockd.conf
+%attr(754,root,root) /etc/rc.d/init.d/sockd
 %attr(755,root,root) %{_sbindir}/sockd
 %{_mandir}/man8/sockd.8*
 %{_mandir}/man5/sockd.conf.5*
 
-
-%config(noreplace) %verify(not size mtime md5)  %{_sysconfdir}/sockd.conf
-%config /etc/rc.d/init.d/sockd
-
 %files devel
 %defattr(644,root,root,755)
-%{_libdir}/libsocks.la
-%{_libdir}/libsocks.a
-%{_libdir}/libdsocks.la
-%{_libdir}/libsocks.so
-%{_libdir}/libdsocks.so
+%attr(755,root,root) %{_libdir}/lib*.so
+%attr(755,root,root) %{_libdir}/lib*.la
+%{_includedir}/*
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/lib*.a
This page took 0.256789 seconds and 4 git commands to generate.