]> git.pld-linux.org Git - packages/dante.git/blobdiff - dante.spec
- added format patch (fixes build with -Werror=format-security)
[packages/dante.git] / dante.spec
index a7317646b5179468e3c49a8215eba5ce7848fbc6..98eeb13759fa8594765b8b7b0a38166695e32548 100644 (file)
@@ -1,18 +1,33 @@
+# TODO:
+# - examine ldap and sasl support (deps are pulled into *.la, no direct linking anywhere?)
+#
+# Conditional build:
+%bcond_without upnp    # UPnP support (via miniupnp)
+#
 Summary:       A free Socks v4/v5 client implementation
-Summary(pl):   Darmowa implementacja klienta Socks v4/5
+Summary(pl.UTF-8):     Darmowa implementacja klienta Socks v4/5
 Name:          dante
-Version:       1.1.19
-%define pre pre1
-Release:       0.%{pre}.1
+Version:       1.4.1
+Release:       1
 License:       BSD-like
 Group:         Networking/Daemons
-Source0:       ftp://ftp.inet.no/pub/socks/%{name}-%{version}-%{pre}.tar.gz
-# Source0-md5: ef97770a0dd4f25b7a5bae2bb8972653
+Source0:       ftp://ftp.inet.no/pub/socks/%{name}-%{version}.tar.gz
+# Source0-md5: 68c2ce12119e12cea11a90c7a80efa8f
 Source1:       sockd.init
+Patch0:                %{name}-am.patch
+Patch1:                %{name}-build.patch
+Patch2:                %{name}-format.patch
 URL:           http://www.inet.no/dante/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.61
 BuildRequires: automake
+BuildRequires: cyrus-sasl-devel
+BuildRequires: heimdal-devel
+BuildRequires: libtool
 BuildRequires: libwrap-devel
+%{?with_upnp:BuildRequires:    miniupnpc-devel >= 1.6}
+BuildRequires: openldap-devel
+BuildRequires: pam-devel
+%{?with_upnp:Requires: miniupnpc >= 1.6}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -24,18 +39,18 @@ Norwegian consulting company. Commercial support is available.
 This package contains the dynamic libraries required to "socksify"
 existing applications to become socks clients.
 
-%description -l pl
-Dante jest darmow± implementacj± protoko³ów proxy: socks w wersji 4,
-socks w wersji 5 (rfc1928) oraz msproxy. Mo¿e byæ u¿ywany jako zapora
-pomiêdzy sieciami. Implementacja jest rozwijana przez Inferno Nettverk
-A/S - Norwesk± firmê konsultingow±. Komercyjne wsparcie jest dostêpne.
+%description -l pl.UTF-8
+Dante jest darmową implementacją protokołów proxy: socks w wersji 4,
+socks w wersji 5 (rfc1928) oraz msproxy. Może być używany jako zapora
+pomiędzy sieciami. Implementacja jest rozwijana przez Inferno Nettverk
+A/S - Norweską firmę konsultingową. Komercyjne wsparcie jest dostępne.
 
 Ten pakiet zawiera dynamiczne biblioteki wymagane do "usocksowiania"
-istniej±cych aplikacji tak by dzia³a³y one jako klienci socks.
+istniejących aplikacji tak by działały one jako klienci socks.
 
 %package server
 Summary:       A free Socks v4/v5 server implementation
-Summary(pl):   Darmowa implementacja serwera Socks v4/5
+Summary(pl.UTF-8):     Darmowa implementacja serwera Socks v4/5
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name} = %{version}-%{release}
@@ -46,44 +61,58 @@ This package contains the socks proxy daemon and its documentation.
 The sockd is the server part of the Dante socks proxy package and
 allows socks clients to connect through it to the network.
 
-%description server -l pl
-Ten pakiet zawiera serwer proxy socks oraz jego dokumentacjê. Serwer
-sockd jest czê¶ci± pakietu proxy Dante. Za po¶rednictwem serwera
-klienci mog± ³±czyæ siê z serwerami w sieci.
+%description server -l pl.UTF-8
+Ten pakiet zawiera serwer proxy socks oraz jego dokumentację. Serwer
+sockd jest częścią pakietu proxy Dante. Za pośrednictwem serwera
+klienci mogą łączyć się z serwerami w sieci.
 
 %package devel
-Summary:       Development libraries for socks
-Summary(pl):   Biblioteki developerskie dla socks
+Summary:       Development files for socks library
+Summary(pl.UTF-8):     Pliki programistyczne biblioteki socks
 Group:         Networking/Daemons
 Requires:      %{name} = %{version}-%{release}
+Requires:      cyrus-sasl-devel
+Requires:      heimdal-devel
+%{?with_upnp:Requires: miniupnpc-devel >= 1.6}
+Requires:      openldap-devel
+Requires:      pam-devel
 
 %description devel
-Additional libraries required to compile programs that use socks.
+Development files required to compile programs that use socks.
 
-%description devel -l pl
-Dodatkowe biblioteki wymagane do rozwoju programów korzystaj±cych z
+%description devel -l pl.UTF-8
+Pliki programistyczne wymagane do rozwoju programów korzystających z
 socks.
 
 %package static
-Summary:       Static libraries for socks
-Summary(pl):   Statyczne biblioteki socks
+Summary:       Static socks library
+Summary(pl.UTF-8):     Statyczna biblioteka socks
 Group:         Networking/Daemons
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
-Static libraries for socks.
+Static socks library.
 
-%description static -l pl
-Statyczne biblioteki socks.
+%description static -l pl.UTF-8
+Statyczna biblioteka socks.
 
 %prep
-%setup -q -n %{name}-%{version}-%{pre}
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
-cp -f /usr/share/automake/config.sub .
+%{__libtoolize}
+%{__aclocal}
 %{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
-       --disable-preload
+       --disable-silent-rules \
+       --without-glibc-secure \
+       %{!?with_upnp:--without-upnp}
+
 %{__make}
 
 %install
@@ -93,9 +122,9 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install example/sock{s,d}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
+install example/sock{s,d}.conf $RPM_BUILD_ROOT%{_sysconfdir}
 
-install %{SOURCE1} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/sockd
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/sockd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -121,11 +150,14 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc BUGS CREDITS LICENSE NEWS README SUPPORT TODO
+%doc BUGS CREDITS LICENSE NEWS README SUPPORT UPGRADE
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/socks.conf
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libsocks.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsocks.so.0
+%attr(755,root,root) %{_libdir}/libdsocks.so
 %attr(755,root,root) %{_bindir}/socksify
 %{_mandir}/man5/socks.conf.5*
+%{_mandir}/man1/socksify.1*
 
 %files server
 %defattr(644,root,root,755)
@@ -137,10 +169,11 @@ fi
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/*
+%attr(755,root,root) %{_libdir}/libsocks.so
+%{_libdir}/libsocks.la
+%{_libdir}/libdsocks.la
+%{_includedir}/socks.h
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libsocks.a
This page took 0.154025 seconds and 4 git commands to generate.