]> git.pld-linux.org Git - packages/dahdi-linux.git/commitdiff
- up to 2.10.2 auto/th/dahdi-linux-2.10.2-1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 29 Jun 2015 05:53:57 +0000 (07:53 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 29 Jun 2015 05:53:57 +0000 (07:53 +0200)
dahdi-linux.spec
ignore-void-value.patch [deleted file]
strnicmp.patch [deleted file]

index 2db8fefaa4c3d786ab64cb2d21485cc030a474d7..ca96567432543add850fa6267b77d4d2c7ede6e0 100644 (file)
@@ -35,18 +35,18 @@ exit 1
 %define                _enable_debug_packages  0
 %endif
 
-%define                rel     5
+%define                rel     1
 %define                pname   dahdi-linux
 %define                FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
 Summary:       DAHDI telephony device support
 Summary(pl.UTF-8):     Obsługa urządzeń telefonicznych DAHDI
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       2.10.1
+Version:       2.10.2
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
-# Source0-md5: 6ccb1bf79007ace9bc6d17fe1354bc21
+# Source0-md5: 0281de245f4fa056f765ae2a6e1f1a4b
 Source3:       %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
 # Source3-md5: 88db9b7a07d8392736171b1b3e6bcc66
 Source4:       %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
@@ -57,8 +57,6 @@ Source6:      %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
 # Source6-md5: 2ea860bb8a9d8ede2858b9557b74ee3c
 Source7:       %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
 # Source7-md5: a7f3886942bb3e9fed349a41b3390c9f
-Patch0:                ignore-void-value.patch
-Patch1:                strnicmp.patch
 URL:           http://www.asterisk.org/
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
 BuildRequires: perl-base
@@ -158,8 +156,6 @@ cd ../..\
 
 %prep
 %setup -q -n %{pname}-%{version}
-%patch0 -p1
-%patch1 -p1
 
 for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
        ln -s $a drivers/dahdi/firmware
diff --git a/ignore-void-value.patch b/ignore-void-value.patch
deleted file mode 100644 (file)
index dda4309..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From 1cc0ad510acd404e63923ed3062b9302d53580da Mon Sep 17 00:00:00 2001
-From: Shaun Ruffell <sruffell@digium.com>
-Date: Mon, 2 Mar 2015 09:00:13 -0600
-Subject: [PATCH] dahdi: Fix "void value not ignored..." error when compiling
- against kernel 4.0.
-
-With commit (d1f1052c52 "device: Change dev_<level> logging functions to return
-void") [1] in kernel version 4.0, DAHDI would fail to compile with the following
-error:
-
-  .../drivers/dahdi/dahdi-base.c:7150:2: error: void value not ignored as it ought to be
-    dahdi_dev_dbg(ASSIGN, span_device(span),
-    ^
-
-Now ignore the dev_printk return value.
-
-[1] https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d1f1052c5204524
-
-Signed-off-by: Shaun Ruffell <sruffell@digium.com>
-Acked-by: Tzafrir Cohen <tzafrir.cohen@xorcom.com>
----
- include/dahdi/kernel.h | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/include/dahdi/kernel.h b/include/dahdi/kernel.h
-index 365801d..54c415e 100644
---- a/include/dahdi/kernel.h
-+++ b/include/dahdi/kernel.h
-@@ -1665,9 +1665,11 @@ struct mutex {
-                               chan_printk(DEBUG, "-" #bits, chan, \
-                                       "%s: " fmt, __func__, ## __VA_ARGS__)))
- #define dahdi_dev_dbg(bits, dev, fmt, ...)         \
--                      ((void)((debug & (DAHDI_DBG_ ## bits)) && \
-+              do { if (debug & (DAHDI_DBG_ ## bits)) { \
-                       dev_printk(KERN_DEBUG, dev, \
--                      "DBG-%s(%s): " fmt, #bits, __func__, ## __VA_ARGS__)))
-+                      "DBG-%s(%s): " fmt, #bits, __func__, ## __VA_ARGS__); \
-+              } } while (0)
-+
- #endif /* DAHDI_PRINK_MACROS_USE_debug */
- #endif /* _DAHDI_KERNEL_H */
diff --git a/strnicmp.patch b/strnicmp.patch
deleted file mode 100644 (file)
index 9646008..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From 1559db9d1ae03780788788c07334ca54cdd1253a Mon Sep 17 00:00:00 2001
-From: Shaun Ruffell <sruffell@digium.com>
-Date: Mon, 2 Mar 2015 09:00:14 -0600
-Subject: [PATCH] dahdi: strnicmp() -> strncasecmp()
-
-With commit (af3cd13501 "lib/string.c: remove strnicmp()") [1] dahdi can no
-longer call strnicmp directly. strncasecmp was added into lib/string.c in kernel
-version 2.6.22 so we'll map calls to strncasecmp to strnicmp for any kernel
-before that.
-
-This is necessary to compile against kernels >= 4.0.
-
-[1] https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=af3cd13501
-
-Signed-off-by: Shaun Ruffell <sruffell@digium.com>
-Acked-by: Tzafrir Cohen <tzafrir.cohen@xorcom.com>
----
- drivers/dahdi/xpp/card_pri.c | 6 +++---
- include/dahdi/kernel.h       | 2 ++
- 2 files changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/drivers/dahdi/xpp/card_pri.c b/drivers/dahdi/xpp/card_pri.c
-index 29b457b..edc8bd2 100644
---- a/drivers/dahdi/xpp/card_pri.c
-+++ b/drivers/dahdi/xpp/card_pri.c
-@@ -2399,11 +2399,11 @@ static DEVICE_ATTR_WRITER(pri_protocol_store, dev, buf, count)
-                       buf, i);
-               return -EINVAL;
-       }
--      if (strnicmp(buf, "E1", 2) == 0)
-+      if (strncasecmp(buf, "E1", 2) == 0)
-               new_protocol = PRI_PROTO_E1;
--      else if (strnicmp(buf, "T1", 2) == 0)
-+      else if (strncasecmp(buf, "T1", 2) == 0)
-               new_protocol = PRI_PROTO_T1;
--      else if (strnicmp(buf, "J1", 2) == 0)
-+      else if (strncasecmp(buf, "J1", 2) == 0)
-               new_protocol = PRI_PROTO_J1;
-       else {
-               XPD_NOTICE(xpd,
-diff --git a/include/dahdi/kernel.h b/include/dahdi/kernel.h
-index 54c415e..90d48a3 100644
---- a/include/dahdi/kernel.h
-+++ b/include/dahdi/kernel.h
-@@ -1502,6 +1502,8 @@ void dahdi_pci_disable_link_state(struct pci_dev *pdev, int state);
- #define list_first_entry(ptr, type, member) \
-       list_entry((ptr)->next, type, member)
-+#define strncasecmp strnicmp
-+
- #ifndef __packed
- #define __packed  __attribute__((packed))
- #endif 
This page took 0.127765 seconds and 4 git commands to generate.