]> git.pld-linux.org Git - packages/cyrus-sasl.git/blobdiff - cyrus-sasl.spec
- fix completely broken logic in get_fqhostname
[packages/cyrus-sasl.git] / cyrus-sasl.spec
index 32e7bdcea6966226f24a52d764f598124b08a6ec..dce68b2dd2032692489cbf9cb0795644880d9cc3 100644 (file)
@@ -7,12 +7,12 @@
 %bcond_without gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
 %bcond_without mysql           # don't build MySQL pluggin
 %bcond_without pgsql           # do not build PostgreSQL pluggin
-%bcond_without sqlite          # do not enable sqlite plugin
+%bcond_without sqlite          # do not enable sqlite 2 plugin
+%bcond_without sqlite3         # do not enable sqlite 3 plugin
 %bcond_with    authlib         # enable courier-authlib (i wasn't able to test it)
-%bcond_with    opie            # enable opie plugin
-%bcond_with    srp             # build srp pluggin
+%bcond_with    opie            # OTP plugin using opie library instead of internal code
+%bcond_with    srp             # build srp plugin
 %bcond_with    pwcheck         # build pwcheck helper (deprecated)
-%bcond_with    x509            # build x509 plugin (no sources in package???)
 #
 %if %{without mysql} && %{without pgsql}
 %undefine with_cryptedpw
@@ -24,12 +24,12 @@ Summary(pt_BR.UTF-8):       Implementação da API SASL
 Summary(ru.UTF-8):     Библиотека Cyrus SASL
 Summary(uk.UTF-8):     Бібліотека Cyrus SASL
 Name:          cyrus-sasl
-Version:       2.1.23
-Release:       2
+Version:       2.1.25
+Release:       4.9
 License:       distributable
 Group:         Libraries
-Source0:       ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
-# Source0-md5: 2eb0e48106f0e9cd8001e654f267ecbc
+Source0:       ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
+# Source0-md5: 341cffe829a4d71f2a6503d669d5a946
 Source1:       saslauthd.init
 Source2:       saslauthd.sysconfig
 Source3:       %{name}.pam
@@ -43,15 +43,23 @@ Patch4:             %{name}-gcc4.patch
 Patch5:                %{name}-cryptedpw.patch
 Patch6:                %{name}-md5sum-passwords.patch
 Patch7:                %{name}-db.patch
-Patch8:                %{name}-automake_1_10.patch
-Patch9:                %{name}-digest-commas.patch
-Patch10:       %{name}-keytab.patch
-Patch11:       %{name}-sizes.patch
-Patch12:       %{name}-nagios-plugin.patch
-Patch13:       %{name}-parallel-make.patch
+Patch8:                %{name}-keytab.patch
+Patch9:                %{name}-sizes.patch
+Patch10:       %{name}-nagios-plugin.patch
+Patch11:       %{name}-parallel-make.patch
+Patch12:       %{name}-gssapi-detect.patch
+Patch13:       %{name}-saslauthd-httpform-urlescape.patch
+Patch14:       %{name}-ac-libs.patch
+Patch15:       %{name}-pam.patch
+Patch16:       %{name}-gssapi_ext.patch
+Patch17:       0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
+Patch18:       0033-fix_segfault_in_GSSAPI.patch
+Patch19:       0034-fix_dovecot_authentication.patch
+Patch20:       %{name}-auxprop.patch
+Patch21:       %{name}-get_fqhostname.patch
 URL:           http://asg.web.cmu.edu/sasl/
 BuildRequires: autoconf >= 2.54
-BuildRequires: automake
+BuildRequires: automake >= 1:1.7
 %{?with_authlib:BuildRequires: courier-authlib-devel}
 BuildRequires: db-devel
 BuildRequires: ed
@@ -59,14 +67,17 @@ BuildRequires:      groff
 %{?with_gssapi:BuildRequires:  heimdal-devel}
 BuildRequires: libtool >= 1.4
 %{?with_mysql:BuildRequires:   mysql-devel}
-%{?with_ldap:BuildRequires:    openldap-devel >= 2.4.6}
+%{?with_ldap:BuildRequires:    openldap-devel >= 2.3.0}
 BuildRequires: openssl-devel >= 0.9.7d
 %{?with_opie:BuildRequires:    opie-devel}
 BuildRequires: pam-devel
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: rpmbuild(macros) >= 1.268
 %{?with_sqlite:BuildRequires:  sqlite-devel}
+%{?with_sqlite3:BuildRequires: sqlite3-devel >= 3}
 Requires:      pam >= 0.79.0
+Requires:      %{name}-libs = %{version}-%{release}
+Obsoletes:     cyrus-sasl-x509 < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/sasl
@@ -108,6 +119,19 @@ Authentication and Security Layer, метод для добавления под
 Authentication and Security Layer, метод для додання підтримки
 аутентикації до протоколів, базованих на з'єднаннях.
 
+%package libs
+Summary:       cyrus-sasl library itself
+Summary(pl.UTF-8):     Sama biblioteka cyrus-sasl
+Group:         Libraries
+Requires(post,postun): /sbin/ldconfig
+Conflicts:     cyrus-sasl < 2.1.23-8
+
+%description libs
+cyrus-sasl library itself.
+
+%description libs -l pl.UTF-8
+Sama biblioteka cyrus-sasl.
+
 %package devel
 Summary:       Header files and documentation for cyrus-sasl
 Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja dla cyrus-sasl
@@ -158,6 +182,25 @@ Statyczne biblioteki cyrus-sasl.
 Статичні бібліотеки, необхідні для розробки програм, що використовують
 Cyrus SASL.
 
+%package anonymous
+Summary:       Anonymous Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka anonymous do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL ANONYMOUS
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description anonymous
+This plugin implements the SASL ANONYMOUS mechanism, used for
+anonymous authentication.
+
+%description anonymous -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
+anonimowego uwierzytelniania.
+
+%description anonymous -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
+autenticação anônima.
+
 %package cram-md5
 Summary:       Cram-MD5 Cyrus SASL plugin
 Summary(pl.UTF-8):     Wtyczka Cram-MD5 do Cyrus SASL
@@ -210,50 +253,6 @@ provavelmente será o novo sistema de autenticação obrigatório para
 protocolos novos. Ele é baseado na autenticação md5 digest
 desenvolvida para HTTP.
 
-%package plain
-Summary:       Plain Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka plain do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL PLAIN
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description plain
-This plugin implements the SASL PLAIN mechanism. Although insecure,
-PLAIN is useful for transitioning to new security mechanisms, as this
-is the only mechanism which gives the server a copy of the user's
-password.
-
-%description plain -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
-że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
-nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
-który udostępnia serwerowi kopię hasła użytkownika.
-
-%description plain -l pt_BR.UTF-8
-Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
-mecanismo é útil durante transições para novos mecanismos de
-segurança, pois é o único esquema que fornece uma cópia da senha do
-usuário para o servidor.
-
-%package anonymous
-Summary:       Anonymous Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka anonymous do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL ANONYMOUS
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description anonymous
-This plugin implements the SASL ANONYMOUS mechanism, used for
-anonymous authentication.
-
-%description anonymous -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
-anonimowego uwierzytelniania.
-
-%description anonymous -l pt_BR.UTF-8
-Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
-autenticação anônima.
-
 %package gssapi
 Summary:       GSSAPI Cyrus SASL plugin
 Summary(pl.UTF-8):     Wtyczka GSSAPI do Cyrus SASL
@@ -286,31 +285,17 @@ Unsupported LOGIN Cyrus SASL plugin.
 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
 SASL.
 
-%package srp
-Summary:       SRP Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka SRP do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL SRP
+%package mysql
+Summary:       Cyrus SASL MySQL plugin
+Summary(pl.UTF-8):     Wtyczka MySQL do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description srp
-This plugin implements the SASL SRP mechanism, based on the Secure
-Remote Password protocol. This mechanism performs mutual
-authentication and can provide a security layer with replay detection,
-integrity protection and/or condifentiality protection.
-
-%description srp -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
-protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
-uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
-powtarzania, zabezpieczeniem integralności i/lub poufności.
+%description mysql
+Cyrus SASL MySQL plugin.
 
-%description srp -l pt_BR.UTF-8
-Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
-(Secure Remote Password). Este mecanismo oferece autenticação mútua
-(do cliente e do servidor) e pode prover uma camada de segurança com
-detecção de ataques de replay, garantia de integridade e/ou
-confidencialidade.
+%description mysql -l pl.UTF-8
+Wtyczka MySQL do Cyrus SASL.
 
 %package otp
 Summary:       OTP Cyrus SASL plugin
@@ -318,6 +303,7 @@ Summary(pl.UTF-8):  Wtyczka OTP do Cyrus SASL
 Summary(pt_BR.UTF-8):  Mecanismo SASL OTP
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     cyrus-sasl-opie < %{version}
 
 %description otp
 This plugin implements the SASL OTP (One Time Password) mechanism.
@@ -326,106 +312,147 @@ This plugin implements the SASL OTP (One Time Password) mechanism.
 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
 SASL.
 
-%package opie
-Summary:       OPIE Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka OPIE do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL OPIE
+%package pgsql
+Summary:       Cyrus SASL PostgreSQL plugin
+Summary(pl.UTF-8):     Wtyczka PostgreSQL do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description opie
-This plugin implements the SASL OPIE (One Time Password) mechanism.
+%description pgsql
+Cyrus SASL PostgreSQL plugin.
 
-%description opie -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
-SASL.
+%description pgsql -l pl.UTF-8
+Wtyczka PostgreSQL do Cyrus SASL.
 
-%package x509
-Summary:       x509 Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka x509 do Cyrus SASL
+%package plain
+Summary:       Plain Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka plain do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL PLAIN
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description x509
-x509 Cyrus SASL plugin.
+%description plain
+This plugin implements the SASL PLAIN mechanism. Although insecure,
+PLAIN is useful for transitioning to new security mechanisms, as this
+is the only mechanism which gives the server a copy of the user's
+password.
+
+%description plain -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
+że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
+nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
+który udostępnia serwerowi kopię hasła użytkownika.
 
-%description x509 -l pl.UTF-8
-Wtyczka x509 do Cyrus SASL.
+%description plain -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
+mecanismo é útil durante transições para novos mecanismos de
+segurança, pois é o único esquema que fornece uma cópia da senha do
+usuário para o servidor.
 
-%package saslauthd
-Summary:       Cyrus SASL authd
-Summary(pl.UTF-8):     Demon authd do Cyrus SASL
-Group:         Daemons
-Requires(post,preun):  /sbin/chkconfig
+%package sasldb
+Summary:       Cyrus SASL sasldb plugin
+Summary(pl.UTF-8):     Wtyczka sasldb do Cyrus SASL
+Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      /sbin/chkconfig
-Requires:      rc-scripts
 
-%description saslauthd
-Cyrus SASL authd.
+%description sasldb
+Cyrus SASL sasldb plugin.
 
-%description saslauthd -l pl.UTF-8
-Demon authd do Cyrus SASL.
+%description sasldb -l pl.UTF-8
+Wtyczka sasldb do Cyrus SASL.
 
-%package pwcheck
-Summary:       Cyrus SASL pwcheck helper
-Summary(pl.UTF-8):     Program pomocniczy pwcheck do Cyrus SASL
+%package scram
+Summary:       SCRAM Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka SCRAM do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL SCRAM
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description pwcheck
-Cyrus SASL pwcheck helper.
+%description scram
+This plugin implements the SASL SCRAM-MD5 mechanism.
 
-%description pwcheck -l pl.UTF-8
-Program pomocniczy pwcheck do Cyrus SASL.
+%description scram -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
 
-%package sasldb
-Summary:       Cyrus SASL sasldb plugin
-Summary(pl.UTF-8):     Wtyczka sasldb do Cyrus SASL
+%description scram -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL SCRAM.
+
+%package sqlite
+Summary:       Cyrus SQLite 2 PostgreSQL plugin
+Summary(pl.UTF-8):     Wtyczka SQLite 2 do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description sasldb
-Cyrus SASL sasldb plugin.
+%description sqlite
+Cyrus SASL SQLite 2 plugin.
 
-%description sasldb -l pl.UTF-8
-Wtyczka sasldb do Cyrus SASL.
+%description sqlite -l pl.UTF-8
+Wtyczka SQLite 2 do Cyrus SASL.
 
-%package mysql
-Summary:       Cyrus SASL MySQL plugin
-Summary(pl.UTF-8):     Wtyczka MySQL do Cyrus SASL
+%package sqlite3
+Summary:       Cyrus SQLite 3 PostgreSQL plugin
+Summary(pl.UTF-8):     Wtyczka SQLite 3 do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description mysql
-Cyrus SASL MySQL plugin.
+%description sqlite3
+Cyrus SASL SQLite 3 plugin.
 
-%description mysql -l pl.UTF-8
-Wtyczka MySQL do Cyrus SASL.
+%description sqlite3 -l pl.UTF-8
+Wtyczka SQLite 3 do Cyrus SASL.
 
-%package pgsql
-Summary:       Cyrus SASL PostgreSQL plugin
-Summary(pl.UTF-8):     Wtyczka PostgreSQL do Cyrus SASL
+%package srp
+Summary:       SRP Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka SRP do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL SRP
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description pgsql
-Cyrus SASL PostgreSQL plugin.
+%description srp
+This plugin implements the SASL SRP mechanism, based on the Secure
+Remote Password protocol. This mechanism performs mutual
+authentication and can provide a security layer with replay detection,
+integrity protection and/or condifentiality protection.
 
-%description pgsql -l pl.UTF-8
-Wtyczka PostgreSQL do Cyrus SASL.
+%description srp -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
+protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
+uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
+powtarzania, zabezpieczeniem integralności i/lub poufności.
 
-%package sqlite
-Summary:       Cyrus SQLite PostgreSQL plugin
-Summary(pl.UTF-8):     Wtyczka SQLite do Cyrus SASL
+%description srp -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
+(Secure Remote Password). Este mecanismo oferece autenticação mútua
+(do cliente e do servidor) e pode prover uma camada de segurança com
+detecção de ataques de replay, garantia de integridade e/ou
+confidencialidade.
+
+%package pwcheck
+Summary:       Cyrus SASL pwcheck helper
+Summary(pl.UTF-8):     Program pomocniczy pwcheck do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description sqlite
-Cyrus SASL SQLite plugin.
+%description pwcheck
+Cyrus SASL pwcheck helper.
 
-%description sqlite -l pl.UTF-8
-Wtyczka SQLite do Cyrus SASL.
+%description pwcheck -l pl.UTF-8
+Program pomocniczy pwcheck do Cyrus SASL.
+
+%package saslauthd
+Summary:       Cyrus SASL authd
+Summary(pl.UTF-8):     Demon authd do Cyrus SASL
+Group:         Daemons
+Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name} = %{version}-%{release}
+Requires:      /sbin/chkconfig
+Requires:      rc-scripts
+
+%description saslauthd
+Cyrus SASL authd.
+
+%description saslauthd -l pl.UTF-8
+Demon authd do Cyrus SASL.
 
 %package -n nagios-plugin-check_saslauthd
 Summary:       Nagios plugin to check health of saslauthd
@@ -452,11 +479,19 @@ Wtyczka Nagiosa do sprawdzania działania saslauthd.
 %endif
 %patch7 -p1
 %patch8 -p1
-%patch9 -p2
+%patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p1
+%patch13 -p0
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
 
 cd doc
 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
@@ -464,25 +499,29 @@ ls rfc*.txt >> rfc-compliance
 rm -f rfc*.txt
 cd ..
 
-rm -rf autom4te.cache saslauthd/autom4te.cache
-# acinclude.m4 contains only old libtool.m4
-rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
+# old version
+%{__rm} config/libtool.m4
+
+# update to our paths
+sed -i -e '
+       s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
+       s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
+       s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
+       s,/var/state/saslauthd,/var/lib/sasl2,g
+' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
 
 %build
 %{__libtoolize}
 %{__aclocal} -I cmulocal -I config
 %{__autoheader}
-%{__automake}
 %{__autoconf}
-
+%{__automake}
 cd saslauthd
-%{__libtoolize}
-%{__aclocal} -I ../cmulocal -I ../config -I config
+%{__aclocal} -I ../cmulocal -I ../config
 %{__autoheader}
-%{__automake}
 %{__autoconf}
+%{__automake}
 cd ..
-
 %configure \
        %{?with_cryptedpw: LDFLAGS=-lcrypt} \
        --disable-krb4 \
@@ -500,20 +539,24 @@ cd ..
        --with-dbpath=/var/lib/sasl2/sasl.db \
        %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
        %{?with_ldap: --with-ldap=%{_prefix}} \
+       %{?with_ldap: --enable-ldapdb} \
        %{?with_mysql: --with-mysql=%{_prefix}} \
        %{?with_pgsql: --with-pgsql=%{_prefix}} \
        %{?with_sqlite: --with-sqlite=%{_prefix}} \
+       %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
        %{?with_opie: --with-opie=%{_prefix}} \
        --with-pam \
        %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
        --with-saslauthd=/var/lib/sasl2
+
 %{__make}
 
 %{__make} -C saslauthd testsaslauthd
 %{__make} -C saslauthd saslcache
+%{__make} -C sample sample-client sample-server
 
 cd doc
-RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
+RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
 for i in $RFCLIST; do
        RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
        echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
@@ -528,11 +571,10 @@ install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/i
        sasldir=%{_libdir}/sasl2 \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
-rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
 
-install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
-install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
+cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
+cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
 
 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
 
@@ -540,15 +582,15 @@ touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
 
 # create empty config
 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
-install %{SOURCE3} cyrus.pam
+install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
+cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
+cp -a %{SOURCE3} cyrus.pam
 
-install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
+install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
 
 # sample programs for testing sasl
-libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
-libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
+libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
+libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
 
 # package for ghost
 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
@@ -559,8 +601,8 @@ install -d $RPM_BUILD_ROOT/etc/nagios/plugins
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
 
 %post saslauthd
 /sbin/chkconfig --add saslauthd
@@ -572,14 +614,19 @@ if [ "$1" = "0" ]; then
        /sbin/chkconfig --del saslauthd
 fi
 
+%triggerin saslauthd -- pam
+# restart saslauthd if pam is upgraded
+# (saslauth is linked with old libpam but tries to open modules linked with new libpam)
+if [ "$2" != 1 ]; then
+       %service -q saslauthd restart
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS COPYING ChangeLog NEWS README
 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
 %dir %{_sysconfdir}
 %dir %{_libdir}/sasl2
-%attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
 # sample programs to subpackage instead?
 %attr(755,root,root) %{_bindir}/sasl-sample-client
 %attr(755,root,root) %{_bindir}/sasl-sample-server
@@ -592,6 +639,11 @@ fi
 %{_mandir}/man8/sasldblistusers2.8*
 %{_mandir}/man8/saslpasswd2.8*
 
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
+
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsasl2.so
@@ -611,6 +663,7 @@ fi
 %if %{with gssapi}
 %files gssapi
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
 %endif
 
@@ -626,14 +679,20 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
 
+%if %{with mysql}
+%files mysql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
+%endif
+
 %files otp
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
 
-%if %{with opie}
-%files opie
+%if %{with pgsql}
+%files pgsql
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libopie.so*
+%attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
 %endif
 
 %files plain
@@ -644,17 +703,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
 
-%if %{with mysql}
-%files mysql
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
-%endif
-
-%if %{with pgsql}
-%files pgsql
+%files scram
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
-%endif
+%attr(755,root,root) %{_libdir}/sasl2/libscram.so*
 
 %if %{with sqlite}
 %files sqlite
@@ -662,16 +713,16 @@ fi
 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
 %endif
 
-%if %{with srp}
-%files srp
+%if %{with sqlite3}
+%files sqlite3
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
+%attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
 %endif
 
-%if %{with x509}
-%files x509
+%if %{with srp}
+%files srp
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libx509.so*
+%attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
 %endif
 
 %if %{with pwcheck}
This page took 0.480748 seconds and 4 git commands to generate.