]> git.pld-linux.org Git - packages/cyrus-sasl.git/blobdiff - cyrus-sasl.spec
- allow building without Nagios support
[packages/cyrus-sasl.git] / cyrus-sasl.spec
index a45271c2a494152b337a5b5061b9848ccd2f8c8f..a87bdd9e6a634712a044fdf71ca8d088deb6406c 100644 (file)
@@ -1,18 +1,18 @@
-# TODO:
-# - add ldap plugin from openldap sources
 #
 # Conditional build:
 %bcond_without cryptedpw       # if you keep crypted passwords in your *sql
 %bcond_without ldap            # disable LDAP support for saslauthd
 %bcond_without gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
-%bcond_without mysql           # don't build MySQL pluggin
-%bcond_without pgsql           # do not build PostgreSQL pluggin
-%bcond_without sqlite          # do not enable sqlite plugin
+%bcond_without mysql           # don't build MySQL plugin
+%bcond_without nagios          # do not enable Nagios plugin
+%bcond_without ntlm            # do not build NTLM plugin
+%bcond_without pgsql           # do not build PostgreSQL plugin
+%bcond_without sqlite          # do not enable sqlite 2 plugin
+%bcond_without sqlite3         # do not enable sqlite 3 plugin
 %bcond_with    authlib         # enable courier-authlib (i wasn't able to test it)
-%bcond_with    opie            # enable opie plugin
-%bcond_with    srp             # build srp pluggin
+%bcond_with    opie            # OTP plugin using opie library instead of internal code
+%bcond_with    srp             # build srp plugin
 %bcond_with    pwcheck         # build pwcheck helper (deprecated)
-%bcond_with    x509            # build x509 plugin (no sources in package???)
 #
 %if %{without mysql} && %{without pgsql}
 %undefine with_cryptedpw
@@ -24,12 +24,13 @@ Summary(pt_BR.UTF-8):       Implementação da API SASL
 Summary(ru.UTF-8):     Библиотека Cyrus SASL
 Summary(uk.UTF-8):     Бібліотека Cyrus SASL
 Name:          cyrus-sasl
-Version:       2.1.23
-Release:       13.1
+Version:       2.1.28
+Release:       2
 License:       distributable
 Group:         Libraries
-Source0:       ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
-# Source0-md5: 2eb0e48106f0e9cd8001e654f267ecbc
+#Source0Download: https://github.com/cyrusimap/cyrus-sasl/releases
+Source0:       https://github.com/cyrusimap/cyrus-sasl/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 6f228a692516f5318a64505b46966cfa
 Source1:       saslauthd.init
 Source2:       saslauthd.sysconfig
 Source3:       %{name}.pam
@@ -38,22 +39,19 @@ Patch0:             %{name}-nolibs.patch
 Patch1:                %{name}-lt.patch
 Patch2:                %{name}-split-sql.patch
 Patch3:                %{name}-opie.patch
-Patch4:                %{name}-gcc4.patch
 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
 Patch5:                %{name}-cryptedpw.patch
 Patch6:                %{name}-md5sum-passwords.patch
 Patch7:                %{name}-db.patch
-Patch8:                %{name}-automake_1_10.patch
-Patch9:                %{name}-digest-commas.patch
-Patch10:       %{name}-keytab.patch
-Patch11:       %{name}-sizes.patch
-Patch12:       %{name}-nagios-plugin.patch
-Patch13:       %{name}-parallel-make.patch
-Patch14:       %{name}-gssapi-detect.patch
-Patch15:               %{name}-saslauthd-httpform-urlescape.patch
-URL:           http://asg.web.cmu.edu/sasl/
-BuildRequires: autoconf >= 2.54
-BuildRequires: automake >= 1:1.7
+Patch9:                %{name}-sizes.patch
+Patch10:       %{name}-nagios-plugin.patch
+Patch12:       %{name}-gssapi-detect.patch
+Patch14:       %{name}-ac-libs.patch
+Patch20:       %{name}-auxprop.patch
+Patch21:       0030-dont_use_la_files_for_opening_plugins.patch
+URL:           https://www.cyrusimap.org/sasl/
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
 %{?with_authlib:BuildRequires: courier-authlib-devel}
 BuildRequires: db-devel
 BuildRequires: ed
@@ -67,9 +65,12 @@ BuildRequires:       openssl-devel >= 0.9.7d
 BuildRequires: pam-devel
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: sphinx-pdg-3
 %{?with_sqlite:BuildRequires:  sqlite-devel}
+%{?with_sqlite3:BuildRequires: sqlite3-devel >= 3}
 Requires:      pam >= 0.79.0
 Requires:      %{name}-libs = %{version}-%{release}
+Obsoletes:     cyrus-sasl-x509 < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/sasl
@@ -174,6 +175,25 @@ Statyczne biblioteki cyrus-sasl.
 Статичні бібліотеки, необхідні для розробки програм, що використовують
 Cyrus SASL.
 
+%package anonymous
+Summary:       Anonymous Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka anonymous do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL ANONYMOUS
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description anonymous
+This plugin implements the SASL ANONYMOUS mechanism, used for
+anonymous authentication.
+
+%description anonymous -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
+anonimowego uwierzytelniania.
+
+%description anonymous -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
+autenticação anônima.
+
 %package cram-md5
 Summary:       Cram-MD5 Cyrus SASL plugin
 Summary(pl.UTF-8):     Wtyczka Cram-MD5 do Cyrus SASL
@@ -226,50 +246,6 @@ provavelmente será o novo sistema de autenticação obrigatório para
 protocolos novos. Ele é baseado na autenticação md5 digest
 desenvolvida para HTTP.
 
-%package plain
-Summary:       Plain Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka plain do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL PLAIN
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description plain
-This plugin implements the SASL PLAIN mechanism. Although insecure,
-PLAIN is useful for transitioning to new security mechanisms, as this
-is the only mechanism which gives the server a copy of the user's
-password.
-
-%description plain -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
-że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
-nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
-który udostępnia serwerowi kopię hasła użytkownika.
-
-%description plain -l pt_BR.UTF-8
-Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
-mecanismo é útil durante transições para novos mecanismos de
-segurança, pois é o único esquema que fornece uma cópia da senha do
-usuário para o servidor.
-
-%package anonymous
-Summary:       Anonymous Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka anonymous do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL ANONYMOUS
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description anonymous
-This plugin implements the SASL ANONYMOUS mechanism, used for
-anonymous authentication.
-
-%description anonymous -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
-anonimowego uwierzytelniania.
-
-%description anonymous -l pt_BR.UTF-8
-Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
-autenticação anônima.
-
 %package gssapi
 Summary:       GSSAPI Cyrus SASL plugin
 Summary(pl.UTF-8):     Wtyczka GSSAPI do Cyrus SASL
@@ -302,31 +278,29 @@ Unsupported LOGIN Cyrus SASL plugin.
 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
 SASL.
 
-%package srp
-Summary:       SRP Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka SRP do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL SRP
+%package mysql
+Summary:       Cyrus SASL MySQL plugin
+Summary(pl.UTF-8):     Wtyczka MySQL do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description srp
-This plugin implements the SASL SRP mechanism, based on the Secure
-Remote Password protocol. This mechanism performs mutual
-authentication and can provide a security layer with replay detection,
-integrity protection and/or condifentiality protection.
+%description mysql
+Cyrus SASL MySQL plugin.
 
-%description srp -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
-protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
-uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
-powtarzania, zabezpieczeniem integralności i/lub poufności.
+%description mysql -l pl.UTF-8
+Wtyczka MySQL do Cyrus SASL.
 
-%description srp -l pt_BR.UTF-8
-Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
-(Secure Remote Password). Este mecanismo oferece autenticação mútua
-(do cliente e do servidor) e pode prover uma camada de segurança com
-detecção de ataques de replay, garantia de integridade e/ou
-confidencialidade.
+%package ntlm
+Summary:       Cyrus SASL NTLM plugin
+Summary(pl.UTF-8):     Wtyczka NTLM do Cyrus SASL
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description ntlm
+Cyrus SASL NTLM plugin.
+
+%description ntlm -l pl.UTF-8
+Wtyczka NTLM do Cyrus SASL.
 
 %package otp
 Summary:       OTP Cyrus SASL plugin
@@ -334,6 +308,7 @@ Summary(pl.UTF-8):  Wtyczka OTP do Cyrus SASL
 Summary(pt_BR.UTF-8):  Mecanismo SASL OTP
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     cyrus-sasl-opie < %{version}
 
 %description otp
 This plugin implements the SASL OTP (One Time Password) mechanism.
@@ -342,58 +317,42 @@ This plugin implements the SASL OTP (One Time Password) mechanism.
 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
 SASL.
 
-%package opie
-Summary:       OPIE Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka OPIE do Cyrus SASL
-Summary(pt_BR.UTF-8):  Mecanismo SASL OPIE
+%package pgsql
+Summary:       Cyrus SASL PostgreSQL plugin
+Summary(pl.UTF-8):     Wtyczka PostgreSQL do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description opie
-This plugin implements the SASL OPIE (One Time Password) mechanism.
+%description pgsql
+Cyrus SASL PostgreSQL plugin.
 
-%description opie -l pl.UTF-8
-Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
-SASL.
+%description pgsql -l pl.UTF-8
+Wtyczka PostgreSQL do Cyrus SASL.
 
-%package x509
-Summary:       x509 Cyrus SASL plugin
-Summary(pl.UTF-8):     Wtyczka x509 do Cyrus SASL
+%package plain
+Summary:       Plain Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka plain do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL PLAIN
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description x509
-x509 Cyrus SASL plugin.
-
-%description x509 -l pl.UTF-8
-Wtyczka x509 do Cyrus SASL.
-
-%package saslauthd
-Summary:       Cyrus SASL authd
-Summary(pl.UTF-8):     Demon authd do Cyrus SASL
-Group:         Daemons
-Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name} = %{version}-%{release}
-Requires:      /sbin/chkconfig
-Requires:      rc-scripts
-
-%description saslauthd
-Cyrus SASL authd.
-
-%description saslauthd -l pl.UTF-8
-Demon authd do Cyrus SASL.
-
-%package pwcheck
-Summary:       Cyrus SASL pwcheck helper
-Summary(pl.UTF-8):     Program pomocniczy pwcheck do Cyrus SASL
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+%description plain
+This plugin implements the SASL PLAIN mechanism. Although insecure,
+PLAIN is useful for transitioning to new security mechanisms, as this
+is the only mechanism which gives the server a copy of the user's
+password.
 
-%description pwcheck
-Cyrus SASL pwcheck helper.
+%description plain -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
+że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
+nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
+który udostępnia serwerowi kopię hasła użytkownika.
 
-%description pwcheck -l pl.UTF-8
-Program pomocniczy pwcheck do Cyrus SASL.
+%description plain -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
+mecanismo é útil durante transições para novos mecanismos de
+segurança, pois é o único esquema que fornece uma cópia da senha do
+usuário para o servidor.
 
 %package sasldb
 Summary:       Cyrus SASL sasldb plugin
@@ -407,41 +366,126 @@ Cyrus SASL sasldb plugin.
 %description sasldb -l pl.UTF-8
 Wtyczka sasldb do Cyrus SASL.
 
-%package mysql
-Summary:       Cyrus SASL MySQL plugin
-Summary(pl.UTF-8):     Wtyczka MySQL do Cyrus SASL
+%package ldapdb
+Summary:       Cyrus SASL LDAPDB plugin
+Summary(pl.UTF-8):     Wtyczka LDAPDB do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description mysql
-Cyrus SASL MySQL plugin.
+%description ldapdb
+Cyrus SASL ldapdb plugin.
 
-%description mysql -l pl.UTF-8
-Wtyczka MySQL do Cyrus SASL.
+%description ldapdb -l pl.UTF-8
+Wtyczka ldapdb do Cyrus SASL.
 
-%package pgsql
-Summary:       Cyrus SASL PostgreSQL plugin
-Summary(pl.UTF-8):     Wtyczka PostgreSQL do Cyrus SASL
+%package passdss
+Summary:       PASSDSS Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka PASSDSS do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL PASSDSS
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
-%description pgsql
-Cyrus SASL PostgreSQL plugin.
+%description passdss
+This plugin implements the PASSDSS 3DES mechanism.
 
-%description pgsql -l pl.UTF-8
-Wtyczka PostgreSQL do Cyrus SASL.
+%description passdss -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
+
+%description passdss -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL PASSDSS 3DES.
+
+%package scram
+Summary:       SCRAM Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka SCRAM do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL SCRAM
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description scram
+This plugin implements the SASL SCRAM-MD5 mechanism.
+
+%description scram -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
+
+%description scram -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL SCRAM.
 
 %package sqlite
-Summary:       Cyrus SQLite PostgreSQL plugin
-Summary(pl.UTF-8):     Wtyczka SQLite do Cyrus SASL
+Summary:       Cyrus SQLite PostgreSQL plugin
+Summary(pl.UTF-8):     Wtyczka SQLite do Cyrus SASL
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description sqlite
-Cyrus SASL SQLite plugin.
+Cyrus SASL SQLite plugin.
 
 %description sqlite -l pl.UTF-8
-Wtyczka SQLite do Cyrus SASL.
+Wtyczka SQLite 2 do Cyrus SASL.
+
+%package sqlite3
+Summary:       Cyrus SQLite 3 PostgreSQL plugin
+Summary(pl.UTF-8):     Wtyczka SQLite 3 do Cyrus SASL
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description sqlite3
+Cyrus SASL SQLite 3 plugin.
+
+%description sqlite3 -l pl.UTF-8
+Wtyczka SQLite 3 do Cyrus SASL.
+
+%package srp
+Summary:       SRP Cyrus SASL plugin
+Summary(pl.UTF-8):     Wtyczka SRP do Cyrus SASL
+Summary(pt_BR.UTF-8):  Mecanismo SASL SRP
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description srp
+This plugin implements the SASL SRP mechanism, based on the Secure
+Remote Password protocol. This mechanism performs mutual
+authentication and can provide a security layer with replay detection,
+integrity protection and/or condifentiality protection.
+
+%description srp -l pl.UTF-8
+Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
+protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
+uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
+powtarzania, zabezpieczeniem integralności i/lub poufności.
+
+%description srp -l pt_BR.UTF-8
+Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
+(Secure Remote Password). Este mecanismo oferece autenticação mútua
+(do cliente e do servidor) e pode prover uma camada de segurança com
+detecção de ataques de replay, garantia de integridade e/ou
+confidencialidade.
+
+%package pwcheck
+Summary:       Cyrus SASL pwcheck helper
+Summary(pl.UTF-8):     Program pomocniczy pwcheck do Cyrus SASL
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description pwcheck
+Cyrus SASL pwcheck helper.
+
+%description pwcheck -l pl.UTF-8
+Program pomocniczy pwcheck do Cyrus SASL.
+
+%package saslauthd
+Summary:       Cyrus SASL authd
+Summary(pl.UTF-8):     Demon authd do Cyrus SASL
+Group:         Daemons
+Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name} = %{version}-%{release}
+Requires:      /sbin/chkconfig
+Requires:      rc-scripts
+
+%description saslauthd
+Cyrus SASL authd.
+
+%description saslauthd -l pl.UTF-8
+Demon authd do Cyrus SASL.
 
 %package -n nagios-plugin-check_saslauthd
 Summary:       Nagios plugin to check health of saslauthd
@@ -461,30 +505,17 @@ Wtyczka Nagiosa do sprawdzania działania saslauthd.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %if %{with cryptedpw}
 %patch5 -p1
 %patch6 -p1
 %endif
 %patch7 -p1
-%patch8 -p1
-%patch9 -p2
-%patch10 -p1
-%patch11 -p1
+%patch9 -p1
+%{?with_nagios:%patch10 -p1}
 %patch12 -p1
-%patch13 -p1
 %patch14 -p1
-%patch15 -p0
-
-cd doc
-echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
-ls rfc*.txt >> rfc-compliance
-rm -f rfc*.txt
-cd ..
-
-rm -rf autom4te.cache saslauthd/autom4te.cache
-# acinclude.m4 contains only old libtool.m4
-rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
+%patch20 -p1
+%patch21 -p1
 
 # update to our paths
 sed -i -e '
@@ -492,59 +523,51 @@ sed -i -e '
        s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
        s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
        s,/var/state/saslauthd,/var/lib/sasl2,g
-' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
+' saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/legacy/sysadmin.html
 
 %build
 %{__libtoolize}
-%{__aclocal} -I cmulocal -I config
-%{__autoheader}
-%{__automake}
+%{__aclocal} -I m4
 %{__autoconf}
-
-cd saslauthd
-%{__libtoolize}
-%{__aclocal} -I ../cmulocal -I ../config -I config
 %{__autoheader}
 %{__automake}
-%{__autoconf}
-cd ..
-
 %configure \
+       SPHINX_BUILD=/usr/bin/sphinx-build-3 \
        %{?with_cryptedpw: LDFLAGS=-lcrypt} \
+       %{!?with_gssapi:--disable-gssapi} \
+       %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
+       --enable-httpform \
        --disable-krb4 \
-       %{!?with_gssapi: --disable-gssapi} \
-       %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
+       %{?with_ldap:--enable-ldapdb} \
        --enable-login \
+       --enable-passdss \
        --enable-sample \
-       --enable-httpform \
        --enable-sql \
-       %{?with_srp: --enable-srp} \
+       %{?with_srp:--enable-srp} \
        --enable-static \
-       --with-plugindir=%{_libdir}/sasl2 \
+       %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
        --with-configdir=%{_sysconfdir} \
        --with-dblib=berkeley \
        --with-dbpath=/var/lib/sasl2/sasl.db \
-       %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
-       %{?with_ldap: --with-ldap} \
-       %{?with_mysql: --with-mysql} \
-       %{?with_pgsql: --with-pgsql} \
-       %{?with_sqlite: --with-sqlite} \
-       %{?with_opie: --with-opie} \
+       %{?with_ldap:--with-ldap} \
+       %{?with_mysql:--with-mysql=%{_prefix}} \
+       %{?with_ntlm:--enable-ntlm} \
+       %{?with_opie:--with-opie=%{_prefix}} \
        --with-pam \
-       %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
-       --with-saslauthd=/var/lib/sasl2
+       %{?with_pgsql:--with-pgsql=%{_prefix}} \
+       --with-plugindir=%{_libdir}/sasl2 \
+       %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
+       --with-saslauthd=/var/lib/sasl2 \
+       %{?with_sqlite:--with-sqlite=%{_prefix}} \
+       %{?with_sqlite3:--with-sqlite3=%{_prefix}}
+
 %{__make}
 
 %{__make} -C saslauthd testsaslauthd
 %{__make} -C saslauthd saslcache
 %{__make} -C sample sample-client sample-server
 
-cd doc
-RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
-for i in $RFCLIST; do
-       RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
-       echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
-done
+%{__rm} -rf doc/html/{_sources,objects.inv,.buildinfo}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -555,8 +578,7 @@ install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/i
        sasldir=%{_libdir}/sasl2 \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
-rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
 
 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
@@ -580,8 +602,10 @@ libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sa
 # package for ghost
 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
 
+%if %{with nagios}
 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -608,8 +632,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING ChangeLog NEWS README
-%doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
+%doc AUTHORS COPYING ChangeLog README doc/legacy/{TODO,*.html,*.fig} doc/html
 %dir %{_sysconfdir}
 %dir %{_libdir}/sasl2
 # sample programs to subpackage instead?
@@ -627,7 +650,7 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
+%attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
 
 %files devel
 %defattr(644,root,root,755)
@@ -635,6 +658,7 @@ fi
 %attr(755,root,root) %{_libdir}/libsasl.so
 %{_libdir}/libsasl2.la
 %{_includedir}/sasl
+%{_pkgconfigdir}/libsasl2.pc
 %{_mandir}/man3/sasl*.3*
 
 %files static
@@ -648,6 +672,7 @@ fi
 %if %{with gssapi}
 %files gssapi
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
 %endif
 
@@ -663,14 +688,26 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
 
+%if %{with mysql}
+%files mysql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
+%endif
+
+%if %{with ntlm}
+%files ntlm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
+%endif
+
 %files otp
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
 
-%if %{with opie}
-%files opie
+%if %{with pgsql}
+%files pgsql
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libopie.so*
+%attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
 %endif
 
 %files plain
@@ -681,17 +718,19 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
 
-%if %{with mysql}
-%files mysql
+%if %{with ldap}
+%files ldapdb
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
+%attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
 %endif
 
-%if %{with pgsql}
-%files pgsql
+%files passdss
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
-%endif
+%attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
+
+%files scram
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/sasl2/libscram.so*
 
 %if %{with sqlite}
 %files sqlite
@@ -699,16 +738,16 @@ fi
 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
 %endif
 
-%if %{with srp}
-%files srp
+%if %{with sqlite3}
+%files sqlite3
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
+%attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
 %endif
 
-%if %{with x509}
-%files x509
+%if %{with srp}
+%files srp
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/sasl2/libx509.so*
+%attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
 %endif
 
 %if %{with pwcheck}
@@ -719,8 +758,7 @@ fi
 
 %files saslauthd
 %defattr(644,root,root,755)
-%doc cyrus.pam
-%doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
+%doc cyrus.pam saslauthd/{COPYING,LDAP_SASLAUTHD}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
 %attr(755,root,root) %{_sbindir}/saslauthd
@@ -733,8 +771,11 @@ fi
 %ghost /var/lib/sasl2/mux.accept
 %ghost /var/lib/sasl2/saslauthd.pid
 %{_mandir}/man8/saslauthd.8*
+%{_mandir}/man8/testsaslauthd.8*
 
+%if %{with nagios}
 %files -n nagios-plugin-check_saslauthd
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
+%endif
This page took 0.14537 seconds and 4 git commands to generate.