]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- allow building without Nagios support
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL plugin
7 %bcond_without  ntlm            # do not build NTLM plugin
8 %bcond_without  pgsql           # do not build PostgreSQL plugin
9 %bcond_without  sqlite          # do not enable sqlite 2 plugin
10 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # OTP plugin using opie library instead of internal code
13 %bcond_with     srp             # build srp plugin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 #
16 %if %{without mysql} && %{without pgsql}
17 %undefine with_cryptedpw
18 %endif
19
20 Summary:        The SASL library API for the Cyrus mail system
21 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
22 Summary(pt_BR.UTF-8):   Implementação da API SASL
23 Summary(ru.UTF-8):      Библиотека Cyrus SASL
24 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
25 Name:           cyrus-sasl
26 Version:        2.1.26
27 Release:        6
28 License:        distributable
29 Group:          Libraries
30 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
31 # Source0-md5:  a7f4e5e559a0e37b3ffc438c9456e425
32 Source1:        saslauthd.init
33 Source2:        saslauthd.sysconfig
34 Source3:        %{name}.pam
35 Source4:        check_saslauthd.cfg
36 Patch0:         %{name}-nolibs.patch
37 Patch1:         %{name}-lt.patch
38 Patch2:         %{name}-split-sql.patch
39 Patch3:         %{name}-opie.patch
40 Patch4:         %{name}-gcc4.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 Patch7:         %{name}-db.patch
45 Patch8:         %{name}-keytab.patch
46 Patch9:         %{name}-sizes.patch
47 Patch10:        %{name}-nagios-plugin.patch
48 Patch11:        %{name}-parallel-make.patch
49 Patch12:        %{name}-gssapi-detect.patch
50 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
51 Patch14:        %{name}-ac-libs.patch
52 Patch15:        %{name}-pam.patch
53 Patch16:        %{name}-gssapi_ext.patch
54 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
55 Patch18:        0033-fix_segfault_in_GSSAPI.patch
56 Patch19:        0034-fix_dovecot_authentication.patch
57 Patch20:        %{name}-auxprop.patch
58 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
59 Patch22:        %{name}-stddef.patch
60 Patch23:        http://sourceforge.net/projects/miscellaneouspa/files/glibc217/cyrus-sasl-2.1.26-glibc217-crypt.diff
61 URL:            http://asg.web.cmu.edu/sasl/
62 BuildRequires:  autoconf >= 2.54
63 BuildRequires:  automake >= 1:1.7
64 %{?with_authlib:BuildRequires:  courier-authlib-devel}
65 BuildRequires:  db-devel
66 BuildRequires:  ed
67 BuildRequires:  groff
68 %{?with_gssapi:BuildRequires:   heimdal-devel}
69 BuildRequires:  libtool >= 1.4
70 %{?with_mysql:BuildRequires:    mysql-devel}
71 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
72 BuildRequires:  openssl-devel >= 0.9.7d
73 %{?with_opie:BuildRequires:     opie-devel}
74 BuildRequires:  pam-devel
75 %{?with_pgsql:BuildRequires:    postgresql-devel}
76 BuildRequires:  rpmbuild(macros) >= 1.268
77 %{?with_sqlite:BuildRequires:   sqlite-devel}
78 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
79 Requires:       pam >= 0.79.0
80 Requires:       %{name}-libs = %{version}-%{release}
81 Obsoletes:      cyrus-sasl-x509 < %{version}
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _sysconfdir     /etc/sasl
85
86 %define         specflags       -fno-strict-aliasing
87
88 %description
89 This is an implementation of the SASL API, useful for adding
90 authentication, authorization, and security to network protocols. The
91 SASL protocol itself is documented in rfc2222; the API standard is a
92 work in progress.
93
94 Note: remember to install appropriate plugins, or you won't have any
95 authentication mechanisms available.
96
97 %description -l pl.UTF-8
98 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
99 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
100 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
101 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
102 RFC 2222; standaryzacja API jest w toku.
103
104 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
105 doinstalować odpowiednie wtyczki.
106
107 %description -l pt_BR.UTF-8
108 Esta é uma implementação da API SASL, útil para acrescentar
109 autenticação, autorização e seguança (criptografia) para protocolos de
110 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
111 ainda está em desenvolvimento.
112
113 %description -l ru.UTF-8
114 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
115 Authentication and Security Layer, метод для добавления поддержки
116 аутентикации к протоколам, основанным на соединениях.
117
118 %description -l uk.UTF-8
119 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
120 Authentication and Security Layer, метод для додання підтримки
121 аутентикації до протоколів, базованих на з'єднаннях.
122
123 %package libs
124 Summary:        cyrus-sasl library itself
125 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
126 Group:          Libraries
127 Requires(post,postun):  /sbin/ldconfig
128 Conflicts:      cyrus-sasl < 2.1.23-8
129
130 %description libs
131 cyrus-sasl library itself.
132
133 %description libs -l pl.UTF-8
134 Sama biblioteka cyrus-sasl.
135
136 %package devel
137 Summary:        Header files and documentation for cyrus-sasl
138 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
139 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
140 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
141 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
142 Group:          Development/Libraries
143 Requires:       %{name} = %{version}-%{release}
144
145 %description devel
146 This includes the header files and documentation needed to develop
147 applications which use SASL.
148
149 %description devel -l pl.UTF-8
150 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
151
152 %description devel -l pt_BR.UTF-8
153 Este pacote inclui os arquivos de cabeçalho e documentação necessários
154 para desenvolver aplicativos que usem SASL.
155
156 %description devel -l ru.UTF-8
157 Хедеры и библиотеки, необходимые для разработки приложений,
158 использующих Cyrus SASL.
159
160 %description devel -l uk.UTF-8
161 Хедери та бібліотеки, необхідні для розробки програм, що
162 використовують Cyrus SASL.
163
164 %package static
165 Summary:        Static cyrus-sasl libraries
166 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
167 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
168 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
169 Group:          Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171
172 %description static
173 Static cyrus-sasl libraries.
174
175 %description static -l pl.UTF-8
176 Statyczne biblioteki cyrus-sasl.
177
178 %description static -l ru.UTF-8
179 Статические библиотеки, необходимые для разработки приложений,
180 использующих Cyrus SASL.
181
182 %description static -l uk.UTF-8
183 Статичні бібліотеки, необхідні для розробки програм, що використовують
184 Cyrus SASL.
185
186 %package anonymous
187 Summary:        Anonymous Cyrus SASL plugin
188 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
189 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
190 Group:          Libraries
191 Requires:       %{name} = %{version}-%{release}
192
193 %description anonymous
194 This plugin implements the SASL ANONYMOUS mechanism, used for
195 anonymous authentication.
196
197 %description anonymous -l pl.UTF-8
198 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
199 anonimowego uwierzytelniania.
200
201 %description anonymous -l pt_BR.UTF-8
202 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
203 autenticação anônima.
204
205 %package cram-md5
206 Summary:        Cram-MD5 Cyrus SASL plugin
207 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
208 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
209 Group:          Libraries
210 Requires:       %{name} = %{version}-%{release}
211
212 %description cram-md5
213 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
214 mandatory-to-implement authentication mechanism for a number of
215 protocols; it uses MD5 with a challenge/response system to
216 authenticate the user.
217
218 %description cram-md5 -l pl.UTF-8
219 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
220 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
221 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
222 systemem challenge/response.
223
224 %description cram-md5 -l pt_BR.UTF-8
225 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
226 mecanismo de autenticação obrigatório de ser implementado para vários
227 protocolos: ele usa MD5 com um sistema de desafio/resposta para
228 autenticar o usuário.
229
230 %package digest-md5
231 Summary:        Digest-MD5 Cyrus SASL plugin
232 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
233 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236
237 %description digest-md5
238 This plugin implements the latest draft of the SASL DIGEST-MD5
239 mechanism. Although not yet finalized, this is likely to become the
240 new mandatory-to-implement authentication system in all new protocols.
241 It's based on the digest md5 authentication system designed for HTTP.
242
243 %description digest-md5 -l pl.UTF-8
244 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
245 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
246 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
247 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
248 Digest-MD5 zaprojektowanym dla HTTP.
249
250 %description digest-md5 -l pt_BR.UTF-8
251 Este plugin implementa a última versão da especificação do mecanismo
252 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
253 provavelmente será o novo sistema de autenticação obrigatório para
254 protocolos novos. Ele é baseado na autenticação md5 digest
255 desenvolvida para HTTP.
256
257 %package gssapi
258 Summary:        GSSAPI Cyrus SASL plugin
259 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
260 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263
264 %description gssapi
265 This plugin implements the SASL GSSAPI mechanism, used for
266 GSSAPI/Kerberos5 authentication.
267
268 %description gssapi -l pl.UTF-8
269 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
270 uwierzytelniania z użyciem GSSAPI/Kerberos5.
271
272 %description gssapi -l pt_BR.UTF-8
273 Este plugin implementa o mecanismo SASL GSSAPI, usado para
274 autenticação Kerberos/GSSAPI.
275
276 %package login
277 Summary:        Unsupported Login Cyrus SASL plugin
278 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
279 Group:          Libraries
280 Requires:       %{name} = %{version}-%{release}
281
282 %description login
283 Unsupported LOGIN Cyrus SASL plugin.
284
285 %description login -l pl.UTF-8
286 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
287 SASL.
288
289 %package mysql
290 Summary:        Cyrus SASL MySQL plugin
291 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
292 Group:          Libraries
293 Requires:       %{name} = %{version}-%{release}
294
295 %description mysql
296 Cyrus SASL MySQL plugin.
297
298 %description mysql -l pl.UTF-8
299 Wtyczka MySQL do Cyrus SASL.
300
301 %package ntlm
302 Summary:        Cyrus SASL NTLM plugin
303 Summary(pl.UTF-8):      Wtyczka NTLM do Cyrus SASL
304 Group:          Libraries
305 Requires:       %{name} = %{version}-%{release}
306
307 %description ntlm
308 Cyrus SASL NTLM plugin.
309
310 %description ntlm -l pl.UTF-8
311 Wtyczka NTLM do Cyrus SASL.
312
313 %package otp
314 Summary:        OTP Cyrus SASL plugin
315 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
316 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
317 Group:          Libraries
318 Requires:       %{name} = %{version}-%{release}
319 Obsoletes:      cyrus-sasl-opie < %{version}
320
321 %description otp
322 This plugin implements the SASL OTP (One Time Password) mechanism.
323
324 %description otp -l pl.UTF-8
325 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
326 SASL.
327
328 %package pgsql
329 Summary:        Cyrus SASL PostgreSQL plugin
330 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
331 Group:          Libraries
332 Requires:       %{name} = %{version}-%{release}
333
334 %description pgsql
335 Cyrus SASL PostgreSQL plugin.
336
337 %description pgsql -l pl.UTF-8
338 Wtyczka PostgreSQL do Cyrus SASL.
339
340 %package plain
341 Summary:        Plain Cyrus SASL plugin
342 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
343 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
344 Group:          Libraries
345 Requires:       %{name} = %{version}-%{release}
346
347 %description plain
348 This plugin implements the SASL PLAIN mechanism. Although insecure,
349 PLAIN is useful for transitioning to new security mechanisms, as this
350 is the only mechanism which gives the server a copy of the user's
351 password.
352
353 %description plain -l pl.UTF-8
354 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
355 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
356 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
357 który udostępnia serwerowi kopię hasła użytkownika.
358
359 %description plain -l pt_BR.UTF-8
360 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
361 mecanismo é útil durante transições para novos mecanismos de
362 segurança, pois é o único esquema que fornece uma cópia da senha do
363 usuário para o servidor.
364
365 %package sasldb
366 Summary:        Cyrus SASL sasldb plugin
367 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
368 Group:          Libraries
369 Requires:       %{name} = %{version}-%{release}
370
371 %description sasldb
372 Cyrus SASL sasldb plugin.
373
374 %description sasldb -l pl.UTF-8
375 Wtyczka sasldb do Cyrus SASL.
376
377 %package ldapdb
378 Summary:        Cyrus SASL LDAPDB plugin
379 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
380 Group:          Libraries
381 Requires:       %{name} = %{version}-%{release}
382
383 %description ldapdb
384 Cyrus SASL ldapdb plugin.
385
386 %description ldapdb -l pl.UTF-8
387 Wtyczka ldapdb do Cyrus SASL.
388
389 %package passdss
390 Summary:        PASSDSS Cyrus SASL plugin
391 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
392 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
393 Group:          Libraries
394 Requires:       %{name} = %{version}-%{release}
395
396 %description passdss
397 This plugin implements the PASSDSS 3DES mechanism.
398
399 %description passdss -l pl.UTF-8
400 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
401
402 %description passdss -l pt_BR.UTF-8
403 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
404
405 %package scram
406 Summary:        SCRAM Cyrus SASL plugin
407 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
408 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
409 Group:          Libraries
410 Requires:       %{name} = %{version}-%{release}
411
412 %description scram
413 This plugin implements the SASL SCRAM-MD5 mechanism.
414
415 %description scram -l pl.UTF-8
416 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
417
418 %description scram -l pt_BR.UTF-8
419 Este plugin implementa o mecanismo SASL SCRAM.
420
421 %package sqlite
422 Summary:        Cyrus SQLite 2 PostgreSQL plugin
423 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
424 Group:          Libraries
425 Requires:       %{name} = %{version}-%{release}
426
427 %description sqlite
428 Cyrus SASL SQLite 2 plugin.
429
430 %description sqlite -l pl.UTF-8
431 Wtyczka SQLite 2 do Cyrus SASL.
432
433 %package sqlite3
434 Summary:        Cyrus SQLite 3 PostgreSQL plugin
435 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
436 Group:          Libraries
437 Requires:       %{name} = %{version}-%{release}
438
439 %description sqlite3
440 Cyrus SASL SQLite 3 plugin.
441
442 %description sqlite3 -l pl.UTF-8
443 Wtyczka SQLite 3 do Cyrus SASL.
444
445 %package srp
446 Summary:        SRP Cyrus SASL plugin
447 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
448 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
449 Group:          Libraries
450 Requires:       %{name} = %{version}-%{release}
451
452 %description srp
453 This plugin implements the SASL SRP mechanism, based on the Secure
454 Remote Password protocol. This mechanism performs mutual
455 authentication and can provide a security layer with replay detection,
456 integrity protection and/or condifentiality protection.
457
458 %description srp -l pl.UTF-8
459 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
460 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
461 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
462 powtarzania, zabezpieczeniem integralności i/lub poufności.
463
464 %description srp -l pt_BR.UTF-8
465 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
466 (Secure Remote Password). Este mecanismo oferece autenticação mútua
467 (do cliente e do servidor) e pode prover uma camada de segurança com
468 detecção de ataques de replay, garantia de integridade e/ou
469 confidencialidade.
470
471 %package pwcheck
472 Summary:        Cyrus SASL pwcheck helper
473 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
474 Group:          Libraries
475 Requires:       %{name} = %{version}-%{release}
476
477 %description pwcheck
478 Cyrus SASL pwcheck helper.
479
480 %description pwcheck -l pl.UTF-8
481 Program pomocniczy pwcheck do Cyrus SASL.
482
483 %package saslauthd
484 Summary:        Cyrus SASL authd
485 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
486 Group:          Daemons
487 Requires(post,preun):   /sbin/chkconfig
488 Requires:       %{name} = %{version}-%{release}
489 Requires:       /sbin/chkconfig
490 Requires:       rc-scripts
491
492 %description saslauthd
493 Cyrus SASL authd.
494
495 %description saslauthd -l pl.UTF-8
496 Demon authd do Cyrus SASL.
497
498 %package -n nagios-plugin-check_saslauthd
499 Summary:        Nagios plugin to check health of saslauthd
500 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
501 Group:          Networking
502 Requires:       nagios-core
503
504 %description -n nagios-plugin-check_saslauthd
505 Nagios plugin to check health of saslauthd.
506
507 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
508 Wtyczka Nagiosa do sprawdzania działania saslauthd.
509
510 %prep
511 %setup -q
512 %patch0 -p1
513 %patch1 -p1
514 %patch2 -p1
515 %patch3 -p1
516 %patch4 -p1
517 %if %{with cryptedpw}
518 %patch5 -p1
519 %patch6 -p1
520 %endif
521 %patch7 -p1
522 %patch8 -p1
523 %patch9 -p1
524 %patch10 -p1
525 %patch11 -p1
526 %patch12 -p1
527 %patch13 -p0
528 %patch14 -p1
529 %patch15 -p1
530 %patch16 -p1
531 %patch17 -p1
532 %patch18 -p1
533 %patch19 -p1
534 %patch20 -p1
535 %patch21 -p1
536 %patch22 -p1
537 %patch23 -p1
538
539 cd doc
540 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
541 ls rfc*.txt >> rfc-compliance
542 rm -f rfc*.txt
543 cd ..
544
545 # old version
546 %{__rm} config/libtool.m4
547
548 # update to our paths
549 sed -i -e '
550         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
551         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
552         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
553         s,/var/state/saslauthd,/var/lib/sasl2,g
554 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
555
556 %build
557 %{__libtoolize}
558 %{__aclocal} -I cmulocal -I config
559 %{__autoheader}
560 %{__autoconf}
561 %{__automake}
562 cd saslauthd
563 %{__aclocal} -I ../cmulocal -I ../config
564 %{__autoheader}
565 %{__autoconf}
566 %{__automake}
567 cd ..
568 %configure \
569         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
570         --disable-krb4 \
571         %{!?with_gssapi:--disable-gssapi} \
572         %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
573         --enable-login \
574         --enable-sample \
575         --enable-httpform \
576         --enable-sql \
577         --enable-passdss \
578         %{?with_srp:--enable-srp} \
579         --enable-static \
580         --with-plugindir=%{_libdir}/sasl2 \
581         --with-configdir=%{_sysconfdir} \
582         --with-dblib=berkeley \
583         --with-dbpath=/var/lib/sasl2/sasl.db \
584         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
585         %{?with_ldap:--with-ldap=%{_prefix}} \
586         %{?with_ldap:--enable-ldapdb} \
587         %{?with_mysql:--with-mysql=%{_prefix}} \
588         %{?with_ntlm:--enable-ntlm} \
589         %{?with_pgsql:--with-pgsql=%{_prefix}} \
590         %{?with_sqlite:--with-sqlite=%{_prefix}} \
591         %{?with_sqlite3:--with-sqlite3=%{_prefix}} \
592         %{?with_opie:--with-opie=%{_prefix}} \
593         --with-pam \
594         %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
595         --with-saslauthd=/var/lib/sasl2
596
597 %{__make}
598
599 %{__make} -C saslauthd testsaslauthd
600 %{__make} -C saslauthd saslcache
601 %{__make} -C sample sample-client sample-server
602
603 cd doc
604 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
605 for i in $RFCLIST; do
606         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
607         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
608 done
609
610 %install
611 rm -rf $RPM_BUILD_ROOT
612 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
613                 $RPM_BUILD_ROOT%{_mandir}/man8
614
615 %{__make} install \
616         sasldir=%{_libdir}/sasl2 \
617         DESTDIR=$RPM_BUILD_ROOT
618
619 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
620
621 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
622 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
623
624 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
625
626 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
627
628 # create empty config
629 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
630 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
631 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
632 cp -a %{SOURCE3} cyrus.pam
633
634 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
635
636 # sample programs for testing sasl
637 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
638 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
639
640 # package for ghost
641 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
642
643 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
644 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
645
646 %clean
647 rm -rf $RPM_BUILD_ROOT
648
649 %post   libs -p /sbin/ldconfig
650 %postun libs -p /sbin/ldconfig
651
652 %post saslauthd
653 /sbin/chkconfig --add saslauthd
654 %service saslauthd restart
655
656 %preun saslauthd
657 if [ "$1" = "0" ]; then
658         %service saslauthd stop
659         /sbin/chkconfig --del saslauthd
660 fi
661
662 %triggerin saslauthd -- pam
663 # restart saslauthd if pam is upgraded
664 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
665 if [ "$2" != 1 ]; then
666         %service -q saslauthd restart
667 fi
668
669 %files
670 %defattr(644,root,root,755)
671 %doc AUTHORS COPYING ChangeLog NEWS README
672 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
673 %dir %{_sysconfdir}
674 %dir %{_libdir}/sasl2
675 # sample programs to subpackage instead?
676 %attr(755,root,root) %{_bindir}/sasl-sample-client
677 %attr(755,root,root) %{_bindir}/sasl-sample-server
678 %attr(755,root,root) %{_sbindir}/pluginviewer
679 %attr(755,root,root) %{_sbindir}/sasldblistusers2
680 %attr(755,root,root) %{_sbindir}/saslpasswd2
681 %dir /var/lib/sasl2
682 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
683 %{_mandir}/man8/pluginviewer.8*
684 %{_mandir}/man8/sasldblistusers2.8*
685 %{_mandir}/man8/saslpasswd2.8*
686
687 %files libs
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
690 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
691
692 %files devel
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/libsasl2.so
695 %attr(755,root,root) %{_libdir}/libsasl.so
696 %{_libdir}/libsasl2.la
697 %{_includedir}/sasl
698 %{_pkgconfigdir}/libsasl2.pc
699 %{_mandir}/man3/sasl*.3*
700
701 %files static
702 %defattr(644,root,root,755)
703 %{_libdir}/libsasl2.a
704
705 %files anonymous
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
708
709 %if %{with gssapi}
710 %files gssapi
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
713 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
714 %endif
715
716 %files cram-md5
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
719
720 %files digest-md5
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
723
724 %files login
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
727
728 %if %{with mysql}
729 %files mysql
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
732 %endif
733
734 %if %{with ntlm}
735 %files ntlm
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
738 %endif
739
740 %files otp
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
743
744 %if %{with pgsql}
745 %files pgsql
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
748 %endif
749
750 %files plain
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
753
754 %files sasldb
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
757
758 %if %{with ldap}
759 %files ldapdb
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
762 %endif
763
764 %files passdss
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
767
768 %files scram
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
771
772 %if %{with sqlite}
773 %files sqlite
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
776 %endif
777
778 %if %{with sqlite3}
779 %files sqlite3
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
782 %endif
783
784 %if %{with srp}
785 %files srp
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
788 %endif
789
790 %if %{with pwcheck}
791 %files pwcheck
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_sbindir}/pwcheck
794 %endif
795
796 %files saslauthd
797 %defattr(644,root,root,755)
798 %doc cyrus.pam
799 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
800 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
801 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
802 %attr(755,root,root) %{_sbindir}/saslauthd
803 %attr(755,root,root) %{_sbindir}/testsaslauthd
804 %attr(755,root,root) %{_sbindir}/saslcache
805 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
806 %ghost /var/lib/sasl2/cache.flock
807 %ghost /var/lib/sasl2/cache.mmap
808 %ghost /var/lib/sasl2/mux
809 %ghost /var/lib/sasl2/mux.accept
810 %ghost /var/lib/sasl2/saslauthd.pid
811 %{_mandir}/man8/saslauthd.8*
812
813 %files -n nagios-plugin-check_saslauthd
814 %defattr(644,root,root,755)
815 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
816 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.169517 seconds and 3 git commands to generate.