]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
- from scratch
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.2
5 Release:        1
6 License:        GPL
7 #Vendor:                
8 Group:          Development/Languages
9 Group(de):      Entwicklung/Sprachen
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        http://www.cs.cornell.edu/projects/%{name}/%{name}-%{version}.tar.gz
12 Source1:        http://www.cs.cornell.edu/projects/%{name}-%{version}-docs.tar.gz
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-options.patch
15 URL:            http://www.cs.cornell.edu/projects/cyclone/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Cyclone is a language for C programmers who want to write secure, robust
20 programs. It's a dialect of C designed to be safe: free of crashes,
21 buffer overflows, format string attacks, and so on.
22
23 %description -l pl
24 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne i
25 szybkie programy. Jest on dialektem C zaprojektowanym by byæ bezpiecznym:
26 wolnym od SEGV, przepe³nieñ buforów, format string attacks, itd.
27
28 %prep
29 %setup -q -n %{name}
30 %patch0 -p1
31 %patch1 -p1
32 tar zxf %{SOURCE1}
33
34 %build
35 ./configure \
36         -sh /bin/sh \
37         -bindir %{_bindir} \
38         -libdir %{_libdir}/%{name} \
39         -incdir %{_includedir}/%{name} 
40
41 %{__make}
42 %{__make} cyclone_src
43 %{__make} update
44 # hack, there is no doc/ in source distribution
45 mkdir doc
46 echo 'clean:' > doc/Makefile
47 %{__make} clean_nogc
48 # here we got C sources generated from patched cyclone,
49 # we can build for real.
50 %{__make} CFLAGS="%{rpmcflags}" CYC_FLAGS="%{rpmcflags}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 make install DESTDIR=$RPM_BUILD_ROOT
56
57 gzip -9nf INSTALL
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc *.gz online-manual/*
65 %attr(755, root, root) %{_bindir}/*
66 %{_libdir}/%{name}
67 %{_includedir}/%{name}
This page took 0.085528 seconds and 4 git commands to generate.