]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
- simplify unpack Source1,
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.2
5 Release:        1
6 License:        GPL
7 #Vendor:                
8 Group:          Development/Languages
9 Group(de):      Entwicklung/Sprachen
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        http://www.cs.cornell.edu/projects/%{name}/%{name}-%{version}.tar.gz
12 Source1:        http://www.cs.cornell.edu/projects/%{name}-%{version}-docs.tar.gz
13 Patch0:         %{name}-DESTDIR.patch
14 Patch1:         %{name}-options.patch
15 URL:            http://www.cs.cornell.edu/projects/cyclone/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Cyclone is a language for C programmers who want to write secure, robust
20 programs. It's a dialect of C designed to be safe: free of crashes,
21 buffer overflows, format string attacks, and so on.
22
23 %description -l pl
24 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne i
25 szybkie programy. Jest on dialektem C zaprojektowanym by byæ bezpiecznym:
26 wolnym od SEGV, przepe³nieñ buforów, format string attacks, itd.
27
28 %prep
29 %setup -q -n %{name} -a1
30 %patch0 -p1
31 %patch1 -p1
32
33 %build
34 ./configure \
35         -sh /bin/sh \
36         -bindir %{_bindir} \
37         -libdir %{_libdir}/%{name} \
38         -incdir %{_includedir}/%{name} 
39
40 %{__make}
41 %{__make} cyclone_src
42 %{__make} update
43 # hack, there is no doc/ in source distribution
44 mkdir doc
45 echo 'clean:' > doc/Makefile
46 %{__make} clean_nogc
47 # here we got C sources generated from patched cyclone,
48 # we can build for real.
49 %{__make} CFLAGS="%{rpmcflags}" CYC_FLAGS="%{rpmcflags}"
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 make install DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc online-manual/*
62 %attr(755, root, root) %{_bindir}/*
63 %{_libdir}/%{name}
64 %{_includedir}/%{name}
This page took 0.075744 seconds and 4 git commands to generate.