]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
- second part of small fixes inspired by kloczek (this time better checked,
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.2
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.cs.cornell.edu/projects/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  f27081a442bff470f9e477e5d017d2d9
10 Source1:        http://www.cs.cornell.edu/projects/%{name}-%{version}-docs.tar.gz
11 # Source1-md5:  395c1b64bee877a69c314cf33fda1a1e
12 Patch0:         %{name}-DESTDIR.patch
13 Patch1:         %{name}-options.patch
14 URL:            http://www.cs.cornell.edu/projects/cyclone/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Cyclone is a language for C programmers who want to write secure,
19 robust programs. It's a dialect of C designed to be safe: free of
20 crashes, buffer overflows, format string attacks, and so on.
21
22 %description -l pl
23 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne
24 i szybkie programy. Jest on dialektem C zaprojektowanym by byæ
25 bezpiecznym: wolnym od SEGV, przepe³nieñ buforów, format string
26 attacks, itd.
27
28 %prep
29 %setup -q -n %{name} -a1
30 %patch0 -p1
31 %patch1 -p1
32
33 %build
34 %ifarch ppc
35 echo "y" | \
36 %endif
37 ./configure \
38         -sh /bin/sh \
39         -bindir %{_bindir} \
40         -libdir %{_libdir}/%{name} \
41         -incdir %{_includedir}/%{name}
42
43 %{__make}
44 %{__make} cyclone_src
45 %{__make} update
46 # hack, there is no doc/ in source distribution
47 mkdir doc
48 echo 'clean:' > doc/Makefile
49 %{__make} clean_nogc
50 # here we got C sources generated from patched cyclone,
51 # we can build for real.
52 %{__make} CFLAGS="%{rpmcflags}" CYC_FLAGS="%{rpmcflags}"
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc online-manual/*
66 %attr(755, root, root) %{_bindir}/*
67 %{_libdir}/%{name}
68 %{_includedir}/%{name}
This page took 0.056518 seconds and 3 git commands to generate.