]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
429f187e40956d84835ff8955ad0470ee2438829
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.5
5 Release:        0.1
6 License:        GPL
7 Group:          Development/Languages
8 #Source0Download: http://www.cs.cornell.edu/projects/cyclone/
9 Source0:        http://www.cs.cornell.edu/projects/cyclone/software/%{name}-%{version}.tar.gz
10 # Source0-md5:  20d2177e8bc432831fbdaa10aca462ee
11 #Source1Download: http://www.cs.cornell.edu/projects/cyclone/
12 Source1:        http://www.cs.cornell.edu/projects/cyclone/software/%{name}-%{version}-docs.tar.gz
13 # Source1-md5:  a3e557032b3444613089894a0e11dff7
14 Patch0:         %{name}-DESTDIR.patch
15 Patch1:         %{name}-options.patch
16 URL:            http://www.cs.cornell.edu/projects/cyclone/
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Cyclone is a language for C programmers who want to write secure,
21 robust programs. It's a dialect of C designed to be safe: free of
22 crashes, buffer overflows, format string attacks, and so on.
23
24 %description -l pl
25 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne
26 i szybkie programy. Jest on dialektem C zaprojektowanym by byæ
27 bezpiecznym: wolnym od SEGV, przepe³nieñ buforów, format string
28 attacks, itd.
29
30 %prep
31 %setup -q -n %{name}-%{version}-%{version} -a1
32 %patch0 -p1
33 #%patch1 -p1
34
35 %build
36 CFLAGS="%{rpmcflags}"
37 LDFLAGS="%{rpmldflags}"
38 %configure
39
40 %{__make}
41 %{__make} cyclone_src
42 %{__make} update
43 # hack, there is no doc/ in source distribution
44 mkdir doc
45 echo 'clean:' > doc/Makefile
46 %{__make} clean_nogc
47 # here we got C sources generated from patched cyclone,
48 # we can build for real.
49 %{__make} \
50         CFLAGS="%{rpmcflags}" \
51         CYC_FLAGS="%{rpmcflags}"
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc online-manual/*
65 %attr(755,root,root) %{_bindir}/*
66 %{_libdir}/%{name}
67 %{_includedir}/%{name}
This page took 0.061547 seconds and 2 git commands to generate.