]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
377957ec43170652c9670c1a743583518a0eb558
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.5
5 Release:        0.1
6 License:        GPL
7 Group:          Development/Languages
8 #Source0Download: http://www.cs.cornell.edu/projects/cyclone/
9 Source0:        http://www.cs.cornell.edu/projects/cyclone/software/%{name}-%{version}.tar.gz
10 # Source0-md5:  20d2177e8bc432831fbdaa10aca462ee
11 #Source1Download: http://www.cs.cornell.edu/projects/cyclone/
12 Source1:        http://www.cs.cornell.edu/projects/cyclone/software/%{name}-%{version}-docs.tar.gz
13 # Source1-md5:  a3e557032b3444613089894a0e11dff7
14 Patch0:         %{name}-DESTDIR.patch
15 Patch1:         %{name}-options.patch
16 URL:            http://www.cs.cornell.edu/projects/cyclone/
17 BuildRequires:  automake
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Cyclone is a language for C programmers who want to write secure,
22 robust programs. It's a dialect of C designed to be safe: free of
23 crashes, buffer overflows, format string attacks, and so on.
24
25 %description -l pl
26 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne
27 i szybkie programy. Jest on dialektem C zaprojektowanym by byæ
28 bezpiecznym: wolnym od SEGV, przepe³nieñ buforów, format string
29 attacks, itd.
30
31 %prep
32 %setup -q -n %{name}-%{version}-%{version} -a1
33 %patch0 -p1
34 #%patch1 -p1
35
36 %build
37 cp -f /usr/share/automake/config.* config
38 CFLAGS="%{rpmcflags}"
39 LDFLAGS="%{rpmldflags}"
40 %configure
41
42 %{__make}
43 %{__make} cyclone_src
44 %{__make} update
45 # hack, there is no doc/ in source distribution
46 mkdir doc
47 echo 'clean:' > doc/Makefile
48 %{__make} clean_nogc
49 # here we got C sources generated from patched cyclone,
50 # we can build for real.
51 %{__make} \
52         CFLAGS="%{rpmcflags}" \
53         CYC_FLAGS="%{rpmcflags}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc online-manual/*
67 %attr(755,root,root) %{_bindir}/*
68 %{_libdir}/%{name}
69 %{_includedir}/%{name}
This page took 0.052568 seconds and 2 git commands to generate.