]> git.pld-linux.org Git - packages/cyclone.git/blame_incremental - cyclone.spec
- tabs in preamble
[packages/cyclone.git] / cyclone.spec
... / ...
CommitLineData
1Summary: The Cyclone compiler
2Summary(pl.UTF-8): Kompilator języka Cyclone
3Name: cyclone
4Version: 0.5
5Release: 0.1
6License: GPL
7Group: Development/Languages
8Source0: http://www.eecs.harvard.edu/~greg/cyclone/software/%{name}-%{version}.tar.gz
9# Source0-md5: 20d2177e8bc432831fbdaa10aca462ee
10Source1: http://www.eecs.harvard.edu/~greg/cyclone/software/%{name}-%{version}-docs.tar.gz
11# Source1-md5: a3e557032b3444613089894a0e11dff7
12Patch0: %{name}-DESTDIR.patch
13Patch1: %{name}-options.patch
14URL: http://www.eecs.harvard.edu/~greg/cyclone/
15BuildRequires: automake
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
19Cyclone is a language for C programmers who want to write secure,
20robust programs. It's a dialect of C designed to be safe: free of
21crashes, buffer overflows, format string attacks, and so on.
22
23%description -l pl.UTF-8
24Cyclone jest językiem dla programistów C, którzy chcą pisać bezpieczne
25i szybkie programy. Jest on dialektem C zaprojektowanym by być
26bezpiecznym: wolnym od SEGV, przepełnień buforów, format string
27attacks, itd.
28
29%prep
30%setup -q -n %{name}-%{version}-%{version} -a1
31%patch0 -p1
32#%patch1 -p1
33
34%build
35cp -f /usr/share/automake/config.* config
36CFLAGS="%{rpmcflags}"
37LDFLAGS="%{rpmldflags}"
38%configure
39
40%{__make}
41%{__make} cyclone_src
42%{__make} update
43# hack, there is no doc/ in source distribution
44mkdir doc
45echo 'clean:' > doc/Makefile
46%{__make} clean_nogc
47# here we got C sources generated from patched cyclone,
48# we can build for real.
49%{__make} \
50 CFLAGS="%{rpmcflags}" \
51 CYC_FLAGS="%{rpmcflags}"
52
53%install
54rm -rf $RPM_BUILD_ROOT
55
56%{__make} install \
57 DESTDIR=$RPM_BUILD_ROOT
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc online-manual/*
65%attr(755,root,root) %{_bindir}/*
66%{_libdir}/%{name}
67%{_includedir}/%{name}
This page took 0.072777 seconds and 4 git commands to generate.