]> git.pld-linux.org Git - packages/cwiid.git/commitdiff
new, version post-0.6.00 (fadf11e)
authorElan Ruusamäe <glen@delfi.ee>
Mon, 19 Jan 2015 20:14:39 +0000 (22:14 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 19 Jan 2015 20:16:23 +0000 (22:16 +0200)
based on fedora package e2afe85

cwiid.spec [new file with mode: 0644]
wmdemo-lib.patch [new file with mode: 0644]
wmgui.desktop [new file with mode: 0644]

diff --git a/cwiid.spec b/cwiid.spec
new file mode 100644 (file)
index 0000000..960569c
--- /dev/null
@@ -0,0 +1,149 @@
+%define subver fadf11e
+%define rel            1
+Summary:       Wiimote interface library
+Name:          cwiid
+Version:       0.6.00
+Release:       0.%{rel}.%{subver}
+License:       GPL v2+
+Group:         Libraries
+#Source0:      https://github.com/abstrakraft/cwiid/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
+Source0:       https://github.com/abstrakraft/cwiid/archive/%{subver}/%{name}-%{version}-%{subver}.tar.gz
+# Source0-md5: 2d5430a465357242514942ae82139609
+Source1:       wmgui.desktop
+Patch0:                wmdemo-lib.patch
+URL:           http://abstrakraft.org/cwiid/
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: bison
+BuildRequires: bluez-libs-devel
+BuildRequires: desktop-file-utils
+BuildRequires: flex
+BuildRequires: gawk
+BuildRequires: gtk+2-devel
+BuildRequires: python-devel >= 2.4
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+CWiiD is a library that enables your application to communicate with a
+wiimote using a bluetooth connection.
+
+%package devel
+Summary:       Development files for %{name}
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      bluez-libs-devel
+
+%description devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
+%package -n python-%{name}
+Summary:       Python binding for %{name}
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     %{name}-python2
+
+%description -n python-%{name}
+Python2 binding for %{name}
+
+%package utils
+Summary:       Wiimote connection test application
+Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
+Provides:      %{name}-wmgui = %{version}-%{release}
+Obsoletes:     cwiid-wmgui < 0.6.00-7
+
+%description utils
+Applications to test the wiimote connection
+
+%package wminput
+Summary:       Enables using the wiimote as an input source
+# The licence must be GPLv2 instead of GPLv2+ for this package
+# since the file wminput/action_enum.txt is GPLv2 as stated
+# in the file.
+License:       GPL v2
+Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
+Requires:      python-%{name} = %{version}-%{release}
+
+%description wminput
+This program allows the user to use the wiimote to emulate normal
+system input sources like the mouse and keyboard.
+
+%prep
+%setup -qc
+mv %{name}-*/* .
+%patch0 -p1
+
+%build
+%{__aclocal}
+%{__autoconf}
+CC="%{__cc} %{rpmcflags}"
+%configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       LDCONFIG=/bin/true \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
+
+rm -v $RPM_BUILD_ROOT%{_libdir}/libcwiid.a
+
+desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} %{SOURCE1}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS NEWS README COPYING ChangeLog
+%attr(755,root,root) %{_libdir}/libcwiid.so.1.0
+%ghost %{_libdir}/libcwiid.so.1
+
+%files devel
+%defattr(644,root,root,755)
+%{_includedir}/cwiid.h
+%{_libdir}/libcwiid.so
+%{_pkgconfigdir}/cwiid.pc
+
+%files -n python-%{name}
+%defattr(644,root,root,755)
+%attr(755,root,root) %{py_sitedir}/cwiid.so
+%{py_sitedir}/cwiid-%{version}-py*.egg-info
+
+%files wminput
+%defattr(644,root,root,755)
+%doc doc/Xmodmap doc/wminput.list
+%dir %{_sysconfdir}/cwiid
+%dir %{_sysconfdir}/cwiid/wminput
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/acc_led
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/acc_ptr
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/buttons
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/default
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/gamepad
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/ir_ptr
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/neverball
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/nunchuk_acc_ptr
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/nunchuk_stick2btn
+%attr(755,root,root) %{_bindir}/wminput
+%{_mandir}/man1/wminput.1*
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/plugins
+%attr(755,root,root) %{_libdir}/%{name}/plugins/acc.so
+%attr(755,root,root) %{_libdir}/%{name}/plugins/ir_ptr.so
+%attr(755,root,root) %{_libdir}/%{name}/plugins/led.so
+%attr(755,root,root) %{_libdir}/%{name}/plugins/nunchuk_acc.so
+%attr(755,root,root) %{_libdir}/%{name}/plugins/nunchuk_stick2btn.so
+
+%files utils
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/lswm
+%attr(755,root,root) %{_bindir}/wmgui
+%{_mandir}/man1/wmgui.1*
+%{_desktopdir}/wmgui.desktop
diff --git a/wmdemo-lib.patch b/wmdemo-lib.patch
new file mode 100644 (file)
index 0000000..282bc31
--- /dev/null
@@ -0,0 +1,28 @@
+# this patch is in github fork git://github.com/bogado/cwiid.git
+# there is an upstream bug filed at http://abstrakraft.org/cwiid/ticket/105
+
+From 3e9dc39b9315bc86a007d0c43d1c14f7e67f41e6 Mon Sep 17 00:00:00 2001
+From: Victor Bogado <victor@bogado.net>
+Date: Wed, 5 May 2010 20:08:59 -0300
+Subject: [PATCH] Fix missing library from wmdemo
+
+---
+ wmdemo/Makefile.in |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/wmdemo/Makefile.in b/wmdemo/Makefile.in
+index 56aed58..1eccc02 100644
+--- a/wmdemo/Makefile.in
++++ b/wmdemo/Makefile.in
+@@ -8,7 +8,7 @@ SOURCES = wmdemo.c
+ CFLAGS += -I@top_builddir@/libcwiid
+ LDFLAGS += -L@top_builddir@/libcwiid
+-LDLIBS += -lcwiid
++LDLIBS += -lcwiid -lbluetooth
+ INST_DIR = @bindir@
+ include $(COMMON)/include/app.mak
+-- 
+1.6.6.1
+
diff --git a/wmgui.desktop b/wmgui.desktop
new file mode 100644 (file)
index 0000000..cbe740f
--- /dev/null
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=wmgui
+GenericName=Wiimote connection tester
+Comment=Test the connection to wiimotes.
+Exec=wmgui
+Icon=wmgui
+Terminal=false
+Type=Application
+Categories=GTK;Utility;System;
+
This page took 0.153269 seconds and 4 git commands to generate.