]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
up to 8.7.1 (fixes CVE-2024-2004 CVE-2024-2379 CVE-2024-2398 CVE-2024-2466)
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # SSH support
4 %bcond_without  ssl             # SSL support
5 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
6 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
7 %bcond_without  ldap            # LDAP support
8 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
9 %bcond_without  metalink        # metalink support
10 %if "%{pld_release}" != "ac"
11 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
12 %bcond_without  rtmp            # Real Time Media Protocol support
13 %else
14 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
15 %bcond_with     rtmp            # Real Time Media Protocol support
16 %endif
17
18 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
19 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
23 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
24 Name:           curl
25 Version:        7.60.0
26 Release:        2
27 License:        MIT-like
28 Group:          Applications/Networking
29 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
30 # Source0-md5:  a889cd11b4ae8794b7030472cb4df0a0
31 Patch0:         %{name}-ac.patch
32 Patch1:         %{name}-krb5flags.patch
33 URL:            http://curl.haxx.se/
34 BuildRequires:  autoconf >= 2.57
35 BuildRequires:  automake
36 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
37 %{?with_kerberos5:BuildRequires:        heimdal-devel}
38 BuildRequires:  libbrotli-devel >= 1.0.0
39 BuildRequires:  libidn2-devel
40 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
41 BuildRequires:  libpsl-devel
42 %{?with_rtmp:BuildRequires:     librtmp-devel}
43 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
44 BuildRequires:  libtool
45 BuildRequires:  nettle-devel
46 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.9.0}
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpm >= 4.4.9-56
50 BuildRequires:  rpmbuild(macros) >= 1.527
51 %if %{with ssl}
52 %if %{with gnutls}
53 BuildRequires:  gnutls-devel
54 %else
55 BuildRequires:  openssl-devel >= 1.0.1
56 %endif
57 %endif
58 BuildRequires:  tar >= 1:1.22
59 BuildRequires:  zlib-devel
60 Requires:       %{name}-libs = %{version}-%{release}
61 Obsoletes:      libcurl2
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 cURL is a tool for getting files with URL syntax, supporting FTP,
66 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
67 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
68 cookies, user+password authentication and a busload of other useful
69 tricks. The main use for curl is when you want to get or send files
70 automatically to or from a site using one of the supported protocols.
71
72 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
73 Dict servers, using any of the supported protocols. cURL is designed
74 to work without user interaction or any kind of interactivity. cURL
75 offers many useful capabilities, like proxy support, user
76 authentication, FTP upload, HTTP post, and file transfer resume.
77
78 %description -l pl.UTF-8
79 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
80 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
81 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
82 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
83 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
84 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
85 pliki z/na serwer używając jednego z dostępnych protokołów.
86 %{?with_ssl:Ten pakiet obsługuje także SSL.}
87
88 %description -l pt_BR.UTF-8
89 Curl é um cliente para baixar/enviar arquivos de/para servidores
90 usando um dos protocolos suportados. É projetado para funcionar sem a
91 interação do usuário.
92
93 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
94 continuar transferências interrompidas, e mais...
95
96 %description -l ru.UTF-8
97 curl - это клиент с множеством поддерживаемых протоколов для получения
98 файлов с серверов, спроектированный для работы как в неинтерактивном
99 режиме, так и с возможностью диалога с пользователем.
100
101 curl поддерживает много полезных возможностей, среди которых поддержка
102 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
103 POST, восстановление прерванной пересылки и многое другое.
104
105 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
106 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
107 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
108
109 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
110 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
111 в╕дновлення перервано╖ пересилки та багато ╕ншого.
112
113 %package libs
114 Summary:        curl library
115 Summary(pl.UTF-8):      Biblioteka curl
116 Group:          Libraries
117 %{?with_ares:Requires:  c-ares >= 1.7.0}
118 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
119 %{?with_http2:Requires: nghttp2-libs >= 1.9.0}
120 %if %{with ssl} && %{without gnutls}
121 Requires:       openssl >= 1.0.1
122 %endif
123 Suggests:       ca-certificates
124 Conflicts:      ca-certificates < 20080809-4
125
126 %description libs
127 curl library.
128
129 %description libs -l pl.UTF-8
130 Biblioteka curl.
131
132 %package devel
133 Summary:        Header files and development documentation for curl library
134 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
135 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
136 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
137 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
138 Group:          Development/Libraries
139 Requires:       %{name}-libs = %{version}-%{release}
140 %{?with_ares:Requires:  c-ares-devel}
141 %{?with_kerberos5:Requires:     heimdal-devel}
142 Requires:       libbrotli-devel >= 1.0.0
143 Requires:       libidn2-devel
144 Requires:       libpsl-devel
145 %{?with_rtmp:Requires:  librtmp-devel}
146 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
147 %{?with_http2:Requires: nghttp2-devel >= 1.9.0}
148 %{?with_ldap:Requires:  openldap-devel}
149 %if %{with ssl}
150 %if %{with gnutls}
151 Requires:       gnutls-devel
152 %else
153 Requires:       openssl-devel >= 0.9.7c
154 %endif
155 %endif
156 Requires:       zlib-devel
157 Obsoletes:      libcurl2-devel
158
159 %description devel
160 Header files and development documentation for curl library.
161
162 %description devel -l pl.UTF-8
163 Pliki nagłówkowe i dokumentacja do biblioteki curl.
164
165 %description devel -l pt_BR.UTF-8
166 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
167
168 %description devel -l ru.UTF-8
169 Этот пакет содержит файлы, необходимые для разработки программ с
170 использованием библиотеки curl.
171
172 %description devel -l uk.UTF-8
173 Цей пакет містить файли, необхідні для розробки програм з
174 використанням бібліотеки curl.
175
176 %package static
177 Summary:        Static version of curl library
178 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
179 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
180 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
181 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
182 Group:          Development/Libraries
183 Requires:       %{name}-devel = %{version}-%{release}
184
185 %description static
186 Static version of curl library.
187
188 %description static -l pl.UTF-8
189 Statyczna wersja biblioteki curl.
190
191 %description static -l pt_BR.UTF-8
192 Bibliotecas estáticas para desenvolvimento com o curl.
193
194 %description static -l ru.UTF-8
195 Этот пакет содержит статическую библиотеку для разработки программ с
196 использованием библиотеки curl.
197
198 %description static -l uk.UTF-8
199 Цей пакет містить статичну бібліотеку для розробки програм з
200 використанням бібліотеки curl.
201
202 %package -n zsh-completion-curl
203 Summary:        ZSH completion for curl command
204 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
205 Group:          Applications/Shells
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       zsh
208
209 %description -n zsh-completion-curl
210 ZSH completion for curl command.
211
212 %description -n zsh-completion-curl -l pl.UTF-8
213 Dopełnianianie parametrów w ZSH dla polecenia curl.
214
215 %prep
216 %setup -q
217 %patch0 -p1
218 %patch1 -p1
219
220 %{__rm} m4/lt*.m4 m4/libtool.m4
221
222 %build
223 %{__libtoolize}
224 %{__aclocal} -I m4
225 %{__autoconf}
226 %{__autoheader}
227 %{__automake}
228 %configure \
229         ac_cv_header_gss_h=no \
230         %{__enable_disable ares} \
231         --enable-ipv6 \
232         %{__enable_disable ldap} \
233         %{__enable_disable ldap ldaps} \
234         --disable-silent-rules \
235 %if %{with ssl}
236         --with-ca-bundle=/etc/certs/ca-certificates.crt \
237 %if %{with gnutls}
238         --with-gnutls --without-ssl \
239 %else
240         --with-ssl=%{_prefix} \
241 %endif
242 %endif
243         %{__with_without kerberos5 gssapi %{_prefix}} \
244         %{__with_without metalink libmetalink} \
245         %{__with_without rtmp librtmp} \
246         %{__with_without http2 nghttp2} \
247         %{__with_without ssh libssh2}
248
249 %{__make}
250
251 %install
252 rm -rf $RPM_BUILD_ROOT
253 %{__make} install \
254         DESTDIR=$RPM_BUILD_ROOT
255
256 %{__make} -C scripts install \
257         DESTDIR=$RPM_BUILD_ROOT
258
259 # no longer in upstream but a lot of apps tries to include it so we create fake one
260 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
261 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %post   libs -p /sbin/ldconfig
267 %postun libs -p /sbin/ldconfig
268
269 %files
270 %defattr(644,root,root,755)
271 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,MANUAL,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
272 %attr(755,root,root) %{_bindir}/curl
273 %{_mandir}/man1/curl.1*
274
275 %files libs
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
278 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
279
280 %files devel
281 %defattr(644,root,root,755)
282 %doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
283 %attr(755,root,root) %{_bindir}/curl-config
284 %attr(755,root,root) %{_libdir}/libcurl.so
285 %{_libdir}/libcurl.la
286 %{_includedir}/curl
287 %{_pkgconfigdir}/libcurl.pc
288 %{_aclocaldir}/libcurl.m4
289 %{_mandir}/man1/curl-config.1*
290 %{_mandir}/man3/curl_*.3*
291 %{_mandir}/man3/libcurl*.3*
292 %{_mandir}/man3/CURLINFO_*.3*
293 %{_mandir}/man3/CURLOPT_*.3*
294 %{_mandir}/man3/CURLMOPT_*.3*
295
296 %files static
297 %defattr(644,root,root,755)
298 %{_libdir}/libcurl.a
299
300 %files -n zsh-completion-curl
301 %defattr(644,root,root,755)
302 %{_datadir}/zsh/site-functions/_curl
This page took 0.106598 seconds and 3 git commands to generate.