]> git.pld-linux.org Git - packages/cura.git/commitdiff
- more fixes, partially works (doesn't generate gcode unfortunately)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 14 May 2015 21:13:07 +0000 (23:13 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 14 May 2015 21:13:07 +0000 (23:13 +0200)
cura
cura-no-firmware.patch
cura.spec

diff --git a/cura b/cura
index 322824e5abb54998a6e8c62a4b455a022fe248e5..738e76f19a3aa3a23afbd174cdcce5aa72b71245 100755 (executable)
--- a/cura
+++ b/cura
@@ -9,7 +9,7 @@ for i in range(len(sys.argv)):
         sys.argv[i] = os.path.abspath(sys.argv[i])
 
 # change the pwd
-os.chdir("/usr/lib/python2.7/site-packages/")
+os.chdir("/usr/%s/python2.7/site-packages/" % sys.lib)
 
 # start cura
 cura.main()
index 39a38734b9ad4835e7c42e5369102c9656797cf9..e3c92cb49b16fc60cd04d047333e3cc2923ad49d 100644 (file)
@@ -54,7 +54,7 @@ diff -urN Cura-15.02.1.org/Cura/gui/firmwareInstall.py Cura-15.02.1/Cura/gui/fir
                        filename = getDefaultFirmware(machineIndex)
                if filename is None:
 -                      wx.MessageBox(_("I am sorry, but Cura does not ship with a default firmware for your machine configuration."), _("Firmware update"), wx.OK | wx.ICON_ERROR)
-+            wx.MessageBox(_("I am sorry, but Cura on Fedora does not ship firmware for technical reasons. Please go download it and install it as custom firmware instead."), _("Firmware update"), wx.OK | wx.ICON_ERROR)
++                      wx.MessageBox(_("I am sorry, but Cura on Fedora does not ship firmware for technical reasons. Please go download it and install it as custom firmware instead."), _("Firmware update"), wx.OK | wx.ICON_ERROR)
                        self.Destroy()
                        return
                self._machine_type = profile.getMachineSetting('machine_type', machineIndex)
index 2b6cb254b9e582603a8a7553bedee0dafbc040f6..1de110d0a20749b12dd359859690216f198f3a2e 100644 (file)
--- a/cura.spec
+++ b/cura.spec
@@ -26,12 +26,13 @@ BuildRequires:      dos2unix
 BuildRequires: gettext
 BuildRequires: python-devel
 Requires:      CuraEngine >= 14.12.1
-Requires:      pypy
+#?
+#Requires:     pypy
 Requires:      python-PyOpenGL
 Requires:      python-numpy
 Requires:      python-power
 Requires:      python-serial
-Requires:      wxPython
+Requires:      python-wxPython
 BuildArch:     noarch
 
 %description
This page took 0.08343 seconds and 4 git commands to generate.