]> git.pld-linux.org Git - packages/cups.git/blobdiff - cups.spec
- php and perl are gone
[packages/cups.git] / cups.spec
index 2f351e12e32766acfeb5dbe671f506decf6c2ed0..bc9965e987ad8bca82387cf081eaef478862d3f2 100644 (file)
--- a/cups.spec
+++ b/cups.spec
@@ -1,28 +1,25 @@
 #
 # Conditional build:
 %bcond_with    gnutls          # use GNU TLS for SSL/TLS support (instead of OpenSSL)
-%bcond_with    dnssd           # DNS Service Discovery support (obsoleted by Avahi patch)
-%bcond_without avahi           # DNS Service Discovery support via Avahi
+%bcond_without dnssd           # DNS Service Discovery support (obsoleted by Avahi patch)
+%bcond_with    avahi           # DNS Service Discovery support via Avahi
 %bcond_without ldap            # do not include LDAP support
 %bcond_without gssapi          # do not include GSSAPI support
-%bcond_without php             # don't build PHP extension/support in web interface
-%bcond_without perl            # don't build Perl extension/support in web interface
 %bcond_without python          # don't build Python support in web interface
 %bcond_without slp             # do not include SLP support
 %bcond_without static_libs     # don't build static library
 
 %define                pdir CUPS
-%include       /usr/lib/rpm/macros.perl
 Summary(pl.UTF-8):     Ogólny system druku dla Uniksa
 Summary(pt_BR.UTF-8):  Sistema Unix de Impressão
 Name:          cups
-Version:       1.5.0
-Release:       8
+Version:       1.5.1
+Release:       0.1
 Epoch:         1
 License:       LGPL v2 (libraries), GPL v2 (the rest) + openssl exception
 Group:         Applications/Printing
 Source0:       http://ftp.easysw.com/pub/cups/%{version}/%{name}-%{version}-source.tar.bz2
-# Source0-md5: e54ed09ede2340fc3014913333520fe4
+# Source0-md5: 7e7026f5b6392deae46f889129b196a7
 Source1:       %{name}.init
 Source2:       %{name}.pamd
 Source3:       %{name}.logrotate
@@ -43,8 +40,6 @@ Patch9:               %{name}-verbose-compilation.patch
 Patch10:       %{name}-peercred.patch
 Patch11:       %{name}-usb.patch
 Patch12:       %{name}-desktop.patch
-Patch13:       %{name}-ssl-segfault.patch
-Patch14:       %{name}-auth.patch
 # avahi patches from fedora
 Patch100:      %{name}-avahi-1-config.patch
 Patch101:      %{name}-avahi-2-backend.patch
@@ -72,15 +67,12 @@ BuildRequires:      libusb-devel
 %{?with_slp:BuildRequires:     openslp-devel}
 %{!?with_gnutls:BuildRequires: openssl-devel}
 BuildRequires: pam-devel
-%{?with_php:BuildRequires:     php-devel >= 4:5.0.0}
 BuildRequires: pkgconfig
-BuildRequires: rpm-perlprov
 BuildRequires: rpmbuild(macros) >= 1.344
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      openssl-tools
 Requires:      pam >= 0.77.3
-Requires:      perl-modules
 Requires:      rc-scripts
 Suggests:      ImageMagick-coder-pdf
 Suggests:      cups-filter-pstoraster
@@ -220,35 +212,6 @@ Ogólny system druku dla Uniksa - biblioteki statyczne.
 Bibliotecas estáticas para desenvolvimento de programas que usam as
 bibliotecas do CUPS.
 
-%package -n perl-cups
-Summary:       Perl module for CUPS
-Summary(pl.UTF-8):     Moduł Perla CUPS
-License:       GPL v2 + openssl exception
-Group:         Development/Languages/Perl
-Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
-
-%description -n perl-cups
-Perl module for Common Unix Printing System.
-
-%description -n perl-cups -l pl.UTF-8
-Moduł Perla do ogólnego systemu druku dla Uniksa.
-
-%package -n php-cups
-Summary:       PHP module for CUPS
-Summary(pl.UTF-8):     Moduł PHP CUPS
-License:       GPL v2 + openssl exception
-Group:         Development/Languages/PHP
-Requires:      %{name}-lib = %{epoch}:%{version}-%{release}
-%{?requires_php_extension}
-Requires:      /etc/php/conf.d
-Requires:      php-common >= 4:5.0.0
-
-%description -n php-cups
-PHP module for Common Unix Printing System.
-
-%description -n php-cups -l pl.UTF-8
-Moduł PHP do ogólnego systemu druku dla Uniksa.
-
 %package backend-usb
 Summary:       USB backend for CUPS
 Summary(pl.UTF-8):     Backend USB dla CUPS-a
@@ -321,14 +284,14 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
 # why it hasn't been merged for so long (and why no other distro uses it)
 #%patch11 -p1
 %patch12 -p1
-%patch13 -p0
-%patch14 -p0
 
+%if %{with avahi}
 %patch100 -p1
 %patch101 -p1
 %patch102 -p1
 %patch103 -p1
 %patch104 -p1
+%endif
 
 %build
 %{__aclocal} -I config-scripts
@@ -365,28 +328,10 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
        --with-optim=-Wno-format-y2k \
        %{?with_dnssd:--with-dnssd-libs=x} \
        %{?with_dnssd:--with-dnssd-includes=x} \
-       %{?with_perl:--with-perl=%{_bindir}/perl} \
-       %{?with_php:--with-php=%{_bindir}/php} \
        %{?with_python:--with-python=%{_bindir}/python}
 
 %{__make} %{?debug:OPTIONS="-DDEBUG"}
 
-%{__perl} -pi -e 's#-I\.\.\/\.\.#-I../.. -I../../cups#g' scripting/php/Makefile
-%{?with_php:%{__make} -C scripting/php PHPCONFIG=%{_bindir}/php-config}
-
-%if %{with perl}
-cd scripting/perl
-%{__perl} -pi -e 's@-lcups@-L../../cups $1@' Makefile.PL
-%{__perl} Makefile.PL \
-       INSTALLDIRS=vendor \
-       OPTIMIZE="%{rpmcflags} -I../.."
-# avoid rpaths generated by MakeMaker
-%{__perl} -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' Makefile
-
-%{__make}
-cd ../..
-%endif
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,logrotate.d,modprobe.d,security,sysconfig/rc-inetd} \
@@ -407,21 +352,6 @@ if [ "%{_lib}" != "lib" ] ; then
 %endif
 fi
 
-%if %{with php}
-%{__make} -C scripting/php install \
-       PHPDIR=$RPM_BUILD_ROOT%{php_extensiondir}
-install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
-cat > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/phpcups.ini << 'EOF'
-; Enable phpcups extension module
-extension=phpcups.so
-EOF
-%endif
-
-%if %{with perl}
-%{__make} -C scripting/perl install \
-       DESTDIR=$RPM_BUILD_ROOT
-%endif
-
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/%{name}
 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
@@ -478,14 +408,6 @@ fi
 %post  image-lib -p /sbin/ldconfig
 %postun        image-lib -p /sbin/ldconfig
 
-%post -n php-cups
-%php_webserver_restart
-
-%postun -n php-cups
-if [ "$1" = 0 ]; then
-       %php_webserver_restart
-fi
-
 %post lpd
 %service -q rc-inetd reload
 
@@ -715,25 +637,6 @@ fi
 %{_libdir}/libcupsppdc.a
 %endif
 
-%if %{with perl}
-%files -n perl-cups
-%defattr(644,root,root,755)
-%{perl_vendorarch}/CUPS.pm
-%dir %{perl_vendorarch}/auto/CUPS
-%{perl_vendorarch}/auto/CUPS/CUPS.bs
-%{perl_vendorarch}/auto/CUPS/autosplit.ix
-%attr(755,root,root) %{perl_vendorarch}/auto/CUPS/CUPS.so
-%{_mandir}/man3/CUPS.3pm*
-%endif
-
-%if %{with php}
-%files -n php-cups
-%defattr(644,root,root,755)
-%doc scripting/php/README
-%attr(755,root,root) %{php_extensiondir}/phpcups.so
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/phpcups.ini
-%endif
-
 %files backend-usb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_ulibdir}/cups/backend/usb
This page took 0.037054 seconds and 4 git commands to generate.