]> git.pld-linux.org Git - packages/cups.git/blobdiff - cups.spec
- added tmpfiles config for systemd
[packages/cups.git] / cups.spec
index 1f0edc244dbc3db0a328e3a676acba13c569a19c..2f351e12e32766acfeb5dbe671f506decf6c2ed0 100644 (file)
--- a/cups.spec
+++ b/cups.spec
@@ -1,7 +1,8 @@
 #
 # Conditional build:
 %bcond_with    gnutls          # use GNU TLS for SSL/TLS support (instead of OpenSSL)
-%bcond_without dnssd           # DNS Service Discovery support
+%bcond_with    dnssd           # DNS Service Discovery support (obsoleted by Avahi patch)
+%bcond_without avahi           # DNS Service Discovery support via Avahi
 %bcond_without ldap            # do not include LDAP support
 %bcond_without gssapi          # do not include GSSAPI support
 %bcond_without php             # don't build PHP extension/support in web interface
 %bcond_without python          # don't build Python support in web interface
 %bcond_without slp             # do not include SLP support
 %bcond_without static_libs     # don't build static library
-#
-%include       /usr/lib/rpm/macros.perl
-%define                pdir CUPS
 
+%define                pdir CUPS
+%include       /usr/lib/rpm/macros.perl
 Summary(pl.UTF-8):     Ogólny system druku dla Uniksa
 Summary(pt_BR.UTF-8):  Sistema Unix de Impressão
 Name:          cups
 Version:       1.5.0
-Release:       3
+Release:       8
 Epoch:         1
 License:       LGPL v2 (libraries), GPL v2 (the rest) + openssl exception
 Group:         Applications/Printing
@@ -29,6 +29,7 @@ Source3:      %{name}.logrotate
 Source4:       %{name}.mailto.conf
 Source5:       %{name}-lpd.inetd
 Source6:       %{name}-modprobe.conf
+Source7:       %{name}.tmpfiles
 # svn diff http://svn.easysw.com/public/cups/tags/release-1.4.3/ http://svn.easysw.com/public/cups/branches/branch-1.4/ > cups-branch.diff
 # + drop config-scripts/cups-common.m4 change
 Patch0:                %{name}-config.patch
@@ -43,11 +44,19 @@ Patch10:    %{name}-peercred.patch
 Patch11:       %{name}-usb.patch
 Patch12:       %{name}-desktop.patch
 Patch13:       %{name}-ssl-segfault.patch
+Patch14:       %{name}-auth.patch
+# avahi patches from fedora
+Patch100:      %{name}-avahi-1-config.patch
+Patch101:      %{name}-avahi-2-backend.patch
+Patch102:      %{name}-avahi-3-timeouts.patch
+Patch103:      %{name}-avahi-4-poll.patch
+Patch104:      %{name}-avahi-5-services.patch
 URL:           http://www.cups.org/
 BuildRequires: acl-devel
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
-%{?with_dnssd:BuildRequires:   avahi-compat-libdns_sd-devel}
+%{?with_dnssd:BuildRequires:    avahi-compat-libdns_sd-devel}
+%{?with_avahi:BuildRequires: avahi-devel}
 BuildRequires: dbus-devel
 BuildRequires: glibc-headers
 %{?with_gnutls:BuildRequires:  gnutls-devel}
@@ -312,7 +321,14 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
 # why it hasn't been merged for so long (and why no other distro uses it)
 #%patch11 -p1
 %patch12 -p1
-%patch13 -p1
+%patch13 -p0
+%patch14 -p0
+
+%patch100 -p1
+%patch101 -p1
+%patch102 -p1
+%patch103 -p1
+%patch104 -p1
 
 %build
 %{__aclocal} -I config-scripts
@@ -330,6 +346,7 @@ Wsparcie dla LPD w serwerze wydruków CUPS.
        --enable-shared \
        --enable-ssl \
        %{?debug:--enable-debug} \
+       --%{!?with_avahi:dis}%{?with_avahi:en}able-avahi \
        --%{!?with_dnssd:dis}%{?with_dnssd:en}able-dnssd \
        --%{!?with_ldap:dis}%{?with_ldap:en}able-ldap \
        --%{!?with_gssapi:dis}%{?with_gssapi:en}able-gssapi \
@@ -374,7 +391,8 @@ cd ../..
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,logrotate.d,modprobe.d,security,sysconfig/rc-inetd} \
        $RPM_BUILD_ROOT/var/run/cups \
-       $RPM_BUILD_ROOT/var/log/{,archive/}cups
+       $RPM_BUILD_ROOT/var/log/{,archive/}cups \
+       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 %{__make} install \
        BUILDROOT=$RPM_BUILD_ROOT \
@@ -404,12 +422,13 @@ EOF
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
-install %{SOURCE1}     $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install %{SOURCE2}     $RPM_BUILD_ROOT/etc/pam.d/%{name}
-install %{SOURCE3}     $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/%{name}
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/cups/mailto.conf
 sed -e 's|__ULIBDIR__|%{_ulibdir}|g' %{SOURCE5} > $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/cups-lpd
-install %{SOURCE6}     $RPM_BUILD_ROOT/etc/modprobe.d/cups.conf
+install %{SOURCE6} $RPM_BUILD_ROOT/etc/modprobe.d/cups.conf
+install %{SOURCE7} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
 
 touch $RPM_BUILD_ROOT/var/log/cups/{access_log,error_log,page_log}
 touch $RPM_BUILD_ROOT/etc/security/blacklist.cups
@@ -517,10 +536,15 @@ fi
 %lang(pl) %{_ulibdir}/cups/cgi-bin/pl
 %lang(ru) %{_ulibdir}/cups/cgi-bin/ru
 
-%exclude %{_ulibdir}/cups/backend/usb
-%exclude %{_ulibdir}/cups/backend/serial
-%exclude %{_ulibdir}/cups/backend/parallel
-%attr(755,root,root) %{_ulibdir}/cups/backend/*
+%attr(755,root,root) %{_ulibdir}/cups/backend/dnssd
+%attr(755,root,root) %{_ulibdir}/cups/backend/http
+%attr(755,root,root) %{_ulibdir}/cups/backend/https
+%attr(755,root,root) %{_ulibdir}/cups/backend/ipp
+%attr(755,root,root) %{_ulibdir}/cups/backend/ipps
+%attr(755,root,root) %{_ulibdir}/cups/backend/lpd
+%attr(755,root,root) %{_ulibdir}/cups/backend/mdns
+%attr(755,root,root) %{_ulibdir}/cups/backend/snmp
+%attr(755,root,root) %{_ulibdir}/cups/backend/socket
 %attr(755,root,root) %{_ulibdir}/cups/daemon/cups-deviced
 %attr(755,root,root) %{_ulibdir}/cups/daemon/cups-driverd
 %attr(755,root,root) %{_ulibdir}/cups/daemon/cups-exec
@@ -578,6 +602,7 @@ fi
 %{_mandir}/man8/cupsfilter.8*
 %{_mandir}/man8/lp*
 
+/usr/lib/tmpfiles.d/%{name}.conf
 %dir %attr(775,root,lp) /var/cache/cups
 %dir %attr(755,root,lp) /var/lib/cups
 %dir %attr(511,lp,sys) /var/lib/cups/certs
This page took 0.072839 seconds and 4 git commands to generate.