]> git.pld-linux.org Git - packages/cudatoolkit.git/blame_incremental - cudatoolkit.spec
- rel 3
[packages/cudatoolkit.git] / cudatoolkit.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with prof # package computeprof (requires Qt < 4.7)
4#
5Summary: NVIDIA CUDA Toolkit
6Summary(pl.UTF-8): Zestaw narzędzi NVIDIA CUDA
7Name: cudatoolkit
8Version: 3.1
9Release: 3
10License: nVidia Binary
11Group: Applications
12Source0: http://developer.download.nvidia.com/compute/cuda/3_1/toolkit/%{name}_%{version}_linux_32_fedora12.run
13# Source0-md5: da98863cf8d538a083dd8958133f76a9
14Source1: http://developer.download.nvidia.com/compute/cuda/3_1/toolkit/%{name}_%{version}_linux_64_fedora12.run
15# Source1-md5: 704b9b937526b758cf8e33817de64d35
16URL: http://www.nvidia.com/object/cuda_home.html
17Requires: %{name}-libs = %{version}-%{release}
18%{?with_prof:Requires: qt4-assistant}
19Requires: xorg-driver-video-nvidia-libs >= 1:190.53-4
20ExclusiveArch: %{ix86} %{x8664}
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The CUDA™ architecture enables developers to leverage the massively
25parallel processing power of NVIDIA GPUs, delivering the performance
26of NVIDIA’s world-renowned graphics processor technology to general
27purpose GPU Computing.
28
29With the CUDA architecture and tools, developers are achieving
30dramatic speedups in fields such as medical imaging and natural
31resource exploration, and creating breakthrough applications in areas
32such as image recognition and real-time HD video playback and
33encoding.
34
35CUDA enables this unprecedented performance via standard APIs such
36OpenCL and DirectCompute, and high level programming languages such as
37C/C++, Fortran, Java, Python, and the Microsoft .NET Framework.
38
39##description -l pl.UTF-8
40
41%package libs
42Summary: NVIDIA CUDA libraries
43Summary(pl.UTF-8): Biblioteki NVIDIA CUDA
44Group: Libraries
45
46%description libs
47NVIDIA CUDA libraries.
48
49%description libs -l pl.UTF-8
50Biblioteki NVIDIA CUDA.
51
52%prep
53%setup -qcT
54%ifarch %{ix86}
55/bin/sh %{SOURCE0} --noexec --keep
56%else
57/bin/sh %{SOURCE1} --noexec --keep
58%endif
59
60cp -a pkg/computeprof/doc pkg/computeprof/computeprof
61
62%build
63
64%install
65rm -rf $RPM_BUILD_ROOT
66install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/cuda/prof/{doc,bin}} \
67 $RPM_BUILD_ROOT{%{_mandir}/man{1,3},%{_includedir}/cuda} \
68 $RPM_BUILD_ROOT%{_sysconfdir}
69
70install pkg/bin/* $RPM_BUILD_ROOT%{_bindir}
71cp -a pkg/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
72install pkg/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
73install pkg/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
74cp -a pkg/include/* $RPM_BUILD_ROOT%{_includedir}/cuda
75
76cp -a pkg/open64 $RPM_BUILD_ROOT%{_libdir}/cuda
77
78mv $RPM_BUILD_ROOT%{_bindir}/nvcc{,.bin}
79cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/nvcc.conf
80INCLUDES="-I/usr/include/cuda"
81LIBRARIES="-lcudart"
82
83CUDAFE_FLAGS=
84OPENCC_FLAGS=
85PTXAS_FLAGS=
86EOF
87
88cat <<EOF >$RPM_BUILD_ROOT%{_bindir}/nvcc
89#!/bin/sh
90
91. %{_sysconfdir}/nvcc.conf
92
93export INCLUDES LIBRARIES CUDAFE_FLAGS OPENCC_FLAGS PTXAS_FLAG
94
95exec %{_bindir}/nvcc.bin "\$@"
96EOF
97
98%if %{with prof}
99cp -a pkg/computeprof/doc/computeprof.{html,q*} $RPM_BUILD_ROOT%{_libdir}/cuda/prof/doc
100cp -a pkg/computeprof/doc/help.png $RPM_BUILD_ROOT%{_libdir}/cuda/prof/doc
101install pkg/computeprof/bin/computeprof $RPM_BUILD_ROOT%{_libdir}/cuda/prof/bin
102
103ln -s %{_libdir}/qt4/bin/assistant $RPM_BUILD_ROOT%{_libdir}/cuda/prof/bin/assistant
104ln -s %{_libdir}/cuda/prof/bin/computeprof $RPM_BUILD_ROOT%{_bindir}/computeprof
105%endif
106
107ln -s %{_libdir}/cuda/open64/bin/nvopencc $RPM_BUILD_ROOT%{_bindir}/nvopencc
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post libs -p /sbin/ldconfig
113%postun libs -p /sbin/ldconfig
114
115%files
116%defattr(644,root,root,755)
117%doc pkg/doc/* pkg/bin/nvcc.profile
118%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nvcc.conf
119%attr(755,root,root) %{_bindir}/bin2c
120%attr(755,root,root) %{_bindir}/cuda-gdb
121%attr(755,root,root) %{_bindir}/cuda-memcheck
122%attr(755,root,root) %{_bindir}/cudafe*
123%attr(755,root,root) %{_bindir}/fatbin
124%attr(755,root,root) %{_bindir}/filehash
125%attr(755,root,root) %{_bindir}/nvcc
126%attr(755,root,root) %{_bindir}/nvcc.bin
127%attr(755,root,root) %{_bindir}/nvopencc
128%attr(755,root,root) %{_bindir}/ptxas
129%{_includedir}/cuda
130%dir %{_libdir}/cuda
131%if %{with prof}
132%doc pkg/computeprof/CUDA_Visual_Profiler_Release_Notes.txt pkg/computeprof/computeprof
133%dir %{_libdir}/cuda/prof
134%dir %{_libdir}/cuda/prof/bin
135%attr(755,root,root) %{_bindir}/computeprof
136%attr(755,root,root) %{_libdir}/cuda/prof/bin/*
137%{_libdir}/cuda/prof/doc
138%endif
139%dir %{_libdir}/cuda/open64
140%dir %{_libdir}/cuda/open64/bin
141%dir %{_libdir}/cuda/open64/lib
142%attr(755,root,root) %{_libdir}/cuda/open64/bin/*
143%attr(755,root,root) %{_libdir}/cuda/open64/lib/*
144%attr(755,root,root) %{_libdir}/lib*.so
145%{_mandir}/man1/*
146%{_mandir}/man3/*
147
148%files libs
149%defattr(644,root,root,755)
150%attr(755,root,root) %ghost %{_libdir}/lib*.so.3
151%attr(755,root,root) %{_libdir}/lib*.so.*.*
This page took 0.071762 seconds and 4 git commands to generate.