]> git.pld-linux.org Git - packages/cryptsetup.git/blame - cryptsetup.spec
- libtoolize (fixes build with libtool 2.2)
[packages/cryptsetup.git] / cryptsetup.spec
CommitLineData
5eb10616
JB
1#
2# Conditonal build:
3%bcond_with static # link cryptsetup statically
4#
d7593791 5%define realname cryptsetup
2488c838 6Summary: LUKS for dm-crypt implemented in cryptsetup
29f5822a 7Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
6351d6a5 8Name: cryptsetup-luks
f5ec273c 9Version: 1.0.6
32ad2fb9 10Release: 2
d7593791 11License: GPL v2
6351d6a5 12Group: Base
d7593791 13Source0: http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
f5ec273c 14# Source0-md5: 00d452eb7a76e39f5749545d48934a10
5eb10616 15Patch1: %{name}-nostatic.patch
5616104c 16URL: http://luks.endorphin.org/
5fe93676
JB
17BuildRequires: autoconf
18BuildRequires: automake
0b90291e 19BuildRequires: device-mapper-devel
5fe93676 20BuildRequires: gettext-devel
0b90291e
JB
21BuildRequires: libgcrypt-devel >= 1.1.42
22BuildRequires: libselinux-devel
23BuildRequires: libsepol-devel
d172f920 24BuildRequires: libtool
0b90291e
JB
25BuildRequires: libuuid-devel
26BuildRequires: popt-devel
5eb10616
JB
27%if %{with static}
28BuildRequires: device-mapper-static >= 1.02.07
a6fd3218 29BuildRequires: libgcrypt-static >= 1.1.42
30BuildRequires: libgpg-error-static
31BuildRequires: libselinux-static
8d9e50de 32BuildRequires: libsepol-static
a6fd3218 33BuildRequires: libuuid-static
34BuildRequires: popt-static
5eb10616 35%endif
c0cc5702 36Provides: cryptsetup = %{version}
12cca230 37Obsoletes: cryptsetup
6351d6a5 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _sbindir /sbin
8bf4e8eb 41%define _noautoreqdep libcryptsetup.so.0
6351d6a5 42
43%description
6e98e6fb 44LUKS is the upcoming standard for Linux hard disk encryption. By
45providing a standard on-disk-format, it does not only facilitate
46compatibility among distributions, but also provide secure management
47of multiple user passwords. In contrast to existing solution, LUKS
48stores all setup necessary setup information in the partition header,
49enabling the user to transport or migrate his data seamlessly.
6351d6a5 50
6e98e6fb 51This package contains implementation of LUKS for dm-crypt implemented
52in cryptsetup.
6351d6a5 53
77f30028
JR
54%description -l pl.UTF-8
55LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
56Dostarczając standardowy format danych na dysku nie tylko ułatwia
57utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
58bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
59do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
60informacje o konfiguracji w nagłówku partycji, pozwalając
61użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
12cca230 62
77f30028 63Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
12cca230
JB
64cryptsetup.
65
6351d6a5 66%package devel
67Summary: Header files for cryptsetup library
29f5822a 68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
6351d6a5 69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: device-mapper-devel
72Requires: libgcrypt-devel >= 1.1.42
12cca230 73Obsoletes: cryptsetup-devel
6351d6a5 74
75%description devel
76Header files for cryptsetup library.
77
77f30028
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe biblioteki cryptsetup.
6351d6a5 80
81%package static
82Summary: Static cryptsetup library
29f5822a 83Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
6351d6a5 84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
fca9458b 86Obsoletes: cryptsetup-static
6351d6a5 87
88%description static
89Static version of cryptsetup library.
90
77f30028 91%description static -l pl.UTF-8
6351d6a5 92Statyczna wersja biblioteki cryptsetup.
93
94%prep
d7593791 95%setup -q -n %{realname}-%{version}
5eb10616 96%patch1 -p1
6351d6a5 97
98%build
8d9e50de 99%{__gettextize}
d7593791 100%{__libtoolize}
8d9e50de 101%{__aclocal} -I m4
102%{__autoconf}
d7593791 103%{__autoheader}
8d9e50de 104%{__automake}
a6fd3218 105%configure \
5eb10616
JB
106 --enable-static \
107 %{?with_static:--enable-static-cryptsetup}
6351d6a5 108%{__make}
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113%{__make} install \
114 DESTDIR=$RPM_BUILD_ROOT
115
116install -d $RPM_BUILD_ROOT/%{_lib}
d7593791
JB
117mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
118ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
6351d6a5 119 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
120
d7593791 121%find_lang %{realname}
6351d6a5 122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%post -p /sbin/ldconfig
127%postun -p /sbin/ldconfig
128
d7593791 129%files -f %{realname}.lang
6351d6a5 130%defattr(644,root,root,755)
d7593791 131%doc AUTHORS ChangeLog TODO
6351d6a5 132%attr(755,root,root) %{_sbindir}/cryptsetup
133%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
d7593791
JB
134%attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
135%{_mandir}/man8/cryptsetup.8*
6351d6a5 136
137%files devel
138%defattr(644,root,root,755)
139%attr(755,root,root) %{_libdir}/libcryptsetup.so
140%{_libdir}/libcryptsetup.la
d7593791 141%{_includedir}/libcryptsetup.h
6351d6a5 142
a6fd3218 143%files static
144%defattr(644,root,root,755)
145%{_libdir}/libcryptsetup.a
This page took 0.168802 seconds and 4 git commands to generate.