]> git.pld-linux.org Git - packages/cryptsetup.git/blame - cryptsetup.spec
- I think it was meant to be _noautoreqdep
[packages/cryptsetup.git] / cryptsetup.spec
CommitLineData
5eb10616
JB
1#
2# Conditonal build:
3%bcond_with static # link cryptsetup statically
4#
2488c838 5Summary: LUKS for dm-crypt implemented in cryptsetup
29f5822a 6Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
6351d6a5 7Name: cryptsetup-luks
e8d84c7d 8Version: 1.0.4
516a2b2d 9Release: 1
6351d6a5 10License: GPL
11Group: Base
12Source0: http://luks.endorphin.org/source/%{name}-%{version}.tar.bz2
e8d84c7d 13# Source0-md5: 156ae6b618438ee9feeddc6c2bdc4e94
5eb10616 14Patch1: %{name}-nostatic.patch
6351d6a5 15URL: http://luks.endorphin.org/about
5fe93676
JB
16BuildRequires: autoconf
17BuildRequires: automake
0b90291e 18BuildRequires: device-mapper-devel
5fe93676 19BuildRequires: gettext-devel
0b90291e
JB
20BuildRequires: libgcrypt-devel >= 1.1.42
21BuildRequires: libselinux-devel
22BuildRequires: libsepol-devel
23BuildRequires: libuuid-devel
24BuildRequires: popt-devel
e8d84c7d 25BuildRequires: libtool
5eb10616
JB
26%if %{with static}
27BuildRequires: device-mapper-static >= 1.02.07
a6fd3218 28BuildRequires: libgcrypt-static >= 1.1.42
29BuildRequires: libgpg-error-static
30BuildRequires: libselinux-static
8d9e50de 31BuildRequires: libsepol-static
a6fd3218 32BuildRequires: libuuid-static
33BuildRequires: popt-static
5eb10616 34%endif
12cca230 35Obsoletes: cryptsetup
6351d6a5 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define _sbindir /sbin
8bf4e8eb 39%define _noautoreqdep libcryptsetup.so.0
6351d6a5 40
41%description
6e98e6fb 42LUKS is the upcoming standard for Linux hard disk encryption. By
43providing a standard on-disk-format, it does not only facilitate
44compatibility among distributions, but also provide secure management
45of multiple user passwords. In contrast to existing solution, LUKS
46stores all setup necessary setup information in the partition header,
47enabling the user to transport or migrate his data seamlessly.
6351d6a5 48
6e98e6fb 49This package contains implementation of LUKS for dm-crypt implemented
50in cryptsetup.
6351d6a5 51
77f30028
JR
52%description -l pl.UTF-8
53LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
54Dostarczając standardowy format danych na dysku nie tylko ułatwia
55utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
56bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
57do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
58informacje o konfiguracji w nagłówku partycji, pozwalając
59użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
12cca230 60
77f30028 61Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
12cca230
JB
62cryptsetup.
63
6351d6a5 64%package devel
65Summary: Header files for cryptsetup library
29f5822a 66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
6351d6a5 67Group: Development/Libraries
68Requires: %{name} = %{version}-%{release}
69Requires: device-mapper-devel
70Requires: libgcrypt-devel >= 1.1.42
12cca230 71Obsoletes: cryptsetup-devel
6351d6a5 72
73%description devel
74Header files for cryptsetup library.
75
77f30028
JR
76%description devel -l pl.UTF-8
77Pliki nagłówkowe biblioteki cryptsetup.
6351d6a5 78
79%package static
80Summary: Static cryptsetup library
29f5822a 81Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
6351d6a5 82Group: Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
fca9458b 84Obsoletes: cryptsetup-static
6351d6a5 85
86%description static
87Static version of cryptsetup library.
88
77f30028 89%description static -l pl.UTF-8
6351d6a5 90Statyczna wersja biblioteki cryptsetup.
91
92%prep
93%setup -q
5eb10616 94%patch1 -p1
6351d6a5 95
96%build
8d9e50de 97%{__gettextize}
5fe93676 98%{__autoheader}
8d9e50de 99%{__aclocal} -I m4
100%{__autoconf}
101%{__automake}
a6fd3218 102%configure \
5eb10616
JB
103 --enable-static \
104 %{?with_static:--enable-static-cryptsetup}
6351d6a5 105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110%{__make} install \
111 DESTDIR=$RPM_BUILD_ROOT
112
113install -d $RPM_BUILD_ROOT/%{_lib}
114mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
115ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libcryptsetup.so.*.*.*) \
116 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
117
118%find_lang %{name}
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%files -f %{name}.lang
127%defattr(644,root,root,755)
128%doc ChangeLog
129%attr(755,root,root) %{_sbindir}/cryptsetup
130%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
131%{_mandir}/man8/*
132
133%files devel
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_libdir}/libcryptsetup.so
136%{_libdir}/libcryptsetup.la
137%{_includedir}/*.h
138
a6fd3218 139%files static
140%defattr(644,root,root,755)
141%{_libdir}/libcryptsetup.a
This page took 0.123571 seconds and 4 git commands to generate.