]> git.pld-linux.org Git - packages/cryptsetup-luks.git/blame - cryptsetup-luks.spec
- patrys: udevsettle was deprecated a year ago
[packages/cryptsetup-luks.git] / cryptsetup-luks.spec
CommitLineData
c769990d
JB
1#
2# Conditonal build:
44e18714 3%bcond_without initrd # don't build initrd version
c769990d 4#
ab903cbb 5%define realname cryptsetup
c25a01c4 6Summary: LUKS for dm-crypt implemented in cryptsetup
f00185e9 7Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
00a57b4e 8Name: cryptsetup-luks
90eb1525 9Version: 1.0.6
44e18714 10Release: 4
ab903cbb 11License: GPL v2
00a57b4e 12Group: Base
ab903cbb 13Source0: http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
90eb1525 14# Source0-md5: 00d452eb7a76e39f5749545d48934a10
c769990d 15Patch1: %{name}-nostatic.patch
8d48ad54 16URL: http://luks.endorphin.org/
6707f1d7
JB
17BuildRequires: autoconf
18BuildRequires: automake
e6ecff5e 19BuildRequires: device-mapper-devel
6707f1d7 20BuildRequires: gettext-devel
e6ecff5e
JB
21BuildRequires: libgcrypt-devel >= 1.1.42
22BuildRequires: libselinux-devel
23BuildRequires: libsepol-devel
81a6ed91 24BuildRequires: libtool
e6ecff5e
JB
25BuildRequires: libuuid-devel
26BuildRequires: popt-devel
44e18714 27%if %{with initrd}
c769990d 28BuildRequires: device-mapper-static >= 1.02.07
24fff120 29BuildRequires: libgcrypt-static >= 1.1.42
30BuildRequires: libgpg-error-static
31BuildRequires: libselinux-static
4ad6edfa 32BuildRequires: libsepol-static
24fff120 33BuildRequires: libuuid-static
34BuildRequires: popt-static
c769990d 35%endif
ad703024 36Provides: cryptsetup = %{version}
b08008aa 37Obsoletes: cryptsetup
00a57b4e 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _sbindir /sbin
e4ea12be 41%define _noautoreqdep libcryptsetup.so.0
00a57b4e 42
43%description
d23e9766 44LUKS is the upcoming standard for Linux hard disk encryption. By
45providing a standard on-disk-format, it does not only facilitate
46compatibility among distributions, but also provide secure management
47of multiple user passwords. In contrast to existing solution, LUKS
48stores all setup necessary setup information in the partition header,
49enabling the user to transport or migrate his data seamlessly.
00a57b4e 50
d23e9766 51This package contains implementation of LUKS for dm-crypt implemented
52in cryptsetup.
00a57b4e 53
8a316dbb
JR
54%description -l pl.UTF-8
55LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
56Dostarczając standardowy format danych na dysku nie tylko ułatwia
57utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
58bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
59do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
60informacje o konfiguracji w nagłówku partycji, pozwalając
61użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
b08008aa 62
8a316dbb 63Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
b08008aa
JB
64cryptsetup.
65
00a57b4e 66%package devel
67Summary: Header files for cryptsetup library
f00185e9 68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
00a57b4e 69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: device-mapper-devel
72Requires: libgcrypt-devel >= 1.1.42
b08008aa 73Obsoletes: cryptsetup-devel
00a57b4e 74
75%description devel
76Header files for cryptsetup library.
77
8a316dbb
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe biblioteki cryptsetup.
00a57b4e 80
81%package static
82Summary: Static cryptsetup library
f00185e9 83Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
00a57b4e 84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
689fc456 86Obsoletes: cryptsetup-static
00a57b4e 87
88%description static
89Static version of cryptsetup library.
90
8a316dbb 91%description static -l pl.UTF-8
00a57b4e 92Statyczna wersja biblioteki cryptsetup.
93
44e18714
ER
94%package initrd
95Summary: LUKS for dm-crypt implemented in cryptsetup - initrd version
96Group: Base
97
98%description initrd
99This package contains implementation of LUKS for dm-crypt implemented
100in cryptsetup - staticaly linked for initrd.
101
00a57b4e 102%prep
ab903cbb 103%setup -q -n %{realname}-%{version}
c769990d 104%patch1 -p1
00a57b4e 105
106%build
4ad6edfa 107%{__gettextize}
ab903cbb 108%{__libtoolize}
4ad6edfa 109%{__aclocal} -I m4
110%{__autoconf}
ab903cbb 111%{__autoheader}
4ad6edfa 112%{__automake}
44e18714
ER
113
114%if %{with initrd}
24fff120 115%configure \
2c80e984 116 --disable-shared-library \
c769990d 117 --enable-static \
2c80e984
ER
118 --enable-static-cryptsetup \
119 --disable-nls
44e18714
ER
120%{__make}
121mv src/cryptsetup cryptsetup-initrd
122%{__make} clean
123%endif
124
125%configure \
126 --enable-static
00a57b4e 127%{__make}
128
129%install
130rm -rf $RPM_BUILD_ROOT
131
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
135install -d $RPM_BUILD_ROOT/%{_lib}
ab903cbb
JB
136mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
137ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
00a57b4e 138 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
139
44e18714
ER
140%if %{with initrd}
141install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
142%endif
143
ab903cbb 144%find_lang %{realname}
00a57b4e 145
146%clean
147rm -rf $RPM_BUILD_ROOT
148
149%post -p /sbin/ldconfig
150%postun -p /sbin/ldconfig
151
ab903cbb 152%files -f %{realname}.lang
00a57b4e 153%defattr(644,root,root,755)
ab903cbb 154%doc AUTHORS ChangeLog TODO
00a57b4e 155%attr(755,root,root) %{_sbindir}/cryptsetup
156%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
ab903cbb
JB
157%attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
158%{_mandir}/man8/cryptsetup.8*
00a57b4e 159
160%files devel
161%defattr(644,root,root,755)
162%attr(755,root,root) %{_libdir}/libcryptsetup.so
163%{_libdir}/libcryptsetup.la
ab903cbb 164%{_includedir}/libcryptsetup.h
00a57b4e 165
24fff120 166%files static
167%defattr(644,root,root,755)
168%{_libdir}/libcryptsetup.a
44e18714
ER
169
170%if %{with initrd}
171%files initrd
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_sbindir}/cryptsetup-initrd
174%endif
This page took 0.111721 seconds and 4 git commands to generate.