]> git.pld-linux.org Git - packages/cryptopp.git/commitdiff
- autoize cryptopp build
authortommat <tommat@pld-linux.org>
Tue, 12 Feb 2008 09:02:34 +0000 (09:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cryptopp-autotools.patch -> 1.1

cryptopp-autotools.patch [new file with mode: 0644]

diff --git a/cryptopp-autotools.patch b/cryptopp-autotools.patch
new file mode 100644 (file)
index 0000000..168bbc4
--- /dev/null
@@ -0,0 +1,356 @@
+diff -crN crypto52.orig/GNUmakefile.am crypto52/GNUmakefile.am
+*** crypto52.orig/GNUmakefile.am       1970-01-01 01:00:00.000000000 +0100
+--- crypto52/GNUmakefile.am    2004-07-24 14:14:34.231122920 +0200
+***************
+*** 0 ****
+--- 1,331 ----
++ lib_LTLIBRARIES = libcryptopp.la
++ libcryptopp_la_LDFLAGS = -version-info 5:5:2
++ libcryptopp_la_LIBADD = -lpthread
++ libcryptopp_la_SOURCES =  \
++      3way.cpp \
++      adler32.cpp \
++      algebra.cpp \
++      algparam.cpp \
++      arc4.cpp \
++      asn.cpp \
++      base32.cpp \
++      base64.cpp \
++      basecode.cpp \
++      bfinit.cpp \
++      blowfish.cpp \
++      blumshub.cpp \
++      camellia.cpp \
++      cast.cpp \
++      casts.cpp \
++      cbcmac.cpp \
++      channels.cpp \
++      cpu.cpp \
++      crc.cpp \
++      cryptlib.cpp \
++      cryptlib_bds.cpp \
++      default.cpp \
++      des.cpp \
++      dessp.cpp \
++      dh.cpp \
++      dh2.cpp \
++      dll.cpp \
++      dsa.cpp \
++      ec2n.cpp \
++      eccrypto.cpp \
++      ecp.cpp \
++      elgamal.cpp \
++      emsa2.cpp \
++      eprecomp.cpp \
++      esign.cpp \
++      files.cpp \
++      filters.cpp \
++      fips140.cpp \
++      fipstest.cpp \
++      gf256.cpp \
++      gf2_32.cpp \
++      gf2n.cpp \
++      gfpcrypt.cpp \
++      gost.cpp \
++      gzip.cpp \
++      hex.cpp \
++      hmac.cpp \
++      hrtimer.cpp \
++      ida.cpp \
++      idea.cpp \
++      integer.cpp \
++      iterhash.cpp \
++      luc.cpp \
++      mars.cpp \
++      marss.cpp \
++      md2.cpp \
++      md4.cpp \
++      md5.cpp \
++      misc.cpp \
++      modes.cpp \
++      mqueue.cpp \
++      mqv.cpp \
++      nbtheory.cpp \
++      network.cpp \
++      oaep.cpp \
++      osrng.cpp \
++      panama.cpp \
++      pch.cpp \
++      pkcspad.cpp \
++      polynomi.cpp \
++      pssr.cpp \
++      pubkey.cpp \
++      queue.cpp \
++      rabin.cpp \
++      randpool.cpp \
++      rc2.cpp \
++      rc5.cpp \
++      rc6.cpp \
++      rdtables.cpp \
++      rijndael.cpp \
++      ripemd.cpp \
++      rng.cpp \
++      rsa.cpp \
++      rw.cpp \
++      safer.cpp \
++      salsa.cpp \
++      seal.cpp \
++      serpent.cpp \
++      sha.cpp \
++      shacal2.cpp \
++      shark.cpp \
++      sharkbox.cpp \
++      simple.cpp \
++      skipjack.cpp \
++      socketft.cpp \
++      sosemanuk.cpp \
++      square.cpp \
++      squaretb.cpp \
++      strciphr.cpp \
++      tea.cpp \
++      tftables.cpp \
++      tiger.cpp \
++      tigertab.cpp \
++      trdlocal.cpp \
++      ttmac.cpp \
++      twofish.cpp \
++      wait.cpp \
++      wake.cpp \
++      whrlpool.cpp \
++      winpipes.cpp \
++      vmac.cpp \
++      xtr.cpp \
++      xtrcrypt.cpp \
++      zdeflate.cpp \
++      zinflate.cpp \
++      zlib.cpp
++ 
++ pkginclude_HEADERS = \
++      3way.h \
++      adler32.h \
++      aes.h \
++      algebra.h \
++      algparam.h \
++      arc4.h \
++      argnames.h \
++      asn.h \
++      base32.h \
++      base64.h \
++      basecode.h \
++      bench.h \
++      blowfish.h \
++      blumshub.h \
++      camellia.h \
++      cast.h \
++      cbcmac.h \
++      channels.h \
++      config.h \
++      cpu.h \
++      crc.h \
++      cryptlib.h \
++      default.h \
++      des.h \
++      dh.h \
++      dh2.h \
++      dll.h \
++      dmac.h \
++      dsa.h \
++      ec2n.h \
++      eccrypto.h \
++      ecp.h \
++      elgamal.h \
++      emsa2.h \
++      eprecomp.h \
++      esign.h \
++      factory.h \
++      files.h \
++      filters.h \
++      fips140.h \
++      fltrimpl.h \
++      gf256.h \
++      gf2_32.h \
++      gf2n.h \
++      gfpcrypt.h \
++      gost.h \
++      gzip.h \
++      hex.h \
++      hmac.h \
++      hrtimer.h \
++      ida.h \
++      idea.h \
++      integer.h \
++      iterhash.h \
++      lubyrack.h \
++      luc.h \
++      mars.h \
++      md2.h \
++      md4.h \
++      md5.h \
++      mdc.h \
++      misc.h \
++      modarith.h \
++      modes.h \
++      modexppc.h \
++      mqueue.h \
++      mqv.h \
++      nbtheory.h \
++      network.h \
++      nr.h \
++      oaep.h \
++      oids.h \
++      osrng.h \
++      panama.h \
++      pch.h \
++      pkcspad.h \
++      polynomi.h \
++      pssr.h \
++      pubkey.h \
++      pwdbased.h \
++      queue.h \
++      rabin.h \
++      randpool.h \
++      rc2.h \
++      rc5.h \
++      rc6.h \
++      resource.h \
++      rijndael.h \
++      ripemd.h \
++      rng.h \
++      rsa.h \
++      rw.h \
++      safer.h \
++      salsa.h \
++      seal.h \
++      secblock.h \
++      seckey.h \
++      serpent.h \
++      serpentp.h \
++      sha.h \
++      shacal2.h \
++      shark.h \
++      simple.h \
++      skipjack.h \
++      smartptr.h \
++      socketft.h \
++      sosemanuk.h \
++      square.h \
++      stdcpp.h \
++      strciphr.h \
++      tea.h \
++      tiger.h \
++      trdlocal.h \
++      trunhash.h \
++      ttmac.h \
++      twofish.h \
++      validate.h \
++      wait.h \
++      wake.h \
++      whrlpool.h \
++      winpipes.h \
++      words.h \
++      vmac.h \
++      xtr.h \
++      xtrcrypt.h \
++      zdeflate.h \
++      zinflate.h \
++      zlib.h
++ 
++ pkgdata_DATA = \
++      3desval.dat \
++      3wayval.dat \
++      camellia.dat \
++      cast128v.dat \
++      cast256v.dat \
++      descert.dat \
++      dh1024.dat \
++      dh2048.dat \
++      dlie1024.dat \
++      dlie2048.dat \
++      dsa1024b.dat \
++      dsa1024.dat \
++      dsa512.dat \
++      elgc1024.dat \
++      esig1023.dat \
++      esig1536.dat \
++      esig2046.dat \
++      gostval.dat \
++      ideaval.dat \
++      luc1024.dat \
++      luc2048.dat \
++      lucc1024.dat \
++      lucc512.dat \
++      lucd1024.dat \
++      lucd512.dat \
++      lucs1024.dat \
++      lucs512.dat \
++      marsval.dat \
++      mqv1024.dat \
++      mqv2048.dat \
++      nr1024.dat \
++      nr2048.dat \
++      rabi1024.dat \
++      rabi2048.dat \
++      rc2val.dat \
++      rc5val.dat \
++      rc6val.dat \
++      rijndael.dat \
++      rsa1024.dat \
++      rsa2048.dat \
++      rsa400pb.dat \
++      rsa400pv.dat \
++      rsa512a.dat \
++      rw1024.dat \
++      rw2048.dat \
++      saferval.dat \
++      serpentv.dat \
++      shacal2v.dat \
++      sharkval.dat \
++      skipjack.dat \
++      squareva.dat \
++      twofishv.dat \
++      usage.dat \
++      xtrdh171.dat \
++      xtrdh342.dat
++ 
++ bin_PROGRAMS = cryptest
++ cryptest_SOURCES = \
++      bench.cpp \
++      bench2.cpp \
++      test.cpp \
++      validat1.cpp \
++      validat2.cpp \
++      validat3.cpp \
++      datatest.cpp \
++      regtest.cpp \
++      fipsalgt.cpp \
++      dlltest.cpp
++      
++ nodist_cryptest_SOURCES = adhoc.cpp
++ CLEANFILES = adhoc.cpp
++ cryptest_LDADD = -lcryptopp
++ 
++ adhoc.cpp: GNUmakefile
++      if test -f adhoc.cpp; then      \
++        touch adhoc.cpp;              \
++      else                            \
++        cp adhoc.cpp.proto adhoc.cpp; \
++      fi
+diff -crN crypto52.orig/configure.in crypto52/configure.in
+*** crypto52.orig/configure.in 1970-01-01 01:00:00.000000000 +0100
+--- crypto52/configure.in      2004-07-14 23:18:44.000000000 +0200
+***************
+*** 0 ****
+--- 1,13 ----
++ AC_INIT([cryptopp], 5.5)
++ AC_CONFIG_SRCDIR(configure.in)
++ AM_INIT_AUTOMAKE([no-define])
++ AM_CONFIG_HEADER([local.h])
++ AM_MAINTAINER_MODE
++ 
++ AC_PROG_CXX
++ AC_PROG_LIBTOOL
++ AC_PROG_INSTALL
++ 
++ AC_C_BIGENDIAN
++ 
++ AC_OUTPUT(GNUmakefile)
This page took 0.141347 seconds and 4 git commands to generate.