]> git.pld-linux.org Git - packages/cryptopp.git/blob - cryptopp.spec
- updated to 8.9.0
[packages/cryptopp.git] / cryptopp.spec
1 #
2 # Conditional build:
3 %bcond_without  asm             # disable x86 assembly code
4 %bcond_without  tests           # build without tests
5
6 %define         orig_ver        564
7 Summary:        Cryptopp Library - a free C++ class library of cryptographic schemes
8 Summary(pl.UTF-8):      Cryptopp - biblioteka klas C++ dostarczająca narzędzia do kryptografii
9 Name:           cryptopp
10 Version:        5.6.4
11 Release:        1
12 License:        Boost v1.0 (BSD-like)
13 Group:          Libraries
14 Source0:        http://downloads.sourceforge.net/cryptopp/%{name}%{orig_ver}.zip
15 # Source0-md5:  4ee7e5cdd4a45a14756c169eaf2a77fc
16 Source1:        %{name}.pc
17 Patch0:         %{name}-libdir.patch
18 URL:            http://www.cryptopp.com/
19 BuildRequires:  cmake >= 2.8.5
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  unzip
22 Obsoletes:      cryptopp-progs
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Cryptopp Library is a free C++ class library of cryptographic schemes.
27
28 %description -l pl.UTF-8
29 Cryptopp jest biblioteką klas C++ dostarczającą narzędzia do
30 kryptografii.
31
32 %package devel
33 Summary:        Files for development of applications which will use Cryptopp
34 Summary(pl.UTF-8):      Pliki do tworzenia aplikacji używających Cryptopp
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Files for development of applications which will use Cryptopp.
40
41 %description devel -l pl.UTF-8
42 Pliki do tworzenia aplikacji używających Cryptopp.
43
44 %package static
45 Summary:        Static Cryptopp library
46 Summary(pl.UTF-8):      Statyczna biblioteka Cryptopp
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static Cryptopp library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka Cryptopp.
55
56 %prep
57 %setup -q -c
58 %patch0 -p1
59
60 %build
61 install -d build
62 cd build
63 %cmake .. \
64         %{!?with_asm:-DDISABLE_ASM=ON}
65
66 %{__make}
67
68 %if %{with tests}
69 ctest -V
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -C build install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
79 sed -e "
80         s|@PREFIX@|%{_prefix}|g
81         s|@LIBDIR@|%{_libdir}|g
82         s|@VERSION@|%{version}|g
83 " %{SOURCE1} > $RPM_BUILD_ROOT%{_pkgconfigdir}/cryptopp.pc
84
85 # tests
86 %{__rm} $RPM_BUILD_ROOT%{_bindir}/cryptest.exe
87 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cryptopp/Test{Data,Vectors}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc License.txt Readme.txt
98 %attr(755,root,root) %{_libdir}/libcryptopp.so.5.6
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libcryptopp.so
103 %{_includedir}/cryptopp
104 %{_pkgconfigdir}/cryptopp.pc
105 %{_libdir}/cmake/cryptopp
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libcryptopp.a
This page took 0.064108 seconds and 3 git commands to generate.