]> git.pld-linux.org Git - packages/crossz80-binutils.git/commitdiff
- new
authorwitekfl <witekfl@pld-linux.org>
Sat, 4 Feb 2012 07:38:28 +0000 (07:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- reason: to be able to build the spectranet firmware
- names of the binaries the same as in Debian

Changed files:
    crossz80-binutils.spec -> 1.1
    tc-z80.c.diff -> 1.1

crossz80-binutils.spec [new file with mode: 0644]
tc-z80.c.diff [new file with mode: 0644]

diff --git a/crossz80-binutils.spec b/crossz80-binutils.spec
new file mode 100644 (file)
index 0000000..7835938
--- /dev/null
@@ -0,0 +1,126 @@
+Summary:       Cross Z80 GNU binary utility development utilities - binutils
+Summary(es.UTF-8):     Utilitarios para desarrollo de binarios de la GNU - Z80 binutils
+Summary(fr.UTF-8):     Utilitaires de développement binaire de GNU - Z80 binutils
+Summary(pl.UTF-8):     Skrośne narzędzia programistyczne GNU dla Z80 - binutils
+Summary(pt_BR.UTF-8):  Utilitários para desenvolvimento de binários da GNU - Z80 binutils
+Summary(tr.UTF-8):     GNU geliştirme araçları - Z80 binutils
+Name:          crossz80-binutils
+Version:       2.22
+Release:       1
+License:       GPL
+Group:         Development/Tools
+Source0:       ftp://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
+# Source0-md5: ee0f10756c84979622b992a4a61ea3f5
+Patch0:                tc-z80.c.diff
+URL:           http://sources.redhat.com/binutils/
+BuildRequires: automake
+BuildRequires: bash
+BuildRequires: bison
+BuildRequires: flex
+BuildRequires: gettext-devel
+BuildRequires: perl-tools-pod
+BuildRequires: texinfo
+%ifarch sparc sparc32
+BuildRequires: sparc32
+%endif
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                target          z80-unknown-coff
+%define                arch            %{_prefix}/%{target}
+
+%description
+Binutils is a collection of binary utilities, including:
+- ar - create, modify and extract from archives,
+- nm - lists symbols from object files,
+- objcopy - copy and translate object files,
+- objdump - display information from object files,
+- ranlib - generate an index for the contents of an archive,
+- size - list the section sizes of an object or archive file,
+- strings - list printable strings from files,
+- strip - discard symbols,
+- c++filt - a filter for demangling encoded C++ symbols,
+- addr2line - convert addresses to file and line,
+- nlmconv - convert object code into an NLM.
+
+This package contains the cross version for Z80.
+
+%description -l pl.UTF-8
+Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
+programów. Znajdują się tutaj między innymi assembler, konsolidator
+(linker), a także inne narzędzia do manipulowania binarnymi plikami
+programów i bibliotek.
+
+Ten pakiet zawiera wersję skrośną generującą kod dla procesora Z80.
+
+%prep
+%setup -q -n binutils-%{version}
+%patch0 -p1
+
+%build
+cp /usr/share/automake/config.sub .
+
+# ldscripts won't be generated properly if SHELL is not bash...
+CFLAGS="%{rpmcflags}" \
+LDFLAGS="%{rpmldflags}" \
+CONFIG_SHELL="/bin/bash" \
+%ifarch sparc
+sparc32 \
+%endif
+./configure \
+       --disable-shared \
+       --prefix=%{_prefix} \
+       --libdir=%{_libdir} \
+       --mandir=%{_mandir} \
+       --infodir=%{_infodir} \
+       --host=%{_target_platform} \
+       --build=%{_target_platform} \
+       --target=%{target} \
+       --with-gnu-ld \
+       --with-gnu-as \
+       --enable-install-libbfd
+
+# We have to regenerate headers after patching.
+%{__make} configure-host \
+       tooldir=%{_prefix} \
+       EXEEXT=""
+
+%{__make} -C bfd headers \
+       tooldir=%{_prefix} \
+       EXEEXT=""
+
+%{__make} all \
+       tooldir=%{_prefix} \
+       EXEEXT=""
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_prefix}
+
+%{__make} install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       infodir=$RPM_BUILD_ROOT%{_infodir} \
+       libdir=$RPM_BUILD_ROOT%{_libdir}
+
+# remove these man pages unless we cross-build for win*/netware platforms.
+# however, this should be done in Makefiles.
+rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
+
+rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/LC_MESSAGES/*.mo
+rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
+rm -rf $RPM_BUILD_ROOT%{_infodir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README
+%attr(755,root,root) %{_bindir}/%{target}-*
+%dir %{arch}
+%dir %{arch}/bin
+%attr(755,root,root) %{arch}/bin/*
+%dir %{arch}/lib
+%dir %{arch}/lib/*
+%{arch}/lib/*/*
+%{_mandir}/man?/%{target}-*
diff --git a/tc-z80.c.diff b/tc-z80.c.diff
new file mode 100644 (file)
index 0000000..07ef41b
--- /dev/null
@@ -0,0 +1,10 @@
+--- binutils-2.22/gas/config/tc-z80.c.orig     2011-12-23 17:17:55.860988588 +0100
++++ binutils-2.22/gas/config/tc-z80.c  2011-12-23 17:17:59.969093857 +0100
+@@ -702,6 +702,7 @@
+       fixp = fix_new_exp (frag_now, p - frag_now->fr_literal, 1, val,
+                         (r_type == BFD_RELOC_8_PCREL) ? TRUE : FALSE, r_type);
+       /* FIXME : Process constant offsets immediately.  */
++      (void)fixp;
+     }
+ }
This page took 0.083826 seconds and 4 git commands to generate.