]> git.pld-linux.org Git - packages/crossppc64-gcc.git/commitdiff
- my fixes for crossbuilds. auto/th/crossppc-gcc-4_0_2-2
authorPaweł Sikora <pluto@pld-linux.org>
Sun, 8 Jan 2006 19:02:17 +0000 (19:02 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-pr25672.patch -> 1.1
    gcc-pr25715.patch -> 1.1

gcc-pr25672.patch [new file with mode: 0644]
gcc-pr25715.patch [new file with mode: 0644]

diff --git a/gcc-pr25672.patch b/gcc-pr25672.patch
new file mode 100644 (file)
index 0000000..f97794d
--- /dev/null
@@ -0,0 +1,14 @@
+--- gcc-4.1-20060106/Makefile.in.orig  2005-12-15 15:02:02.000000000 +0100
++++ gcc-4.1-20060106/Makefile.in       2006-01-08 19:27:18.406458250 +0100
+@@ -329,9 +329,9 @@
+ # CFLAGS will be just -g.  We want to ensure that TARGET libraries
+ # (which we know are built with gcc) are built with optimizations so
+ # prepend -O2 when setting CFLAGS_FOR_TARGET.
+-CFLAGS_FOR_TARGET = -O2 $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
++CFLAGS_FOR_TARGET = -O2 $(SYSROOT_CFLAGS_FOR_TARGET)
+ SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
+-CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
++CXXFLAGS_FOR_TARGET = -O2 $(SYSROOT_CFLAGS_FOR_TARGET)
+ LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)
+ LIBCXXFLAGS_FOR_TARGET = $(CXXFLAGS_FOR_TARGET) -fno-implicit-templates
+ LDFLAGS_FOR_TARGET = 
diff --git a/gcc-pr25715.patch b/gcc-pr25715.patch
new file mode 100644 (file)
index 0000000..cf01ad0
--- /dev/null
@@ -0,0 +1,19 @@
+In file included from ../../gcc/libgcc2.c:43:
+../../gcc/libgcc2.h:214:3: error: #error "expand the table"
+../../gcc/libgcc2.c: In function '__mulhi3':
+../../gcc/libgcc2.c:514: error: 'BITS_PER_UNIT' undeclared (first use in this function)
+../../gcc/libgcc2.c:514: error: (Each undeclared identifier is reported only once
+../../gcc/libgcc2.c:514: error: for each function it appears in.)
+make[2]: *** [libgcc/./_muldi3.o] Error 1
+
+--- gcc-4.1-20060106/gcc/mkconfig.sh.orig      2005-06-25 04:02:01.000000000 +0200
++++ gcc-4.1-20060106/gcc/mkconfig.sh   2006-01-08 19:41:26.003429750 +0100
+@@ -64,7 +64,7 @@
+       ;;
+     esac
+     if [ $# -ge 1 ]; then
+-      echo '#ifdef IN_GCC' >> ${output}T
++      echo '#if defined(IN_GCC) || defined(IN_LIBGCC2)' >> ${output}T
+       for file in "$@"; do
+           echo "# include \"$file\"" >> ${output}T
+       done
This page took 0.064254 seconds and 4 git commands to generate.